LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 07-09-2006, 08:07 AM   #1
hungrigerhaifisch
Member
 
Registered: Aug 2005
Distribution: Arch Linux
Posts: 91

Rep: Reputation: 15
Unhappy Debian-amd64 : Xorg & Ati's fglrx


I'm reposting my initial Post:
http://www.linuxquestions.org/questi...d.php?t=457707
here, because I'm receiving no feedback

I'm trying to get ati's driver to work with my radeon 9800.
I'm on Debian-amd64, running Xorg 7.0
I've been following the steps described here: http://wiki.cchtml.com/index.php/Deb...allation_Guide
By tweaking some dependencys I was able to install the debs that ati's installer generates.
I then went and built the fglrx-module using module-assistant

Code:
lsmod | grep fglrx 
fglrx 444404 0
shows that it is loaded. However, X refuses to start, claiming

Code:
...
(II) LoadModule: "fglrx" 
(WW) Warning, couldn't open module fglrx 
(II) UnloadModule: "fglrx" 
(EE) Failed to load module "fglrx" (module does not exist, 0) 
... 
(EE) No drivers available.
Any insights on this board ?
 
Old 07-09-2006, 08:15 AM   #2
Ephracis
Senior Member
 
Registered: Sep 2004
Location: Sweden
Distribution: Ubuntu, Debian
Posts: 1,109

Rep: Reputation: 49
Did fglrxinfo work for you? Otherwise you may need to symlink the driver into X's module directory.

It seems that xorg can't find your fglrx module. Check for it in /usr/lib/xorg/modules/drivers, it should be named something like fglrx_drv.so

If you are using xorg >= 7.0 you should be able to just
apt-get install xserver-xorg-video-ati
and the module should be there for you.
 
Old 07-09-2006, 08:34 AM   #3
hungrigerhaifisch
Member
 
Registered: Aug 2005
Distribution: Arch Linux
Posts: 91

Original Poster
Rep: Reputation: 15
Unhappy

Thanks for the fast reply...

EDIT:

Ok,
first I double checked, and there are no prebuilt fglrx-packages availible. The xserver-xorg-video-ati package of course is, in fact I'm currently using it. It lacks dri support for my card (Radeon 9800), thats why I'm trying to get ati's driver to work.

fglrxinfo, gave me an error about som RGB-surface not being found, but my guess is, that it does so because I'm not actually running the fglrx-driver.
I also checked /usr/lib/xorg/modules/drivers/ for a fglrx_drv.so - of course none existed.
After searching around for a while, I discovered that the ati-generated debs are installing their files into /usr/X11R6/libs. I then attempted to manually copy the files into their respective subdirs under /usr/lib. Of course the xserver died on me, this time however, it gave me following message:
Code:
...
(II) LoadModule: "fglrx"
(II) Loading /usr/lib/xorg/modules/drivers/fglrx_drv.o
(II) Module fglrx: vendor="FireGL - ATI Technologies Inc."
        compiled for 4.3.0.1, module version = 8.26.18
        Module class: XFree86 Video Driver
        ABI class: XFree86 Video Driver, version 0.6
[R200Setup] X version mismatch - detected X.org 7.0.0.0, required XFree86 4.3.0$
(II) UnloadModule: "fglrx"
(II) Unloading /usr/lib/xorg/modules/drivers/fglrx_drv.o
(EE) Failed to load module "fglrx" (module requirement mismatch, 0)
...
So it seems I'm a dumb ass, and downloaded the wrong package from ati's website...well
Quote:
ATI Driver Installer Version: 8.26.18
this is what I downloaded, and as stated above, I modified one of the debs, that this 'installer' generates, and again to quote ati (the 'control-file' from their deb)
Quote:
Depends: libc6 (>= 2.3.5-1), libstdc++5 (>= 1:3.3.4-1), libx11-6, libxext6, libxrandr2, libxrender1, xserver-xorg (>= 7.0.0), xserver-xorg (<< 7.0.22)
Now would somebody explain how this correlates to the xserver error posted obove???
I would be truly thankfull ... Help me!

EDIT AGAIN:
Quote:
xserver-xorg (<< 7.0.22) actually reads xserver-xorg(<< 7.0.99)
I modified the line to be able to install it.

Last edited by hungrigerhaifisch; 07-09-2006 at 12:39 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Debian-amd64 : Xorg & Ati's fglrx hungrigerhaifisch Debian 4 07-08-2006 01:29 PM
ati's latest fglrx driver fglrx_4_3_0-8.10.19-1 crashes redflo Linux - Hardware 1 03-06-2005 02:50 AM
XOrg-6.8.1 problem with ATI's fglrx-8.8.25 driver??? ginobili_20 Linux From Scratch 4 02-16-2005 01:57 PM
ATI's fglrx kernel 2.6.9 and X.org 6.8.1 electronique Slackware 20 02-01-2005 04:11 PM
Yet another issue with ati's fglrx, X and 3D emu_123 Linux - Hardware 5 01-18-2005 06:15 PM


All times are GMT -5. The time now is 09:40 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration