LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 11-14-2007, 01:05 AM   #1
cybermatthieu
LQ Newbie
 
Registered: Feb 2006
Posts: 5

Rep: Reputation: 0
Debian Alsa configuration snd_emu10k1


Hi,
I'm having some troubles with alsa. To start off my card is an Creative Labs SB Audigy. I got sound with totem and pidgin, but xmms gives me this error :

Code:
Please check that:
Your soundcard is configured properly
You have the correct output plugin selected
No other program is blocking the soundcard
And in the console I get :

Code:
ALSA lib confmisc.c:1286:(snd_func_refer) Unable to find definition 'defaults.pcm.dmix.device'
ALSA lib conf.c:3510:(_snd_config_evaluate) function snd_func_refer returned error: No such file or directory
ALSA lib conf.c:3982:(snd_config_expand) Evaluate error: No such file or directory
ALSA lib pcm.c:2144:(snd_pcm_open_noupdate) Unknown PCM default

** WARNING **: alsa_setup(): Failed to open pcm device (default): No such file or directory

I can get sound out of xmms only if I select the oss plugin, I was using alsa in xmms before...

An other problem that I have, is that tremulous has no sound.. Sad When I run tremulous from a console I get this message:

Code:
------ Initializing Sound ------
Initializing SDL audio driver...
ALSA lib confmisc.c:1286:(snd_func_refer) Unable to find definition 'defaults.pcm.dmix.device'
ALSA lib conf.c:3510:(_snd_config_evaluate) function snd_func_refer returned error: No such file or directory
ALSA lib conf.c:3982:(snd_config_expand) Evaluate error: No such file or directory
ALSA lib pcm.c:2144:(snd_pcm_open_noupdate) Unknown PCM default
SDL audio driver is "(UNKNOWN)".
SDL_OpenAudio() failed: No available audio device
Sound intialization failed.
--------------------------------

So I google a bit to find info about asound for SDL config... When I try asoundconf list I get no card.

Also in gnome sound preferences, I get an error if I try to test the sound playback for the sound event, music and movies, audio conferencing with alsa but oss is ok... Here's the error I get :

Code:
audiotestsrc wave=sine freq=512 ! audioconvert ! audioresample ! gconfaudiosink: Internal GStreamer error: state change failed.  Please file a bug at http://bugzilla.gnome.org/enter_bug.cgi?product=GStreamer.

Here's what I've done so far:
put "snd_emu10k1" in /etc/modules

added these two lines in

Code:
options snd_hda_intel index=-2
options snd_emu10k1 index=0

So that my creative card is loaded and not the onboard card.

I've used alsaconf with no success...

Wish config file am I missing??

Thanks,

Matt

Last edited by cybermatthieu; 11-14-2007 at 01:06 AM.
 
Old 11-14-2007, 08:06 AM   #2
hansalfredche
Member
 
Registered: Jun 2005
Posts: 445

Rep: Reputation: 31
I think this is more a xmms problem than an ALSA one. So maybe you should play around in xmms. It is not maintained since some years now, btw.
 
Old 11-14-2007, 11:51 AM   #3
HappyTux
Senior Member
 
Registered: Mar 2003
Location: Nova Scotia, Canada
Distribution: Debian AMD64
Posts: 3,513

Rep: Reputation: 63
I had the same problem having two sound cards use to work perfectly but now it does not what I did to solve it was go into my BIOS and disable the onboard sound, now my Audigy works fine and make sure you the alsa-oss package installed for emulation of the OSS for those programs that still need it.
 
Old 11-14-2007, 06:52 PM   #4
cybermatthieu
LQ Newbie
 
Registered: Feb 2006
Posts: 5

Original Poster
Rep: Reputation: 0
Thanks for the replies!

That's true, xmms is not maintained anymore but I really like it. It's not only an xmms problem... (sadly) If in gnome I set the configuration to alsa I don't have any sound... But if I set it to oss I get sound but I really want alsa.

For the bios, I thought of that, the onboard card is disabled, but it was disabled after the inicial Debian installation.

Thanks again for the replies, I'll keep googling...

Matt
 
Old 11-18-2007, 11:34 PM   #5
cybermatthieu
LQ Newbie
 
Registered: Feb 2006
Posts: 5

Original Poster
Rep: Reputation: 0
Today I tried to install the libsdl1.2debian-oss. After that I fired up tremulous, got sound! but oss ..

I tried to reinstall libsdl1.2debian-alsa thinking that maybe the mystery configuration whould be solve... but no... Still googling

I find it odd that asoundconf list has no results.

I saw that I'm not the only one :
http://ubuntuforums.org/showthread.php?t=362231

Seems like unbuntu 7.10 was also affected.
 
Old 11-18-2007, 11:50 PM   #6
cybermatthieu
LQ Newbie
 
Registered: Feb 2006
Posts: 5

Original Poster
Rep: Reputation: 0
Smile

Problem solved!

I deleted these two files in my home directory:
.asoundrc
.asoundrc.asoundconf

Rebooted and I had alsa workin!

I tried this after resding this bug report:
https://bugs.launchpad.net/ubuntu/+s...ils/+bug/67998

Hope this can help someone else!

Thanks for all your support,

Matt
 
  


Reply

Tags
alsa, debian, sdl, sound


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
snd_emu10k1, alsa, and /dev/dsp dissappearing Gort32 Linux - Hardware 1 08-07-2005 01:18 PM
Audigy2 NX and snd_emu10k1 module? redneon Linux - Hardware 2 07-16-2005 06:33 AM
alsa 1.0.7 rpm -F says snd_emu10k1 module is missing fight_the_$oft Suse/Novell 0 11-23-2004 12:50 PM
ALSA on Debian, Kernel Source is There Alsa dosent see it? pfizur Linux - Software 3 12-27-2003 08:46 AM
snd_emu10k1 doesnt load automatically in 2.6 yenonn Slackware 3 12-19-2003 05:37 PM


All times are GMT -5. The time now is 02:36 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration