LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices



Reply
 
Search this Thread
Old 01-16-2003, 09:20 AM   #1
Silent1
Member
 
Registered: Jul 2002
Location: Davie, FL
Distribution: Debian
Posts: 33

Rep: Reputation: 15
Cups & gimp-print "No pages found!"


i've been trying to get cups to work on my system, i had it working for awhile then small errors started popping up. It was a fully functional networked printer to only being able to print from the machine connected to it, then printing pages halfway, and now it won't print at all, I've tried 3 versions of cups( 1.1.16-1.1.18) and serval versions of gimp-print (even tried cvs). Here are some of the errrors from the errror_log

D [15/Jan/2003:23:09:25 -0500] [Job 48] Unknown device: cups
E [15/Jan/2003:23:09:25 -0500] PID 21038 stopped with status 1!
D [15/Jan/2003:23:09:25 -0500] [Job 48] 0 %%CreationDate: Mon Nov 12 2001
E [15/Jan/2003:23:09:25 -0500] PID 21039 stopped with status 1!
D [15/Jan/2003:23:09:25 -0500] [Job 48] 0 %% Font Page 00
D [15/Jan/2003:23:09:25 -0500] [Job 48] 0 %%BeginFont: LuxiMono-Bold
D [15/Jan/2003:23:09:25 -0500] [Job 48] 0 %%FontName: LuxiMono-Bold-Uni
D [15/Jan/2003:23:09:25 -0500] [Job 48] 0 %%Creator: Composite font created by Qt
D [15/Jan/2003:23:09:25 -0500] [Job 48] 0 %%EndFont
D [15/Jan/2003:23:09:25 -0500] [Job 48] 0 %%EndSetup
D [15/Jan/2003:23:09:25 -0500] [Job 48] 0 %%Page: 1 1
D [15/Jan/2003:23:09:25 -0500] [Job 48] 0 %%Page: 1 1
D [15/Jan/2003:23:09:25 -0500] [Job 48] pw = 612.0, pl = 746.0
D [15/Jan/2003:23:09:25 -0500] [Job 48] PageLeft = 0.0, PageRight = 612.0
D [15/Jan/2003:23:09:25 -0500] [Job 48] PageTop = 787.0, PageBottom = 41.0
D [15/Jan/2003:23:09:25 -0500] [Job 48] PageWidth = 612.0, PageLength = 792.0
D [15/Jan/2003:23:09:25 -0500] [Job 48] 0 %%BeginPageSetup
D [15/Jan/2003:23:09:25 -0500] [Job 48] 0 %%EndPageSetup
D [15/Jan/2003:23:09:25 -0500] [Job 48] 0 %%Trailer
D [15/Jan/2003:23:09:25 -0500] [Job 48] Saw Trailer!
D [15/Jan/2003:23:09:25 -0500] [Job 48] Saw EOF!
E [15/Jan/2003:23:09:25 -0500] [Job 48] No pages found!
D [15/Jan/2003:23:09:25 -0500] UpdateJob: job 48, file 0 is complete.
D [15/Jan/2003:23:09:25 -0500] CancelJob: id = 48


any ideas?
Also i can't print from using lpd, i'm not sure where the lpd log is but it just says an error was found and it can't print. But the printer does work, using an app i can connect to printer and clean the nozzels, etc, i just can't print using this printer utility. BTw printer is a lexmark z42.
 
Old 01-17-2003, 05:38 AM   #2
Aussie
Senior Member
 
Registered: Sep 2001
Location: Brisvegas, Antipodes
Distribution: Slackware
Posts: 4,590

Rep: Reputation: 56
Have you installed espgs?
 
Old 01-17-2003, 11:44 AM   #3
Silent1
Member
 
Registered: Jul 2002
Location: Davie, FL
Distribution: Debian
Posts: 33

Original Poster
Rep: Reputation: 15
thanks, that was not installed for some reason. I can print thru cups, but it only prints halfway then stalls. It strangely seems to be related to the fonts, if i print something using a fancy font it'll start printing then stop. but say i print with courier it'll print the first paragraph and stop. Not to sure about this though, have to look a bit more into it. This is what cups is doing while the printer is stalling,

D [17/Jan/2003:11:37:46 -0500] AcceptClient() 3 from 192.168.1.101:631.
D [17/Jan/2003:11:37:46 -0500] ReadClient() 3 POST /printers/ HTTP/1.1
D [17/Jan/2003:11:37:46 -0500] ProcessIPPRequest: 3 status_code=0
D [17/Jan/2003:11:37:46 -0500] AcceptClient() 7 from 192.168.1.101:631.
D [17/Jan/2003:11:37:46 -0500] CloseClient() 3
D [17/Jan/2003:11:37:46 -0500] ReadClient() 7 POST /classes/ HTTP/1.1
D [17/Jan/2003:11:37:46 -0500] ProcessIPPRequest: 7 status_code=0
D [17/Jan/2003:11:37:46 -0500] AcceptClient() 3 from 192.168.1.101:631.
D [17/Jan/2003:11:37:46 -0500] CloseClient() 7
D [17/Jan/2003:11:37:46 -0500] ReadClient() 3 POST /printers/ HTTP/1.1
D [17/Jan/2003:11:37:46 -0500] ProcessIPPRequest: 3 status_code=0
D [17/Jan/2003:11:37:46 -0500] AcceptClient() 7 from 192.168.1.101:631.
D [17/Jan/2003:11:37:46 -0500] CloseClient() 3
D [17/Jan/2003:11:37:46 -0500] ReadClient() 7 POST / HTTP/1.1
D [17/Jan/2003:11:37:46 -0500] ProcessIPPRequest: 7 status_code=1
D [17/Jan/2003:11:37:46 -0500] CloseClient() 7

and this is the printer state,
Printer State: processing, accepting jobs.
"Processing page 2..."

I'm not exactly sure whats the problem, anyone run into this problem? Printer driver info: LEXMARK Z42, CUPS+GIMP-print v4.2.4
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
"Successful install" results in "Boot device not found" slackr007 Fedora 2 06-21-2005 05:05 PM
"Successful install" results in "Boot device not found" slackr007 Linux - Newbie 2 05-31-2005 09:02 PM
Couldn't display "SMB:///" , No host "(Null)" could been Found?????? help munkey Fedora 6 04-30-2004 07:04 PM
cups halts at "print test" jarhead *BSD 2 09-13-2003 09:28 PM
Samba & Win2K pro, "network path not found" RedHat123 Linux - Networking 8 02-05-2002 10:57 PM


All times are GMT -5. The time now is 12:28 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration