LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices



Reply
 
Search this Thread
Old 01-09-2009, 11:45 PM   #1
deb1bhu
Member
 
Registered: Sep 2008
Posts: 49

Rep: Reputation: 16
creative sound card not working in fedora 8


Hello, ALL
last day I have installed creative sound blaster audigy in my PC. It's working fine in xp but in fedora it seems to be that my default sound card Intel audio is primary sound card & creative is not working. Although it's being recognized, but not working. I have 5.1 sound system but I can hear sound from only one speaker & from the sub woofer (it's Altec Lansing 5.1). I have tried to change the default sound card but it failed every time I check the default card it's Intel again. can any body tell me how to make work my sound card in fedora 8 !

Also in fedora I can't find anything to configure 5.1 sound system like XP, is there anything like that to configure (like center, master speaker etc etc).

please help is my only request.
 
Old 01-10-2009, 06:53 AM   #2
pgpython
Member
 
Registered: Dec 2005
Location: Sheffield, UK
Distribution: Gentoo
Posts: 141

Rep: Reputation: 32
There is a way of setting the default driver however it is probably a lot more easier just to use the one sound card. First of all though you need to make sure that your system has got the soundcard installed propely. (It may well be picked up by dmesg but nothing is there to make use of it) To do this I recommend you look at www.alsa-project.org where they have a driver matrix for all soundcards linux supports as well as help configuring alsa. Once you have the module for your harddrive you can then find if you have it or not, Which will depend on how your system is set up:

1. Modular Approach:

Most Likely you have a modular system. Which means when you run lsmod as root you will find the intel driver and the soundblaster driver. If that occurs you can use any tool you prefer to configure the volume. I personally prefer kmixer in kde as it allows you to easily select your device and options. However gnome has a similar tool or you can use alsamixer from the command line. Then you can simply blacklist the intel module to make sure it doesn'r get loaded at boot by adding blacklist intel8x0 to /etc/modprobe.d/blacklist. which will ensure at boot that it wont get loaded.

2, Inbuilt approach

Suppose when you run lsmod you happen to notice the intel module is not there. that is because its built into the kernel which will mean you have to reconfigure the kernel and adding the appropiate sound drivers into which can be done by running as root in /usr/src/linux make config, make && make modules_install && make install

I hope that helps.
 
Old 01-10-2009, 08:36 AM   #3
deb1bhu
Member
 
Registered: Sep 2008
Posts: 49

Original Poster
Rep: Reputation: 16
Quote:
Originally Posted by pgpython View Post
There is a way of setting the default driver however it is probably a lot more easier just to use the one sound card. First of all though you need to make sure that your system has got the soundcard installed propely. (It may well be picked up by dmesg but nothing is there to make use of it) To do this I recommend you look at www.alsa-project.org where they have a driver matrix for all soundcards linux supports as well as help configuring alsa. Once you have the module for your harddrive you can then find if you have it or not, Which will depend on how your system is set up:

1. Modular Approach:

Most Likely you have a modular system. Which means when you run lsmod as root you will find the intel driver and the soundblaster driver. If that occurs you can use any tool you prefer to configure the volume. I personally prefer kmixer in kde as it allows you to easily select your device and options. However gnome has a similar tool or you can use alsamixer from the command line. Then you can simply blacklist the intel module to make sure it doesn'r get loaded at boot by adding blacklist intel8x0 to /etc/modprobe.d/blacklist. which will ensure at boot that it wont get loaded.

2, Inbuilt approach

Suppose when you run lsmod you happen to notice the intel module is not there. that is because its built into the kernel which will mean you have to reconfigure the kernel and adding the appropiate sound drivers into which can be done by running as root in /usr/src/linux make config, make && make modules_install && make install

I hope that helps.
thank you but I got a problem here, u told me to visit the site, & that I visited but My sound card is creative sound blaster audigy value CA0106 in the tags section you can see
PCI Digital/Analog input does not work yet. Needs more development
work.


So how to find out which approach I should follow? One thing I also want to tell you that I am very poor in installing and checking software in linux, I love this OS but sometimes I found myself in a great danger when something bad things happen in system. So could you provide a little bit more in details of what to do.waiting for your reply.
 
Old 01-10-2009, 09:28 AM   #4
pgpython
Member
 
Registered: Dec 2005
Location: Sheffield, UK
Distribution: Gentoo
Posts: 141

Rep: Reputation: 32
It depends on wether you care about that feature. If you need to record sound from a external source then you might want to look at oss to see if it can offer that feature. If OSS can't then unfortunately there is nothing you can do. If all you want to do though is listen to music then your ok. Then all you have to do is make sure that its been loaded:

Become root first by using su - then run lsmod. If the module name you require is there. your just need to unmute the various channels and probably blacklist the module. As I said I would recommend kmixer in kde but easily lets you select cards, channels and features but use whatever you feel comfortable.

If the module you need is not listed then you need to reconfigure your kernel to add support for your card. It sounds a lot more scarier than it is. At least for what you need to do (assuming you do).

To do this as root got /usr/src/linux and run make menuconfig. You will get a blue menu screen. You then select Device Drivers->Sound Support->Alsa-> and then you press y next to your card to have it inbuilt into the kernel and M to have it built sepperately as a module. press escape a few timees and when prompted to save your configuration say yes. Then run make && make modules_install && make install. blacklist the intel module if neccessary Reboot the system unmute the various channels and Job finnished
 
Old 01-10-2009, 11:42 AM   #5
deb1bhu
Member
 
Registered: Sep 2008
Posts: 49

Original Poster
Rep: Reputation: 16
Quote:
Originally Posted by pgpython View Post
It depends on wether you care about that feature. If you need to record sound from a external source then you might want to look at oss to see if it can offer that feature. If OSS can't then unfortunately there is nothing you can do. If all you want to do though is listen to music then your ok. Then all you have to do is make sure that its been loaded:

Become root first by using su - then run lsmod. If the module name you require is there. your just need to unmute the various channels and probably blacklist the module. As I said I would recommend kmixer in kde but easily lets you select cards, channels and features but use whatever you feel comfortable.

If the module you need is not listed then you need to reconfigure your kernel to add support for your card. It sounds a lot more scarier than it is. At least for what you need to do (assuming you do).

To do this as root got /usr/src/linux and run make menuconfig. You will get a blue menu screen. You then select Device Drivers->Sound Support->Alsa-> and then you press y next to your card to have it inbuilt into the kernel and M to have it built sepperately as a module. press escape a few timees and when prompted to save your configuration say yes. Then run make && make modules_install && make install. blacklist the intel module if neccessary Reboot the system unmute the various channels and Job finnished

here I got a problem again, I can't find a path /usr/src/linux.. instead I have /usr/src/kernels or /usr/src/redhat So what 'd I do? when I run lsmod commad I got the following output(the part). I hope you might help me this time.
.........
snd_usb_audio 75585 0
snd_usb_lib 17345 1 snd_usb_audio
snd_hda_intel 331001 4
snd_ca0106 32609 2
snd_seq_dummy 6853 0
snd_rawmidi 21441 2 snd_usb_lib,snd_ca0106
snd_ac97_codec 92389 1 snd_ca0106
snd_seq_oss 29633 0
snd_seq_midi_event 9921 1 snd_seq_oss
snd_seq 44913 5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_seq_device 9933 4 snd_seq_dummy,snd_rawmidi,snd_seq_oss,snd_seq
snd_pcm_oss 37441 0
snd_mixer_oss 16705 3 snd_pcm_oss
snd_pcm 61509 5 snd_usb_audio,snd_hda_intel,snd_ca0106,snd_ac97_codec,snd_pcm_oss
nvidia 7091012 34
iTCO_wdt 13925 0
snd_timer 21065 2 snd_seq,snd_pcm
snd_hwdep 10309 2 snd_usb_audio,snd_hda_intel
e100 33997 0
iTCO_vendor_support 7109 1 iTCO_wdt
ac97_bus 5825 1 snd_ac97_codec
snd 46437 21 snd_usb_audio,snd_hda_intel,snd_ca0106,snd_rawmidi,snd_ac97_codec,snd_seq_oss,snd_seq,snd_seq_device ,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer,snd_hwdep
i2c_i801 11985 0
soundcore 9633 3 snd
mii 8385 1 e100
snd_page_alloc 11337 3 snd_hda_intel,snd_ca0106,snd_pcm
sg 31605 0
i2c_core 20949 2 nvidia,i2c_i801
parport_pc 26725 0
pcspkr 6593 0
parport 32173 1 parport_pc
sr_mod 17541 0
cdrom 33249 1 sr_mod
ata_piix 19397 8
ata_generic 8773 0
pata_acpi 8001 0
libata 132065 3 ata_piix,ata_generic,pata_acpi
sd_mod 26329 10
scsi_mod 123917 8 ib_iser,iscsi_tcp,libiscsi,scsi_transport_iscsi,sg,sr_mod,libata,sd_mod
ext3 110281 1
jbd 41045 1 ext3
mbcache 10309 1 ext3
uhci_hcd 22993 0
..........

now what 'd I do?
 
Old 01-10-2009, 12:17 PM   #6
pgpython
Member
 
Registered: Dec 2005
Location: Sheffield, UK
Distribution: Gentoo
Posts: 141

Rep: Reputation: 32
Ok from lsmod it looks like you have the both sound cards so you don't need to wory about your kernel. so you best bet if your not going to use the intel card is to blacklist it. so as root edit /etc/modprobe.d/blacklist. add the line blacklist snd_hda_intel save it and then restart. This time when you run lsmod you should note that snd_hda_intel is not there. So then all you do is unmute various channels and your sorted.
 
Old 01-10-2009, 12:29 PM   #7
deb1bhu
Member
 
Registered: Sep 2008
Posts: 49

Original Poster
Rep: Reputation: 16
Quote:
Originally Posted by pgpython View Post
Ok from lsmod it looks like you have the both sound cards so you don't need to wory about your kernel. so you best bet if your not going to use the intel card is to blacklist it. so as root edit /etc/modprobe.d/blacklist. add the line blacklist snd_hda_intel save it and then restart. This time when you run lsmod you should note that snd_hda_intel is not there. So then all you do is unmute various channels and your sorted.
Thanks this time sound is coming. But only from two front speakers, neither from the rear ones nor from the center speakers. one thing I want to tell you that in creative CD there is no drivers for fedora, If I have to download then from where & how to install those packages ! I hope you can solve this problem too.
 
Old 01-10-2009, 12:44 PM   #8
pgpython
Member
 
Registered: Dec 2005
Location: Sheffield, UK
Distribution: Gentoo
Posts: 141

Rep: Reputation: 32
They wouldn't be, sound card support for linux is provided as part of the kernel source. Are you sure you have unmuted all the channels? You will also need which ever app your using to use surround sound. If your trying to use something like amarok. It provide options for xine as part of the settings.Alternatively you can setup up alsa to route sound to all channels for everything. see the surround sound wiki alsa.opensrc.org/SurroundSound
 
Old 01-11-2009, 05:21 AM   #9
deb1bhu
Member
 
Registered: Sep 2008
Posts: 49

Original Poster
Rep: Reputation: 16
Quote:
Originally Posted by pgpython View Post
They wouldn't be, sound card support for linux is provided as part of the kernel source. Are you sure you have unmuted all the channels? You will also need which ever app your using to use surround sound. If your trying to use something like amarok. It provide options for xine as part of the settings.Alternatively you can setup up alsa to route sound to all channels for everything. see the surround sound wiki alsa.opensrc.org/SurroundSound
I don't know how to unmuted all the channels, you told me to configure alsamixer and there I configured correctly. However I didn't try amarok but audacious, Also which app means i don't understand!! Every player 'd have a sorround effect. What I try to say that only two speakers output sound is coming rest are mute. Help me please.
 
Old 01-11-2009, 08:25 AM   #10
pgpython
Member
 
Registered: Dec 2005
Location: Sheffield, UK
Distribution: Gentoo
Posts: 141

Rep: Reputation: 32
depending on what desktop you using, you unmute the various channels your device has. In Kde kmixer is used which is accessed by clicking the speaker icon on kicker clicking mixer. Then you just make sure all the sound outputs are highlighted green. Then increase the level of master, pcm, surround, font, center, side and line.

If your using Gnome, you can access gnome volume mixer by clicking Applications->sound and video->Volume Control, make sure the outputs don't have a speaker with a cross over them. Then adjust the various controls.

Im not too familar with other desktops so if you have another one have a look around or you can use alsamixer from the command line, you just use left/right to select the output and up/down to increase/decrease the volume.

you then need to make sure whatever app your using is configured to use surround sound. by default it only uses stereo sound. To do this, it best to have output to something like esd or xine which have surround sound support. In audacious just press ctrl+p.click and then click configure sound output plugin.
 
Old 01-12-2009, 01:00 AM   #11
deb1bhu
Member
 
Registered: Sep 2008
Posts: 49

Original Poster
Rep: Reputation: 16
Quote:
Originally Posted by pgpython View Post
depending on what desktop you using, you unmute the various channels your device has. In Kde kmixer is used which is accessed by clicking the speaker icon on kicker clicking mixer. Then you just make sure all the sound outputs are highlighted green. Then increase the level of master, pcm, surround, font, center, side and line.

If your using Gnome, you can access gnome volume mixer by clicking Applications->sound and video->Volume Control, make sure the outputs don't have a speaker with a cross over them. Then adjust the various controls.

Im not too familar with other desktops so if you have another one have a look around or you can use alsamixer from the command line, you just use left/right to select the output and up/down to increase/decrease the volume.

you then need to make sure whatever app your using is configured to use surround sound. by default it only uses stereo sound. To do this, it best to have output to something like esd or xine which have surround sound support. In audacious just press ctrl+p.click and then click configure sound output plugin.
I use genome & there I can't find anything like kmixer or something like that, actually in the volume control I unmuted all the channel and the result is as ...
when I play some music files (in audacious) front speakers working, but If I play music files only placing the mouse cursor (or in audacious) over it the rear ones working. Is not sound interesting? However the 5.1 surround sound I never got till now. I have unmuted all. Even tried the output device to put into surround sound. What 'd I do?
 
  


Reply

Tags
creative, soundcard


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
buzzing/distorted sound with creative sb live sound card Valkyrie_of_valhalla Linux - Software 1 06-07-2007 10:51 PM
ALSA not working for Creative Sound Blaster Live 24 Bit sound card vishalsonu Linux - Hardware 7 08-20-2005 02:02 PM
Sound card not working in Fedora Core 3 hybridstorm Linux - Hardware 3 06-18-2005 02:05 PM
Creative Sound Card not working. ShaanAli Solaris / OpenSolaris 3 08-13-2004 08:30 AM
Sound card not working in Fedora Core 2 Fredstar Linux - Newbie 8 07-05-2004 05:30 PM


All times are GMT -5. The time now is 10:25 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration