LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices



Reply
 
Search this Thread
Old 07-29-2003, 10:56 AM   #1
Dabria
Member
 
Registered: Jul 2003
Location: Caraquet, New-Brunswick
Distribution: Slackware - Current
Posts: 35

Rep: Reputation: 15
Couldn't open mixer device /dev/sound/mixer


I just installed Slackware 9 ( 2.4.20 ) and after logging in I get that error message. Couldn't open mixer device /dev/sound/mixer. Everything works fine except for the sound. This is the sound card I have.

lspci
00:1f.5 Multimedia audio controller: Intel Corp. 82801DB AC'97 Audio (rev 02)

During the boot process I noticed something about i810 scrolling several times. Syslog shows this:

Jul 28 14:24:13 Slack kernel: i810_rng: RNG not detected
Jul 28 14:24:13 Slack kernel: i810_audio: Audio Controller supports 6 channels.
Jul 28 14:24:13 Slack kernel: i810_audio: Primary codec not ready.
Jul 28 14:24:13 Slack kernel: i810 TCO timer init: failed to reset NO_REBOOT flag, reboot disabled by hardware

I tried to manually load the i810_audio module with both modprobe and insmod but this is the message I get:

/lib/modules/2.4.20/kernel/drivers/sound/i810_audio.o.gz: init_module: No such device
/lib/modules/2.4.20/kernel/drivers/sound/i810_audio.o.gz: Hint: insmod errors can be caused by incorrect module parameters, including invalid IO or IRQ parameters.
You may find more information in syslog or the output from dmesg
/lib/modules/2.4.20/kernel/drivers/sound/i810_audio.o.gz: insmod /lib/modules/2.4.20/kernel/drivers/sound/i810_audio.o.gz failed
/lib/modules/2.4.20/kernel/drivers/sound/i810_audio.o.gz: insmod i810_audio failed

When I lsmod I get these modules currently loaded
Module Size Used by Not tainted
soundcore 3332 0 (autoclean)
agpgart 35776 6 (autoclean)
uhci 24560 0 (unused)
ehci-hcd 14632 0 (unused)
usbcore 58144 1 [uhci ehci-hcd]
pcmcia_core 38112 0
ide-scsi 8048 0
8139too 15272 1
mii 2240 0 [8139too]

I could easily get rid of the actual error by removing the volume control of the panel but I still would get no sound.

Hopefully someone will be able to help me or point me to the proper place to fix this. I'm not against recompiling if it will fix this issue.

Thank you in advance for any help with this. I greatly appreciate it.
 
Old 07-29-2003, 12:37 PM   #2
fancypiper
Guru
 
Registered: Feb 2003
Location: Sparta, NC USA
Distribution: Ubuntu 10.04
Posts: 5,141

Rep: Reputation: 58
You have to run kernel-2.5.11 or later

Intel - Configuring Onboard Audio

Last edited by fancypiper; 07-29-2003 at 12:42 PM.
 
Old 07-29-2003, 12:50 PM   #3
Dabria
Member
 
Registered: Jul 2003
Location: Caraquet, New-Brunswick
Distribution: Slackware - Current
Posts: 35

Original Poster
Rep: Reputation: 15
Thanks,

I figured this is what it would come to. I'll give it a try tonight after work or tomorrow morning and post the results.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Couldn't open mixer device /dev/sound/mixer laurentwahl Linux - General 8 05-17-2005 09:15 PM
couldn't open mixer device /dev/sound/mixer pitts68 Linux - Newbie 4 11-15-2004 09:03 AM
Couldn't open mixer device /dev/sound/mixer arctic123 Linux - Newbie 4 09-22-2004 10:39 AM
couldn't open mixer device /dev/sound/mixer wangcity Linux - General 8 02-01-2004 08:17 AM
Sound issue - "Couldn't open mixer device /dev/sound/mixer" zsejk Slackware 17 08-14-2003 11:20 PM


All times are GMT -5. The time now is 05:12 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration