LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 10-26-2006, 12:54 PM   #1
mufy
Member
 
Registered: Oct 2004
Location: Kuwait
Distribution: Currently - AIX | Previously - RHEL 4 ES, FC 10
Posts: 206
Blog Entries: 4

Rep: Reputation: 30
Conexant chipset internal modem - dialing problem on RHEL 4


Hi (Whoever is viewing this),

I managed to successfully install my internal modem (conexant chipset) on RHEL 4 (2.6.9-5.EL).

Successfully executed 'wvdialconf /etc/wvdial.conf'. Now when I run 'wvdial' the modem picks the line and starts dialing in tone dialing mode. Immediately after dialing, the line is dropped even before the connection is established.

My line supports pulse dialing. I faced the same problem in my Win XP. There, even after changing the dialing mode to pulse; the modem was still going for the tone. Finally, after a lot of tinkering I stumbled on this - when I added a ',' in the dialing rules box (where it is mentioned - type the number you use to access local lines) the modem was able to get the required pause before commencing pulse mode dialing.

I am sure it is the same case with RHEL 4 now, but I don't where to include that extra ',' in wvdial.

Any help would be greatly appreciated.
 
Old 10-28-2006, 05:10 AM   #2
mufy
Member
 
Registered: Oct 2004
Location: Kuwait
Distribution: Currently - AIX | Previously - RHEL 4 ES, FC 10
Posts: 206
Blog Entries: 4

Original Poster
Rep: Reputation: 30
Pulse-mode dialing

Hi,

I don't really know what exactly caused the file lock problem, but having edited the file /etc/ppp/options as:
lock
crtscts
defaultroute
noauth

and after subsequent reboots the problem was solved. Also, I found out that the link /dev/modem pointing to my internal modem /dev/ttySFSH0 was getting deleted everytime I rebooted. So I added the line,

ln -s /dev/ttySFSH0 dev/modem

to the /etc/rc.d/rc.local file and cleared that hurdle.

I was able to achieve the dialing mode change by changing the 'Dialing String' variable in the modem commands in Kppp modem settings from ATDT(tone) to ATDP(pulse).
 
  


Reply

Tags
conexant, hsf, internal modem, lock file


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Intel 536ep Chipset Internal Modem cynsmc3 Linux - Hardware 0 06-02-2006 08:29 AM
Installing internal Modem, chipset Intel536ep in Ubuntu5.10 dh2k Linux - Hardware 0 04-09-2006 08:54 AM
conexant v.92 internal modem not detecting in redhat linux 9.0 supersac Linux - Newbie 9 11-30-2004 01:04 PM
Problems Installing drivers for an Internal conexant modem Agent M Linux - Hardware 3 05-30-2004 02:07 AM
Conexant PCI ADSL Internal Modem tattooedpierre Linux - Newbie 14 04-30-2003 03:34 AM


All times are GMT -5. The time now is 02:32 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration