LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 06-18-2004, 11:10 AM   #1
jkobrien
Member
 
Registered: Jun 2003
Location: Dublin, Ireland
Distribution: Slackware, LFS, Ubuntu, RedHat, Slamd64
Posts: 507

Rep: Reputation: 30
compose key not working


Hi,

I'm trying to use the compose key for characters like , , and so on.

It seems, from google searches, that Shift-AltGr is the default, but pressing this, followed by ',','c' does nothing - the cursor doesn't move so I guess some sort of signal is being sent.

I've tried using the kde control center -> Regional & Accessibility -> Keyboard Layout -> Options to set the right windows key, and also "xmodmap -e 'keycode 78 = Multi_key'" to set the scroll lock as the compose key but neither method works.

Reading the manpage for dumpkeys, I notice a comment about the kernel requiring compose key support. I've searched /usr/src/linux/Documentation and can't find anything on this.

I'm using Slackware 9.1, kernel 2.4.26, a Dell Precision 650 and my XF86Config keyboard section look like this (comments strippped) ...

Section "InputDevice"
Identifier "Keyboard1"
Driver "Keyboard"
Option "AutoRepeat" "500 30"
Option "XkbRules" "xfree86"
Option "XkbModel" "pc105"
Option "XkbLayout" "gb"
EndSection


Thanks in advance for any suggestions,

John
 
Old 08-05-2004, 09:18 AM   #2
jkobrien
Member
 
Registered: Jun 2003
Location: Dublin, Ireland
Distribution: Slackware, LFS, Ubuntu, RedHat, Slamd64
Posts: 507

Original Poster
Rep: Reputation: 30
Note to self. Include this line in /etc/X11/xorg.conf

Code:
    Option     "XkbOptions"    "compose:menu"
This works sporadically for some letters, and doesn't work at all for others.

John
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Control Key not working! pfeito Linux - General 2 04-06-2006 11:46 AM
Insert key not working Drunkalot Linux From Scratch 1 11-01-2005 11:45 AM
How to disable compose key (Right Control) under GNOME? wirawan0 Suse/Novell 0 10-05-2005 12:57 PM
KDE, compose key, and xkb problems nazdrowie Linux - General 0 02-24-2005 01:37 AM
AltGr key not working in X iceman47 Linux - Software 3 03-07-2004 07:27 PM


All times are GMT -5. The time now is 07:27 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration