LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices



Reply
 
Search this Thread
Old 03-05-2004, 06:30 PM   #1
kev
LQ Newbie
 
Registered: Mar 2004
Posts: 5

Rep: Reputation: 0
Change default sound card with 2 cards


Hi, I recently installed Mandrake 9.2 and everything went well except for sound. The problem is that I have 2 sound cards (onboard which i don't use, and SB audigy which i want to use).

I have set the system output to dsp1 which is my audigy and the 'Test Sound' button works as well as other system sounds, but no apps use the right sound card. I can get output from my onbaord card with the apps.

What I want to do is make the audigy my default card. I noticed the onboard sound modules load first, so maybe if I can switch the order in which they load I can fix this?? How to I switch the load order? I am familiar with scripting and such, so changing a script won't be a problem if I know where to go.

If anyone has other suggestions on how to get my audigy to work for all apps, that would be great. Oh, and when i mouse over an audio file, it goes through the audigy too! Just not normally in apps (like Totem etc.). Thanks for any help, this is the only thing keeping me from using Linux on a more regular basis, I need my music.

... one thing I did try was to rename dsp to dsp5 or something, and change dsp1 to the default dsp, but it won't let me do that, even as root.

(sorry, I can't post any output about my setup now, I'm at work, it's the 2.4 kernel with alsa)

Last edited by kev; 03-05-2004 at 06:33 PM.
 
Old 03-05-2004, 06:55 PM   #2
Electro
Guru
 
Registered: Jan 2002
Posts: 6,042

Rep: Reputation: Disabled
If the motherboard sound is compiled in the kernel, you are going to have a hard time making the audigy card being first. You can compile your kernel and make the on-board sound be as modules. Then edit modules.conf or conf.modules to load your audigy mudules first than your on-board sound modules next.

Why cant you just disable the on-board sound?
 
Old 03-26-2004, 12:49 AM   #3
czechknight93
Member
 
Registered: Aug 2003
Location: Weatherford, OK
Distribution: openSUSE 10.1
Posts: 95

Rep: Reputation: 15
How do you disable a sound card in Linux? I am using Mandrake 9.1. I have the same problem. My onboard sound card (SIS) monopolizes the sound in my system. I would like my (much more expensive and better) Audigy 2 card to do all the talking, but I can't shut my SIS on-board card up (disable it). Thanks!
 
Old 05-03-2004, 07:02 PM   #4
untwisted
Member
 
Registered: Dec 2003
Distribution: Slackware 10
Posts: 34

Rep: Reputation: 15
I'm actually having the same problem here too, and I'm running fedora core 1. If anyone knows the answer it'd be most appriciated!!

Thanks!
 
Old 05-04-2004, 08:44 AM   #5
Aussie
Senior Member
 
Registered: Sep 2001
Location: Brisvegas, Antipodes
Distribution: Slackware
Posts: 4,590

Rep: Reputation: 56
The answer lies in your /etc/modules.conf file, for mandrake have a look at the alsa page for your sound card for the correct entries, I don't know if fedora uses alsa.
If you want to stop a module from loading add it to /etc/hotplug/blacklist.
 
Old 05-04-2004, 10:54 AM   #6
czechknight93
Member
 
Registered: Aug 2003
Location: Weatherford, OK
Distribution: openSUSE 10.1
Posts: 95

Rep: Reputation: 15
Reboot your PC and load your system BIOS. You should have a feature to disable the on-board sound card. This will prevent your on-board sound from loading at all.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
specify default sound card joelescoulie Slackware 2 07-12-2005 04:43 PM
Two sound cards: Which one is default? dominik81 Linux - Hardware 2 04-10-2005 07:37 PM
Default sound card Wakeboardbum83 Suse/Novell 3 03-24-2005 01:13 PM
2 sound cards, howto configure one as default? Firestarter75 Mandriva 6 02-27-2005 11:33 PM
Make a sound card default. darkarcon2015 Slackware 9 01-07-2005 06:13 PM


All times are GMT -5. The time now is 10:05 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration