LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 01-01-2013, 10:13 PM   #1
JBJ1962
LQ Newbie
 
Registered: Dec 2012
Posts: 12

Rep: Reputation: Disabled
Angry Centos HANGS [Please Help] I'm Frustrated with this Workstation


I have Centos installed dual booted alongside windows on DELL PRECISION T7500 with 96GB RAM and 1TB storage for each OS.

My Kernel version is 2.6.32-279.19.1.el6.x86_64
I run CentOS release 6.3 (Final)


The OS boots up everythings fine and suddenly it HANGS just freezes on the screen, without any slowing down first, Sometimes the Workstation works very fine under heavy jobs for 2 3 days but somedays hangs after hang and I have to ForceSHUTDOWN by holding powerbutton for 10s.

Im totally frustrated with this , I've tried many of the errors found in my LOGS but haven't had successfully solved it yet ((

Please See the summary of my messages and Error LOg and help if you can:
Code:
Dec 31 09:03:06 Workstation-B kernel: ACPI: PCI Interrupt Link [LNKB] (IRQs 3 4 5 6 7 9 *10 11 12 15)
Dec 31 09:03:06 Workstation-B kernel: ACPI: PCI Interrupt Link [LNKC] (IRQs 3 4 *5 6 7 9 10 11 12 15)
Dec 31 09:03:06 Workstation-B kernel: ACPI: PCI Interrupt Link [LNKD] (IRQs 3 4 5 6 7 9 10 11 12 15) *0, disabled.
Dec 31 09:03:06 Workstation-B kernel: pci 0000:20:03.0: PCI bridge to [bus 22-22]
Dec 31 09:03:06 Workstation-B kernel: pci 0000:20:03.0: PCI bridge to [bus 22-22]
Dec 31 09:03:06 Workstation-B kernel: pci 0000:20:03.0:   bridge window [io  disabled]
Dec 31 09:03:06 Workstation-B kernel: pci 0000:20:03.0:   bridge window [mem 0xdfe00000-0xdfefffff]
Dec 31 09:03:06 Workstation-B kernel: dracut: dracut-004-284.el6_3.1
Dec 31 09:03:06 Workstation-B kernel: dracut: rd_NO_LUKS: removing cryptoluks activation
Dec 31 09:03:06 Workstation-B kernel: [drm] Initialized drm 1.1.0 20060810
Dec 31 09:03:06 Workstation-B kernel: [drm] radeon defaulting to kernel modesetting.
Dec 31 09:03:06 Workstation-B kernel: [drm] radeon kernel modesetting enabled.
Dec 31 09:03:06 Workstation-B kernel: radeon 0000:03:00.0: PCI INT A -> GSI 24 (level, low) -> IRQ 24
Dec 31 10:45:16 Workstation-B kernel: ACPI: LAPIC (acpi_id[0x37] lapic_id[0x00] disabled)
Dec 31 10:45:16 Workstation-B kernel: ACPI: LAPIC (acpi_id[0x38] lapic_id[0x00] disabled)
Dec 31 10:45:16 Workstation-B kernel: ACPI: LAPIC (acpi_id[0x39] lapic_id[0x00] disabled)
Dec 31 10:45:16 Workstation-B kernel: ACPI: LAPIC (acpi_id[0x3a] lapic_id[0x00] disabled)
Dec 31 10:45:16 Workstation-B kernel: ACPI: IOAPIC (id[0x09] address[0xfec80000] gsi_base[24])
Dec 31 10:45:16 Workstation-B kernel: IOAPIC[1]: apic_id 9, version 32, address 0xfec80000, GSI 24-47
Dec 31 10:45:16 Workstation-B kernel: ACPI: IOAPIC (id[0x0a] address[0xfec88000] gsi_base[48])
Dec 31 10:45:16 Workstation-B kernel: IOAPIC[2]: apic_id 10, version 32, address 0xfec88000, GSI 48-71
Dec 31 10:45:16 Workstation-B kernel: ACPI: INT_SRC_OVR (bus 0 bus_irq 0 global_irq 2 dfl dfl)
Dec 31 10:45:16 Workstation-B kernel: ACPI: INT_SRC_OVR (bus 0 bus_irq 9 global_irq 9 high level)
Dec 31 10:45:16 Workstation-B kernel: Using ACPI (MADT) for SMP configuration information
Dec 31 10:45:16 Workstation-B kernel: PM: Registered nosave memory: 00000000dbdfa000 - 00000000dbe4b000
Dec 31 10:45:16 Workstation-B kernel: PM: Registered nosave memory: 00000000dbe4b000 - 00000000dbe4c000
Dec 31 10:45:16 Workstation-B kernel: PM: Registered nosave memory: 00000000dbe4c000 - 00000000dbe4d000
Dec 31 10:45:16 Workstation-B kernel: pcpu-alloc: [0] 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47
Dec 31 10:45:16 Workstation-B kernel: pcpu-alloc: [0] 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63
Dec 31 10:45:16 Workstation-B kernel: Kernel command line: ro root=/dev/mapper/vg_workstationb-lv_root rd_NO_LUKS  KEYBOARDTYPE=pc KEYTABLE=us LANG=en_US.UTF-8 rd_NO_MD quiet SYSFONT=latarcyrheb-s$
Dec 31 10:45:16 Workstation-B kernel: PID hash table entries: 4096 (order: 3, 32768 bytes)
Dec 31 10:45:16 Workstation-B kernel: Checking aperture...
Dec 31 10:45:16 Workstation-B kernel: No AGP bridge found
Dec 31 10:45:16 Workstation-B kernel: PCI-DMA: Using software bounce buffering for IO (SWIOTLB)
Dec 31 10:45:16 Workstation-B kernel: Inode-cache hash table entries: 8388608 (order: 14, 67108864 bytes)
Dec 31 10:45:16 Workstation-B kernel: Mount-cache hash table entries: 256
Dec 31 10:45:16 Workstation-B kernel: Initializing cgroup subsys ns
Dec 31 10:45:16 Workstation-B kernel: Initializing cgroup subsys cpuacct
Dec 31 10:45:16 Workstation-B kernel: Initializing cgroup subsys memory
Dec 31 10:45:16 Workstation-B kernel: Initializing cgroup subsys devices
Dec 31 10:45:16 Workstation-B kernel: Initializing cgroup subsys freezer
Dec 31 10:45:16 Workstation-B kernel: Initializing cgroup subsys net_cls
Dec 31 10:45:16 Workstation-B kernel: Initializing cgroup subsys blkio
Dec 31 10:45:16 Workstation-B kernel: Initializing cgroup subsys perf_event
Dec 31 10:45:16 Workstation-B kernel: Initializing cgroup subsys net_prio
Dec 31 10:45:16 Workstation-B kernel: CPU: Physical Processor ID: 0
Dec 31 10:45:16 Workstation-B kernel: CPU: Processor Core ID: 0
Dec 31 10:45:16 Workstation-B kernel: mce: CPU supports 9 MCE banks
Dec 31 10:45:16 Workstation-B kernel: CPU0: Thermal monitoring enabled (TM1)
Dec 31 10:45:16 Workstation-B kernel: pci_root PNP0A03:00: host bridge window [io  0x03bc-0x03bf]
Dec 31 10:45:16 Workstation-B kernel: firewire_ohci 0000:07:0a.0: PCI INT A -> GSI 18 (level, low) -> IRQ 18
Dec 31 10:45:16 Workstation-B kernel: firewire_ohci: Added fw-ohci device 0000:07:0a.0, OHCI version 1.10
Dec 31 10:45:16 Workstation-B kernel: sr0: scsi3-mmc drive: 48x/48x writer dvd-ram cd/rw xa/form2 cdda tray
Dec 31 10:45:16 Workstation-B kernel: Uniform CD-ROM driver Revision: 3.20
Dec 31 10:45:16 Workstation-B kernel: dracut: Scanning devices sdb2  for LVM logical volumes vg_workstationb/lv_root vg_workstationb/lv_swap
Dec 31 10:45:16 Workstation-B kernel: dracut: inactive '/dev/vg_workstationb/lv_root' [50.00 GiB] inherit
Dec 31 10:45:16 Workstation-B kernel: dracut: inactive '/dev/vg_workstationb/lv_home' [784.41 GiB] inherit
Dec 31 10:45:16 Workstation-B kernel: dracut: inactive '/dev/vg_workstationb/lv_swap' [96.61 GiB] inherit
Dec 31 10:45:16 Workstation-B kernel: firewire_core: created device fw0: GUID 8073031825af4400, S400
Dec 31 10:45:16 Workstation-B kernel: EXT4-fs (dm-0): INFO: recovery required on readonly filesystem
Dec 31 10:45:16 Workstation-B kernel: EXT4-fs (dm-0): write access will be enabled during recovery
Dec 31 10:45:16 Workstation-B kernel: EXT4-fs (dm-0): orphan cleanup on readonly fs
Dec 31 09:03:06 Workstation-B kernel: [drm] initializing kernel modesetting (CAYMAN 0x1002:0x6704 0x1028:0x2B0C).
Dec 31 09:03:06 Workstation-B kernel: [drm] register mmio base: 0xF7DE0000
Dec 31 09:03:06 Workstation-B kernel: [drm] register mmio size: 131072
Dec 31 09:03:06 Workstation-B kernel: ATOM BIOS: DELL
Dec 31 09:03:06 Workstation-B kernel: radeon 0000:03:00.0: VRAM: 2048M 0x0000000000000000 - 0x000000007FFFFFFF (2048M used)
Dec 31 09:03:06 Workstation-B kernel: radeon 0000:03:00.0: GTT: 512M 0x0000000080000000 - 0x000000009FFFFFFF
Jan  2 11:02:23 Workstation-B kernel: PM: Registered nosave memory: 00000000000f0000 - 0000000000100000
Jan  2 11:02:23 Workstation-B kernel: PM: Registered nosave memory: 00000000dbdf9000 - 00000000dbdfa000
Jan  2 11:02:23 Workstation-B kernel: PM: Registered nosave memory: 00000000dbdfa000 - 00000000dbe4b000
Code:
Dec 26 10:32:51 Workstation-B kernel: ctxfi: Preparing pcm playback failed!!!
Dec 26 10:32:51 Workstation-B kernel: ctxfi: PLL initialization failed!!!
Dec 26 10:32:51 Workstation-B kernel: ctxfi: Preparing pcm playback failed!!!
Dec 26 10:32:51 Workstation-B kernel: ctxfi: PLL initialization failed!!!
Dec 26 10:32:51 Workstation-B kernel: ctxfi: Preparing pcm playback failed!!!
Dec 26 10:32:51 Workstation-B kernel: ctxfi: PLL initialization failed!!!
Dec 26 10:32:51 Workstation-B kernel: ctxfi: Preparing pcm playback failed!!!
Dec 26 10:32:51 Workstation-B kernel: ctxfi: PLL initialization failed!!!

Jan  2 11:02:28 Workstation-B automount[2440]: lookup_read_master: lookup(nisplus): couldn't locate nis+ table auto.master
Jan  2 11:02:28 Workstation-B mcelog: failed to prefill DIMM database from DMI data
Jan  2 11:02:28 Workstation-B mcelog: mcelog read: No such device
Jan  2 11:02:29 Workstation-B abrtd: Init complete, entering main loop

Jan  2 11:02:31 Workstation-B libvirtd: Could not find keytab file: /etc/libvirt/krb5.tab: No such file or directory
Jan  2 10:38:08 Workstation-B kernel: ctxfi: PLL initialization failed!!!
Jan  2 10:38:08 Workstation-B kernel: ctxfi: Preparing pcm playback failed!!!
Jan  2 10:38:15 Workstation-B pulseaudio[3296]: ratelimit.c: 12 events suppressed
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!sometimes hangs few minutres after this!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
Code:
gdm-simple-greeter[3040]: Gtk-WARNING: gtkwidget.c:5460: widget not within a GtkWindow
Jan  2 11:02:52 Workstation-B seahorse-daemon[3177]: DNS-SD initialization failed: Daemon not running
Jan  2 11:02:52 Workstation-B kernel: fuse init (API version 7.13)
Jan  2 11:02:52 Workstation-B seahorse-daemon[3177]: init gpgme version 1.1.8
Jan  2 11:02:53 Workstation-B pulseaudio[3238]: pid.c: Stale PID file, overwriting.

an  2 11:02:51 Workstation-B pam: gdm-password[3080]: WARNING: unable to log session
Jan  2 11:02:52 Workstation-B seahorse-daemon[3177]: DNS-SD initialization failed: Daemon not running
Jan  2 11:02:52 Workstation-B kernel: fuse init (API version 7.13)
Jan  2 11:02:52 Workstation-B seahorse-daemon[3177]: init gpgme version 1.1.8
Jan  2 11:02:53 Workstation-B pulseaudio[3238]: pid.c: Stale PID file, overwriting.

Jan  2 11:02:28 Workstation-B automount[2440]: lookup_read_master: lookup(nisplus): couldn't locate nis+ table auto.master
Jan  2 11:02:31 Workstation-B dnsmasq[2797]: read /etc/hosts - 2 addresses
Jan  2 11:02:33 Workstation-B kernel: lo: Disabled Privacy Extensions
Jan  2 11:02:32 Workstation-B kernel: Ebtables v2.0 registered
Jan  2 11:02:38 Workstation-B polkitd[3042]: started daemon version 0.96 using authority implementation `local' version `0.96'
Jan  2 11:02:39 Workstation-B rtkit-daemon[3054]: Sucessfully made thread 3052 of process 3052 (/usr/bin/pulseaudio) owned by '42' high priority at nice level -11.
Jan  2 11:02:39 Workstation-B rtkit-daemon[3054]: Sucessfully made thread 3057 of process 3052 (/usr/bin/pulseaudio) owned by '42' RT at priority 5.
Jan  2 11:02:39 Workstation-B rtkit-daemon[3054]: Sucessfully made thread 3059 of process 3052 (/usr/bin/pulseaudio) owned by '42' RT at priority 5.
Jan  2 11:02:39 Workstation-B rtkit-daemon[3054]: Sucessfully made thread 3060 of process 3052 (/usr/bin/pulseaudio) owned by '42' RT at priority 5.
Jan  2 11:02:40 Workstation-B kernel: hda-intel: IRQ timing workaround is activated for card #0. Suggest a bigger bdl_pos_adj.
Jan  2 11:02:40 Workstation-B gdm-simple-greeter[3040]: Gtk-WARNING: gtkwidget.c:5460: widget not within a GtkWindow
Jan  2 11:02:51 Workstation-B kernel: type=1400 audit(1357095771.316:4): avc:  denied  { read } for  pid=3080 comm="gdm-session-wor" name="root" dev=dm-0 ino=131073 scontext=system_u:system_r:xdm_$
Jan  2 11:02:51 Workstation-B pam: gdm-password[3080]: WARNING: unable to log session
Jan  2 11:02:52 Workstation-B seahorse-daemon[3177]: DNS-SD initialization failed: Daemon not running
Jan  2 11:25:14 Workstation-B pulseaudio[4202]: pid.c: Daemon already running.
Jan  2 11:25:14 Workstation-B rtkit-daemon[3054]: Sucessfully made thread 4203 of process 4203 (/usr/bin/pulseaudio) owned by '507' high priority at nice level -11.
Jan  2 11:25:14 Workstation-B pulseaudio[4203]: pid.c: Daemon already running.
Jan  2 11:25:14 Workstation-B rtkit-daemon[3054]: Sucessfully made thread 4204 of process 4204 (/usr/bin/pulseaudio) owned by '507' high priority at nice level -11.
Jan  2 11:25:14 Workstation-B pulseaudio[4204]: pid.c: Daemon already runnin
Sometimes after this !!!!
Code:
Jan  2 11:56:46 Workstation-B rtkit-daemon[3069]: Sucessfully made thread 3072 of process 3067 (/usr/bin/pulseaudio) owned by '42' RT at priority 5.
Jan  2 11:56:47 Workstation-B rtkit-daemon[3069]: Sucessfully made thread 3074 of process 3067 (/usr/bin/pulseaudio) owned by '42' RT at priority 5.
Jan  2 11:56:47 Workstation-B rtkit-daemon[3069]: Sucessfully made thread 3075 of process 3067 (/usr/bin/pulseaudio) owned by '42' RT at priority 5.
Jan  2 11:56:47 Workstation-B gdm-simple-greeter[3055]: Gtk-WARNING: gtkwidget.c:5460: widget not within a GtkWindow
Jan  2 11:56:47 Workstation-B kernel: hda-intel: IRQ timing workaround is activated for card #0. Suggest a bigger bdl_pos_adj.
Code:
ERROR LOG:
Dec 31 16:05:22 Workstation-B gdm-simple-slave[5811]: GLib-GObject-CRITICAL: g_signal_handlers_disconnect_matched: assertion `G_TYPE_CHECK_INSTANCE (instance)' failed
Dec 31 16:05:22 Workstation-B gdm-simple-slave[5811]: GLib-GObject-CRITICAL: g_signal_handlers_disconnect_matched: assertion `G_TYPE_CHECK_INSTANCE (instance)' failed
Dec 31 17:07:26 Workstation-B kernel: sd 7:0:0:0: [sdc] Assuming drive cache: write through
Dec 31 17:07:26 Workstation-B kernel: sd 7:0:0:0: [sdc] Assuming drive cache: write through
Dec 31 17:07:26 Workstation-B kernel: sd 7:0:0:0: [sdc] Assuming drive cache: write through
Jan  2 09:07:59 Workstation-B abrtd: Init complete, entering main loop
Jan  2 09:08:01 Workstation-B libvirtd: Could not find keytab file: /etc/libvirt/krb5.tab: No such file or directory
Jan  2 09:11:06 Workstation-B pulseaudio[3273]: pid.c: Daemon already running.
Jan  2 10:38:08 Workstation-B kernel: ctxfi: PLL initialization failed!!!
Jan  2 10:38:08 Workstation-B kernel: ctxfi: Preparing pcm playback failed!!!
Jan  2 10:38:08 Workstation-B kernel: ctxfi: PLL initialization failed!!!
Jan  2 10:38:08 Workstation-B kernel: ctxfi: Preparing pcm playback failed!!!
Jan  2 10:38:08 Workstation-B kernel: ctxfi: PLL initialization failed!!!
Jan  2 10:38:08 Workstation-B kernel: ctxfi: Preparing pcm playback failed!!!
Jan  2 11:02:28 Workstation-B automount[2440]: lookup_read_master: lookup(nisplus): couldn't locate nis+ table auto.master
Jan  2 11:02:28 Workstation-B mcelog: failed to prefill DIMM database from DMI data
Jan  2 11:02:28 Workstation-B mcelog: mcelog read: No such device
Jan  2 11:02:29 Workstation-B abrtd: Init complete, entering main loop
Jan  2 11:02:31 Workstation-B libvirtd: Could not find keytab file: /etc/libvirt/krb5.tab: No such file or directory
Jan  2 11:25:14 Workstation-B pulseaudio[4202]: pid.c: Daemon already running.
Jan  2 11:25:14 Workstation-B pulseaudio[4203]: pid.c: Daemon already running.
Jan  2 11:25:14 Workstation-B pulseaudio[4204]: pid.c: Daemon already running.
Jan  2 11:56:36 Workstation-B automount[2455]: lookup_read_master: lookup(nisplus): couldn't locate nis+ table auto.master
Jan  2 11:56:36 Workstation-B mcelog: failed to prefill DIMM database from DMI data
Jan  2 11:56:36 Workstation-B mcelog: mcelog read: No such device
Jan  2 11:56:37 Workstation-B abrtd: Init complete, entering main loop
Jan  2 11:56:38 Workstation-B libvirtd: Could not find keytab file: /etc/libvirt/krb5.tab: No such file or directory
Please SCAN THROUGH THIS LOGS AND HELP ME FIND A SOLUTION !!!!!

Is it possible that my Log files gets too big sometimes that it causes the crash? !!!!!!

Last edited by onebuck; 01-02-2013 at 07:30 AM. Reason: clean up post by using vbcode tags
 
Old 01-01-2013, 10:59 PM   #2
foodown
Member
 
Registered: Jun 2009
Location: Texas
Distribution: Slackware
Posts: 609

Rep: Reputation: 218Reputation: 218Reputation: 218
Have you run memtest86 on this workstation?

Based on the errors and your description of the malfunctions, I'd suspect that a DIMM was failing.
 
Old 01-01-2013, 11:36 PM   #3
JBJ1962
LQ Newbie
 
Registered: Dec 2012
Posts: 12

Original Poster
Rep: Reputation: Disabled
DIMM

NO I haven't RUN memtest86+ , should I ? ! !

I searched DIMM , but Every link I browsed Said that this DIMM thing is harmless , So I tried other things , actually a week ago I used to see another error which Im not seeing now ,The Error was something like this ---> radeon 0000:03:00.0: IH ring buffer overflow (0x00000031, 0, 65600)
Anyway , Something is wrong with my workstation and I can't figure that out sometimes it works ok but some other times hanging after hanging
please go through my LOG and share Ur opinion, thanks a lot 4 ur quick reply foodown :-bd

Quote:
Originally Posted by foodown View Post
Have you run memtest86 on this workstation?

Based on the errors and your description of the malfunctions, I'd suspect that a DIMM was failing.

Last edited by JBJ1962; 01-01-2013 at 11:42 PM.
 
Old 01-01-2013, 11:53 PM   #4
JBJ1962
LQ Newbie
 
Registered: Dec 2012
Posts: 12

Original Poster
Rep: Reputation: Disabled
ACTUALLY Recently I GET THIS ERRORS A LOT : !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

Jan 2 10:37:58 Workstation-B kernel: ctxfi: PLL initialization failed!!!
Jan 2 10:37:58 Workstation-B kernel: ctxfi: Preparing pcm playback failed!!!
Jan 2 10:37:59 Workstation-B kernel: ctxfi: PLL initialization failed!!!
Jan 2 10:37:59 Workstation-B kernel: ctxfi: Preparing pcm playback failed!!!
Jan 2 10:37:59 Workstation-B kernel: ctxfi: PLL initialization failed!!!
Jan 2 10:37:59 Workstation-B kernel: ctxfi: Preparing pcm playback failed!!!
Jan 2 10:38:08 Workstation-B kernel: ctxfi: Preparing pcm playback failed!!!

and
Dec 31 16:05:22 Workstation-B gdm-simple-slave[5811]: GLib-GObject-CRITICAL: g_signal_handlers_disconnect_matched: assertion `G_TYPE_CHECK_INSTANCE (instance)' failed
Dec 31 16:05:22 Workstation-B gdm-simple-slave[5811]: GLib-GObject-CRITICAL: g_signal_handlers_disconnect_matched: assertion `G_TYPE_CHECK_INSTANCE (instance)' failed


Can it be my rsyslog
or SOUND CARD which I don't need at all might as well disable it!
 
Old 01-02-2013, 09:05 AM   #5
foodown
Member
 
Registered: Jun 2009
Location: Texas
Distribution: Slackware
Posts: 609

Rep: Reputation: 218Reputation: 218Reputation: 218
Quote:
Originally Posted by JBJ1962 View Post
NO I haven't RUN memtest86+ , should I ? ! !
It couldn't hurt.

Boot from a system recovery CD or DVD; most of them have a memtest86 option in the bootloader. If nothing else, I know that Ubuntu install CDs have this option available.

Quote:
I searched DIMM , but Every link I browsed Said that this DIMM thing is harmless
When I said DIMM I was referring to a memory module. You could have age-related errors creeping into one of your memory modules.
 
1 members found this post helpful.
Old 01-06-2013, 09:49 PM   #6
JBJ1962
LQ Newbie
 
Registered: Dec 2012
Posts: 12

Original Poster
Rep: Reputation: Disabled
Thumbs up

[QUOTE=foodown;4861266]It couldn't hurt.

Boot from a system recovery CD or DVD; most of them have a memtest86 option in the bootloader. If nothing else, I know that Ubuntu install CDs have this option available.


Dear Foodown

Hi
I installed memtest86+ from a centos 6.2 CD , I don't know how and what to do exactly with it, Do you know of any tutorial or link that can help understand how to use MEMTEST on Centos ? thanks a lot.
 
Old 01-07-2013, 05:26 PM   #7
foodown
Member
 
Registered: Jun 2009
Location: Texas
Distribution: Slackware
Posts: 609

Rep: Reputation: 218Reputation: 218Reputation: 218
I would recommend running it from a bootable CD or DVD as I've described.

Since you're testing the system's memory and not anything having to do with the installed operating system, there is no need to worry about doing it "on CentOS."

Since memtest86+ does read and write testing on all of the address space in your RAM, I don't think it is the kind of utility that you'd want to run on a system with living processes anyway.
 
1 members found this post helpful.
Old 01-07-2013, 06:55 PM   #8
JBJ1962
LQ Newbie
 
Registered: Dec 2012
Posts: 12

Original Poster
Rep: Reputation: Disabled
I know what you say, but what I ended up doing was to put a centos CD in the CD ROM and then I searched for memtest86+ .rpm , i doubled clicked on it and the system said its installed. then I typed a command like /sbin/usr/setup-memtest something like this to put it in GRUB menu, I read instructions in Google, Is it OK?

Funnily though it has NOT crashed since yesterday morning as I revert back my kernel version to an older one using another Centos kernel in GRUB menu !!! Do you have any opinion on this?

thanks a lot 4 ur reply
 
Old 01-08-2013, 02:35 PM   #9
foodown
Member
 
Registered: Jun 2009
Location: Texas
Distribution: Slackware
Posts: 609

Rep: Reputation: 218Reputation: 218Reputation: 218
Quote:
Originally Posted by JBJ1962 View Post
Funnily though it has NOT crashed since yesterday morning as I revert back my kernel version to an older one using another Centos kernel in GRUB menu !!! Do you have any opinion on this?
It suggests that the hanging behavior was driver/interrupt related; maybe it was the driver for your sound card, as you'd suspected.
 
Old 01-08-2013, 07:57 PM   #10
JBJ1962
LQ Newbie
 
Registered: Dec 2012
Posts: 12

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by foodown View Post
It suggests that the hanging behavior was driver/interrupt related; maybe it was the driver for your sound card, as you'd suspected.
Can it be Fatal? Is there anyway to completely disable this issue , I don't need sound, I don't want this frustrating problem caused by something as simple as sound card !!!
 
Old 01-10-2013, 04:21 AM   #11
foodown
Member
 
Registered: Jun 2009
Location: Texas
Distribution: Slackware
Posts: 609

Rep: Reputation: 218Reputation: 218Reputation: 218
Quote:
Originally Posted by JBJ1962 View Post
Can it be Fatal? Is there anyway to completely disable this issue , I don't need sound, I don't want this frustrating problem caused by something as simple as sound card !!!
You can blacklist the kernel module, as described here:

http://linux-bsd-sharing.blogspot.co...odules-on.html

It looks like the module for your card is called 'ctxfi' ...

So ...
Code:
echo "blacklist ctxfi" >> /etc/modprobe.d/blacklist.conf
... as root should do it.
 
Old 01-15-2013, 07:29 PM   #12
JBJ1962
LQ Newbie
 
Registered: Dec 2012
Posts: 12

Original Poster
Rep: Reputation: Disabled
I did this command , I blacklisted ctxfi and snd_ctxfi which appeared in my lsmod , but the problem is still there, I ran memtest as well and it showed no errors.

So now I don't know what to do exactly
 
  


Reply

Tags
centos, crash, crashes, hang, kernel


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Can ssh to LDAP client workstation running CentOS 6.3 but cannot "su" on workstation scott.anderson Linux - Desktop 2 09-27-2012 04:41 PM
[SOLVED] Installing VMWare Workstation 8 on CentOS 6.2 samdizzy Linux - Newbie 1 03-01-2012 02:21 PM
I cannot install VMware workstation on CentOS. corone Linux - Virtualization and Cloud 2 07-26-2010 02:28 PM
nfslock hangs on boot with diskless workstation wmakowski Fedora 5 02-14-2008 05:02 PM
VMware Workstation and Linux. No way to start it, it hangs always. sblantipodi Fedora 5 01-16-2008 05:31 PM


All times are GMT -5. The time now is 05:44 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration