LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices



Reply
 
Search this Thread
Old 07-24-2005, 05:37 PM   #1
junger
LQ Newbie
 
Registered: Jul 2005
Distribution: FC3
Posts: 14

Rep: Reputation: 0
CDRom works under /Root, not under non-/root


Hey, newbie to Linux here!
Anyway.... I am working with fedora core 3, linux kernel 2.6.9-1.667 on a Pentium 2 500mhz computer, with a S3 Savage4 AGP card, Soundblaster AWE 32, ~300MB ram, 13GB HDD (Linux) dualbooting with 4GB HDD (Windows 98), 2 cdroms (both non-writers).
I have not been able to update any aspect of Linux, as I am not able to hook up a modem yet (this is another problem I need help on...later, though. not as important)
When I am under the /root user, I can play audio cd's no problem. under a different user, though... using just the regular cdplayer that comes with fc3, I get "drive error". I've tried other programs as well. No good. Under my Windows installation, cdrom works fine.
Jason
 
Old 07-24-2005, 10:02 PM   #2
junme
Member
 
Registered: Oct 2004
Location: ~/.au
Distribution: Mepis Kanotix SUSE
Posts: 189

Rep: Reputation: 31
seems like you need to allow users to acess the cdrom
an easy way if u use kde is use kuser as root look at the users groups and add them to group cdrom
not sure how FC is set up but generaly there is a file /etc/group which stores this info
hope this helps :-)
 
Old 07-25-2005, 01:09 AM   #3
junger
LQ Newbie
 
Registered: Jul 2005
Distribution: FC3
Posts: 14

Original Poster
Rep: Reputation: 0
Um... yeah. I'm a newbie, so you might have to walk me through this one...
do you mean log on as "root"?
there is no entry under "etc/groups" that says "cdrom"
I can read data cd's no problem under either user acct, but only "/root" can play audio cds.
I could have a "helper problem" as well, that might guide you to the correct solution. I have a USB flash drive (lexar jumpdrive secure) and under "/root" I can access this no problem, it shows on the desktop. But under "jason" (that's my main login) i get the error:
"Unable to mount the selected volume
mount: only root can mount /dev/sda1 on /mnt/public_a"
this installation of FC3 is only a week old, so one would think that there should be no errors in the subsystem. But, I already had to deal with a login issue, where the system tried to look up some internet thing reguarding "localhost.localdomain"
Ach.... this is getting annoying. Then again, linux was (is) written by practically millions of people!
 
Old 07-25-2005, 02:49 AM   #4
junger
LQ Newbie
 
Registered: Jul 2005
Distribution: FC3
Posts: 14

Original Poster
Rep: Reputation: 0
oh... actually... i figured it out. but not fully in the way you told me.
For the cdroms... I had to add "jason" to the "disk" group. Do you know if there will be any problems from that?
And for the USB drive... this was weird. I thought that if I couldn't use "jason" normally to access the flash drive, what if I ran "mount dev/sda1 mnt/public_a" under terminal. Well, I tried that, and got some error saying something like "only root can do that". So I thought what if I switched users, without switching users? Staying logged under "jason", I ran "su root" under terminal, switched to root that way, and reran the mount command. IT WORKED, but I think there should have been a more straightforward way to do this. IE, not have to go through that procedure for each user.
 
Old 07-25-2005, 02:52 AM   #5
Nylex
LQ Addict
 
Registered: Jul 2003
Location: London, UK
Distribution: Slackware
Posts: 7,464

Rep: Reputation: Disabled
Edit: never mind now!
 
Old 07-25-2005, 11:30 AM   #6
Walman
Member
 
Registered: Jun 2004
Location: Venezuela
Distribution: RHEL ,Centos,Debian,Slax , Solaris
Posts: 94

Rep: Reputation: 15
Junger

Root can only mount files by default and unless you specify that other user can do it , you are stuck to that law . Erlier , Member junme supplied you with the answer .
What environment are you running ? kde , gnome , other ??
 
Old 07-25-2005, 08:26 PM   #7
junger
LQ Newbie
 
Registered: Jul 2005
Distribution: FC3
Posts: 14

Original Poster
Rep: Reputation: 0
I use gnome, but KDE is installed also.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Mozilla works only when root larsma Linux - Software 1 10-21-2004 04:49 PM
X only works with root user joe83 Slackware 14 09-06-2004 09:17 AM
Sound only works as root spiezer Linux - Newbie 2 05-16-2004 06:36 PM
IntelliMouse thumb buttons work as root, broken as non-root user, wheel works always digital vortex Linux - Hardware 7 03-02-2004 05:14 PM
root files: create as root:root or root:wheel? pcass Linux - Security 1 02-07-2004 05:14 PM


All times are GMT -5. The time now is 10:58 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration