LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (http://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   CDROM mounting problem => /dev/cdrom is not a valid block device (http://www.linuxquestions.org/questions/linux-hardware-18/cdrom-mounting-problem-%3D-dev-cdrom-is-not-a-valid-block-device-154201/)

Vizy 03-06-2004 10:19 AM

CDROM mounting problem => /dev/cdrom is not a valid block device
 
Hello,

I have encountered a problem when tryin to mount a CD-ROM.
I am using Slackware 9.1 and i had previously no problems with my CD rom.

Everything worked just fine on my first slackware install. But now im getting this message when
trying to mount :

mount /mnt/cdrom
mount: /dev/cdrom is not a valid block device

/mnt/cdrom exsits.

I have read several other threads with similar problem but i haven found a solution.

If someone has any idea what should i do plz let me know. Else i can still install the whole thing again.

320mb 03-06-2004 10:33 AM

Please post your /etc/fstab
and make sure that /dev/cdrom is a symlink to /dev/hdc

fancypiper 03-06-2004 10:38 AM

/dev/cdrom is a symbolic link to the actual device. Is it a plain CDROM, CD-RW or what exactly? Without knowing the hardware, I don't know what the actual device is.

# Managing drives
LNAG - Accessing my drives
Rute - Device Mounting

UnrulyGrrl99 03-06-2004 03:41 PM

When you first boot up, did you see that the kernel reconized your cdrom as an IDE device?
Is it an IDE device (or scsi)? Mine for example shows up as "/dev/hdc", which i have a symbolic link
from to /dev/cdrom. Check your
Code:

dmesg
output to see if the drive was recognized.
My dmesg shows this:
hdc: ATAPI 24X DVD-ROM CD-R/RW drive, 2048kB Cache
Uniform CD-ROM driver Revision: 3.12
Do you have cdrom support compiled into the kernel itself? or as a module?

Vizy 03-08-2004 11:38 AM

Thnx for all your help guys, but everything you said was fine.
i have just formated the disk and installed slackware 9.1 again from scratch, because it was a fresh install and my kernel wasn't even configured yet.

Now everything works just fine and i did everything just as the first time.
I don't have a clue what went wrong before.

Thnx again and goodbye :)

Vaitya 12-17-2004 09:17 AM

Block Device not Valid
 
Hey all, a few weeks ago I formatted my data hard drive. I made it a fat32 type (using windows fdisk). Formerly it had been split between BSD and Win32, however I was unsuccessful in my learning attempt on BSD so I just have Mandrake 10.1 and win98 again.

Now, when I started MDK 10.0 again I was unable to mount hdc2. It says that it is not a valid block device at least twice when I boot into MDK.

I checked in /dev and have discovered that there is a directory named hdc2 but no block device file. Something has apparently damaged the file.

The drive was formerly mounted successfully as a fat32 mount on hdc2 and worked flawlessly.

I attempted the "dmesg" that was in a previous post in this thread and I came up with "hdc: ST3120026A, ATA DISK drive". MDK seems to do something to mount hdc to dev hdc2. As I said, the drive was formerly mounted at hdc2 and worked fine until I started playing with BSD. It even worked after I had BSD installed, but I could not access the BSD portion of the drive through MDK. Once I fdisked the BSD and windows partitions and remade a new win partition is when all of the issues started.

Anyway, is it possible to rebuild a block device file for hdc2?

fancypiper 12-17-2004 01:11 PM

A couple of questions:

1. Have you done a scandisk on that drive in Windows?
2. Does the bios recognise the drive as being attached to the machine?
3. Post the output of the command fdisk -l
4. Have you examined the disk with fdisk /dev/hdc? I only have one ext3 partition on mine:
Code:

root@tinwhistle ~ # fdisk /dev/hdc
 
The number of cylinders for this disk is set to 19457.
There is nothing wrong with that, but this is larger than 1024,
and could in certain setups cause problems with:
1) software that runs at boot time (e.g., old versions of LILO)
2) booting and partitioning software from other OSs
  (e.g., DOS FDISK, OS/2 FDISK)
 
Command (m for help): p
 
Disk /dev/hdc: 160.0 GB, 160041885696 bytes
255 heads, 63 sectors/track, 19457 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
 
  Device Boot    Start      End    Blocks  Id  System
/dev/hdc1            1    19457 156288321  83  Linux
 
Command (m for help):

If you have a /dev/MAKEDEV script in your distro, you could run that and see if it will make the devices.

# Mandrake links
Mandrake home page
Mandrake Users website (needs money to access now)
Software management configuration: Easy urpmi config for Mandrake
Software management: urpmi mini-HOWTO
Software management: All You Ever Wanted to Know About Urpmi But Never Dared Asking Before
You didn't install the developmental packages? As root, command:
urpmi gcc
An Introduction to the Midnight Commander. You can install it by commanding:
urpmi mc
Midnight Commander home page

floppy_stuttgart 11-04-2010 03:49 PM

CDROM booted but content not indicated
 
Hello,

thanks this post and the indicated links, I could mount my CDROM in DamnSmallLinux by
doing

mount -t iso9660 /dev/cdaudio /mnt/cdrom

Unfortunately the ls-l dont show any content (this CDROM has files.. this is indicated in the CDROM of my wife which has Ubuntu 10.04).
The content of /mnt/auto/cdrom indicate the files by using emelFM 0.9.2.
But how to copy the files into the directory indicated on the left side?

Can somebody help and indicate the way of copying files from this CDROM into a directory?

Thanks
Pascal

System: AMD K6-2 450, 780MB RAM, 6GB HDD, CDROM, USB (not mounted.. too), FritzWLAN USB (I am trying to connect with ndiswrapper and the files are on this CDROM), Damnsmalllinux with frugal install on HDD

floppy_stuttgart 11-04-2010 04:46 PM

sorry..
 
Beginner failure.. I had to mount under superuser then make a manual "cp from CDROM .. to directory" then this was ok.
Pascal


All times are GMT -5. The time now is 06:23 PM.