LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (http://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   Can't record from Mic (http://www.linuxquestions.org/questions/linux-hardware-18/cant-record-from-mic-378504/)

sabre307 10-31-2005 12:02 AM

Can't record from Mic
 
Linux localhost 2.6.8.1-12mdk #1 Tue Feb 22 16:05:56 EST 2005 i686 Intel(R) Pentium(R) 4 CPU 1.60GHz unknown GNU/Linux

Running Mandrake 10.1, using a SB PCI512 soundcard. Everything sound wise works fine, I can even hear a side tone from the mic in the headset, but no matter what I try I have yet to be able to get any sound to record to a file. I have tried plugging in to the mic and line inputs on the sound card. I have tried changing permissions on /dev/dsp to 777. I have played with the alsamixer until I'm cross-eyed. I've even tried numerous recording tools, including rosegarden, ardour, audacity, arecord, and the plain ol vanilla kde sound recorder. If anyone has any idea as to what I can do, please let me know. I would really like to get this computer to record. Thanks!

ciotog 10-31-2005 01:37 AM

Try running alsamixer, press F4, then make sure that the correct input is set as the recording device (by pressing 'space'). In general line in is much better quality than mic. You also might need to increase input gain as well to see any waveform. If you find alsamixer hard to work with you could try aumix as well.

sabre307 10-31-2005 07:31 PM

Tried what you said, had actually already done it, but figured it wouldn't hurt to try. Still no joy. Any other suggestions. It just baffles me that I can hear myself, but I'm just not getting any recording. Tried messing with Jack, but I'm not really sure if I did anything right with that or not. Thanks for the quick reply though.

ciotog 11-01-2005 02:44 PM

You really shouldn't be able to hear yourself - when recording it's best to mute the input. Maybe by default if you're not muted it won't record to avoid feedback. In other words, try muting the input. You can use a tool like ameter with arecord to see the input levels:
Code:

arecord -D ameter -f cd a.wav

SlackerLX 11-01-2005 03:03 PM

There may be also permission problem. Try resolving it by:
Code:

chgrp audio /dev/dsp
chgrp audio /dev/dsp*
 or
 
chmod 777 /dev/dsp
or
chmod 666 /dev/dsp !!!! DANGEROUS for Security


ciotog 11-01-2005 03:11 PM

Add yourself to the audio group as well:
Code:

gpasswd -a user audio

sabre307 11-06-2005 09:38 PM

I've tried all of that. I've even tried recording as root using sudo. Recording as root should resolve any permission problems. I'm starting to think it's something with the driver for the sound card. Everything works fine under XP.

ciotog 11-07-2005 12:10 AM

Am I safe to assume you've already run alsaconf?

spuzzzzzzz 12-31-2005 06:54 PM

Kind of an old thread, but maybe this will be useful anyway...

The microphone has 2 sets of levels, capture and playback. The playback level controls how loudly you hear the mic, the capture level controls how loudly the mic records. In order to set the capture levels (instead of the playback levels as is the default), start alsamixer with "alsamixer -V capture"

Treviño 04-15-2006 11:26 AM

Quote:

Originally Posted by spuzzzzzzz
Kind of an old thread, but maybe this will be useful anyway...

The microphone has 2 sets of levels, capture and playback. The playback level controls how loudly you hear the mic, the capture level controls how loudly the mic records. In order to set the capture levels (instead of the playback levels as is the default), start alsamixer with "alsamixer -V capture"

Thanks so much... I didn't know the 2 levels mic... So, simply using KDE's KMix I've opened the mixer and just enabled the «Capture» «Input» interface and actived Mic (both "green" and "red" lights"). Now my krecorder works good.

Many thanks ;)

dmcinnis63 05-27-2006 07:06 PM

It worked for me too
 
Thank you,

I had the exact same problem with my SoundBlaster Live.

I run Fedora Core and now my microphone works perfectly!


Dave


All times are GMT -5. The time now is 08:01 AM.