LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (http://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   Can't Play Audio CDs (http://www.linuxquestions.org/questions/linux-hardware-18/cant-play-audio-cds-285552/)

Soobwrex 02-02-2005 09:12 PM

Can't Play Audio CDs
 
Using Fedora Core 3
KDE Desktop
on Sony Vaio Laptop

Thanks to all who help in these forums...
After fresh install of Fedora Core 3 (Along with the Autorun utility that automatically mounts CDs), I can't play Audio CD's KsCD gives error message:

~~~~~~~~~~~~~~~~
CD-ROM Read or Access error (or no audio disk in drive).
Please make sure you have access permissions to:
/dev/cdrom
~~~~~~~~~~~~~~~~

However I don't have a /dev/cdrom file. The systems mounts data cd's fine. So issued the comand:

~~~~~~~~~~~~~~~~
$ dmesg|grep CD
hdc: UJDA730 DVD/CDRW, ATAPI CD/DVD-ROM drive
hdc: ATAPI 24X DVD-ROM CD-R/RW drive, 2048kB Cache, UDMA(33)
Uniform CD-ROM driver Revision: 3.20
~~~~~~~~~~~~~~~~

when issue a mount command from the terminal, i get:
$ mount /dev/hdc
/dev/hdc: Input/output error
mount: /dev/hdc: can't read superblock

Here is a listing of fstab:

~~~~~~~~~~~~~~~~
# This file is edited by fstab-sync - see 'man fstab-sync' for details
LABEL=/ / ext2 defaults 1 1
none /dev/pts devpts gid=5,mode=620 0 0
none /dev/shm tmpfs defaults 0 0
none /proc proc defaults 0 0
none /sys sysfs defaults 0 0
LABEL=SWAP-hda3 swap swap defaults 0 0
/dev/hdc /media/cdrecorder auto pamconsole,ro,exec,noauto,managed 0 0
/dev/fd0 /media/floppy auto pamconsole,exec,noauto,managed 0 0
~~~~~~~~~~~~~~~~

Anyhelp would be greatly appreciated. Thanks.

beaucoup 02-02-2005 10:22 PM

Configure your CD drive device in KsCD to be /dev/hdc instead of /dev/cdrom (it's under Configure, under Extras).

Alternately, you could log in as root and make a symlink from /dev/cdrom to /dev/hdc

ln -s /dev/hdc /dev/cdrom

The latter method may save you additional headaches in the future, since a lot of programs assume that such a link will already exist (like KsCD, for example).

reddazz 02-02-2005 11:48 PM

Also you may need to give yourself read permissions to the CD drive e.g.
#chmod a+r /dev/cdrom (or whatever your cd drive is)

Soobwrex 02-03-2005 02:40 PM

Configuration and link NOT saved
 
Thanks for the reply guys. However, when I do those actions, after a reboot, it looks as if I never made the changes - the link is gone and the permissions to /dev/hdc are back the way they were. Does this have something to do with the fstab file maybe (forcing) certain options on the CDROM drive. I started a new thread in the software section, because I thought that it might be a KDE or Fedora issue. Any ideas would be greatly appreciated.

Thanks

here is the link to the new thread if you want to post there

http://www.linuxquestions.org/questi...hreadid=285794

reddazz 02-03-2005 04:46 PM

Try putting yourself in the audio and cdrom groups.

Soobwrex 02-03-2005 05:28 PM

Thanx reddazz. I will try that. I didn't know those gorups existed. Just curious (new to Linux): How do I find a list of all the groups there are? (and what are they for)

reddazz 02-03-2005 05:57 PM

You can use a tools such as kuser or gnome system tools. Alternatively you can just do
$cat /etc/group
a list will be printed on the screen. To find out what groups you are in, you can run the command "groups" in a console.

Soobwrex 02-03-2005 07:47 PM

groups do not exist
 
I think we're getting closer. The only problem is that I don't have audio or cdrom groups. One interesting thing is that when I log on as root. CD's play fine. I anticipate that I need to be a member of one of the groups that root is, but I want to be sure of which one so I don't screw anything up. Here is a listing of /etc/group
Thanks again for all your help.


root:x:0:root
bin:x:1:root,bin,daemon
daemon:x:2:root,bin,daemon
sys:x:3:root,bin,adm
adm:x:4:root,adm,daemon
tty:x:5:
disk:x:6:root
lp:x:7:daemon,lp
mem:x:8:
kmem:x:9:
wheel:x:10:root
mail:x:12:mail
news:x:13:news
uucp:x:14:uucp
man:x:15:
games:x:20:
gopher:x:30:
dip:x:40:
ftp:x:50:
lock:x:54:
nobody:x:99:
users:x:100:
dbus:x:81:
floppy:x:19:
vcsa:x:69:
nscd:x:28:nscd,wes
rpm:x:37:
haldaemon:x:68:
utmp:x:22:
netdump:x:34:
slocate:x:21:
sshd:x:74:
rpc:x:32:
rpcuser:x:29:
nfsnobody:x:65534:
mailnull:x:47:
smmsp:x:51:
pcap:x:77:
xfs:x:43:
ntp:x:38:
gdm:x:42:
wes:x:500:

Soobwrex 02-04-2005 03:29 AM

Well it works good being a member of group disk; but after I'm done playing a CD and put in a data CD, i can't mount it - some error like /media/cdrecorder is busy. Weird... I have to reboot to get it to work or in some cases, just wait a random amount of time (over 10 minutes). I know I'm dragging this out from issue to another, but I've already learned alot. Thanks so much reddazz (and the rest of you).

Soob

reddazz 02-04-2005 11:20 AM

That sometimes happens to me on my Slack system, I have to wait a few minutes after ejecting a cd from my dvd drive before the system recognises that it's empty. I don't know what causes this.

Soobwrex 02-04-2005 03:32 PM

Are you running KDE on your slackware? Have you noticed if it happens in X, GNOME, or only KDE? Thanks for all the help by the way. Being a member of group "disk" was all it took.

S

reddazz 02-05-2005 03:34 AM

I run KDE, on my Slack box, but occassionally use Fluxbox or Windowmaker. I am gonna try it out in a console session as well as Fluxbox and Windowmaker, to see if it makes a difference.

Soobwrex 02-07-2005 12:11 AM

I'd be interested in knowing how that works for you...
WHat is Fluxbox and Windowmaker?
I've only heard of X, GNOME, and KDE.

reddazz 02-07-2005 08:58 AM

They are window managers whereas GNOME, KDE and XFCE are desktop environments. Windowmaker, fluxbox and other window managers are very minimalistic, so they don't have all the fancy menus etc, just clean simple interfaces. There are some screenshots at fluxbox's and windowmakers' home pages.

Soobwrex 02-10-2005 02:39 AM

been a great help
 
redazz,
you've been a great help, thanks. I ended up trying out Mandrake 10.1 and really like it - no problems with the CD stuff. Thanks again - I really learned alot.

S


All times are GMT -5. The time now is 02:38 AM.