LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (http://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   Can't install NVIDIA proprietary driver in Slackware 13.1 (http://www.linuxquestions.org/questions/linux-hardware-18/cant-install-nvidia-proprietary-driver-in-slackware-13-1-a-836866/)

bonixavier 10-07-2010 10:45 PM

Can't install NVIDIA proprietary driver in Slackware 13.1
 
1 Attachment(s)
I've been trying to install the driver for my NVIDIA GeForce 6150SE nForce 430 in Slackware 13.1 with no success. I always get the same error report: the module you're trying to build does not match the kernel source or something like that. The result: unable to build module and the installation crashes.

I have tried to:
  • set a custom kernel source path,
  • install it with the slackbuilds driver and kernel,
  • extract the contents and trying to compile it myself,
  • find possibly conflicting drivers or modules,
  • use different versions of the same driver (I've tried installing the versions 256.53, 256.44, 195.36.31 and 173.14.27)
  • recompile the Linux kernel in an attempt to make sure that the tools used to build the kernel were the same used o build the module.

The only time I got a different error message was when I used the slackbuild packages. It built the 'nvidia.ko' module, but it didn't work. I got a version magic notice when booting and, when I tried to start x, a fatal error "no screens were found."

Just to be sure, I made a clean full install of Slackware (only added WICD to be able to download the drivers and ran slackpkg update and upgrade all) and tried again. It didn't work.

I have browsed as much as I could, but now I gave up. Can anybody help me, please? If you need me to post any logs, the actual messages that were displayed, etc. I'll do it ASAP. Just don't ask me to recompile the kernel again unless you're damn sure it will work because it takes forever to do that and it would be frustrating to go through that for the third time without success.

Thanks in advance!

Nikosis 10-07-2010 11:48 PM

I assume you use 32bit version. So you should use only 256.53 or one of the previous versions, not 195.x.x nor 173.x.x.
Can you post xorg log

disturbed1 10-08-2010 12:02 AM

/proc/config.gz
/boot/config
and
/usr/src/linux/.config
Should all match.
/usr/src/linux should be or link to the current running kernel.
/usr/src/linux should be in a ready state --- make prepare.

bonixavier 10-08-2010 07:02 AM

2 Attachment(s)
Quote:

Originally Posted by Nikosis (Post 4121140)
I assume you use 32bit version. So you should use only 256.53 or one of the previous versions, not 195.x.x nor 173.x.x.
Can you post xorg log

I installed the slackbuilds package again (256.44) so I posted 2 logs: one from before it was installed and the current one.
Looking at it now, I see that X has been trying to load "dri", but I commented it out in the xorg.conf. That might be the cause of my problems because the nvidia readme file states that that module should be disabled. Or maybe it's something else. It also asks me to check the kernel log for details so I attached it too on the OP because I couldn't do it here.
By the way, should I use another format for them? It seems they still keep the same permissions requirements they had. Maybe copy/paste would be better?

Quote:

Originally Posted by disturbed1 (Post 4121147)
/proc/config.gz
/boot/config
and
/usr/src/linux/.config
Should all match.
/usr/src/linux should be or link to the current running kernel.
/usr/src/linux should be in a ready state --- make prepare.

So, /usr/src/linux is a link to /usr/src/linux/2.6.33.4. Is that the running kernel? I ran make prepare there. I have a question: how can I make sure that /proc/config.gz is the same as the other two files? I tried to open it to check, but it's a binary.

Guys, thanks for the support. Any other information you need, just ask.

brianL 10-08-2010 07:20 AM

Quote:

NVIDIA GeForce 6150SE nForce 430
Same as mine, in my desktop. I didn't use the SlackBuild, but downloaded and ran (as root, at runlevel 3) the latest driver from the NVidia website. And everything is OK.

bonixavier 10-08-2010 07:24 AM

Quote:

Originally Posted by brianL (Post 4121413)
Same as mine, in my desktop. I didn't use the SlackBuild, but downloaded and ran (as root, at runlevel 3) the latest driver from the NVidia website. And everything is OK.

I envy you so much! grrr...

brianL 10-08-2010 07:28 AM

Well, try it yourself, get the 256.53 from here:
http://www.nvidia.com/object/unix.html

bonixavier 10-08-2010 07:32 AM

Quote:

Originally Posted by brianL (Post 4121422)
Well, try it yourself, get the 256.53 from here:
http://www.nvidia.com/object/unix.html

I did. That's where I started. I began experimenting different paths when it was not working. The installer always crashes - it is unable to build the kernel. Apparently, the slackbuilds script could do it, but I can't get X to start without some further tweaking that I don't know how to do.

brianL 10-08-2010 07:43 AM

I don't know the solution, but it might be better if you got this thread moved to the Slackware forum.

Nikosis 10-09-2010 03:09 PM

What exactly did you do, when recompiling the kernel?
Did you have it working before?

bonixavier 10-09-2010 05:00 PM

Quote:

Originally Posted by Nikosis (Post 4122390)
What exactly did you do, when recompiling the kernel?
Did you have it working before?

Just changed some settings, such as adding the appropriate processor, but keeping the rest of the config unaltered. However, I am NOT running a recompiled kernel. I am trying to install this friendly driver in a clean install of Slackware 13.1. The only things that are different from what came from the full install are:
1-installed wicd.
2-slackpkg update and slackpkg upgrade-all,
3-slackbuilds driver and kernel + the executable from nvidia's website.

As to the other question, it has never worked in Slackware. I could get it working in Ubuntu 10.04.

GazL 10-09-2010 05:21 PM

I prefer to use the NVIDIA.run installer rather than the slackbuilds.org packages and it's always worked for me.

Have you switched to running the 'generic' kernel, initrd & modules rather than the initial 'huge' install kernel. If not then you might want to do that before trying to install the proprietary nvidia driver. Have a read of /boot/README.initrd if you need any guidance on that.

You also need to ensure that the kernel source for your running kernel is installed or the nvidia kernel module won't build.

Alien Bob 10-09-2010 05:21 PM

You are running a non-SMP kernel in 32-bit Slackware ("/boot/vmlinuz-huge-2.6.33.4" according to your X.Org logfile).

If you run a non-SMP kernel (why? it would only be required on old hardware usually) you have to tweak the installed kernel source. SLackware's kernel source package has been pre-configured to generate kernel modules for a SMP kernel. That is why you get those "version magic" errors.
If you want to build kernel modules for a non-SMP kernel, then use the information you find here: http://slackware.osuosl.org/slackwar...3.4-nosmp-sdk/ to "patch" your copy of the kernel source.

After you do that, building a NVIDIA kernel module will no longer fail.

Eric

bonixavier 10-09-2010 05:34 PM

Quote:

Originally Posted by Alien Bob (Post 4122473)
If you run a non-SMP kernel (why? it would only be required on old hardware usually) you have to tweak the installed kernel source.

I also wonder why. I didn't type in the huge option when installing. I chose a full install and might have missed it when I got the option to select the kernel. Is there anyway I can switch to the SMP one? I suppose most things I try to install will bring me the same problems. Is that something I can still do or is it an installation option?

Either way, I'll look into what was suggested and report back.

Thanks guys!

GazL 10-09-2010 05:47 PM

Converting to use the 'generic-smp' (or just 'generic' on x86_64) kernel is a manual step you have to do post install. The details are in that README.initrd file I mentioned in my post above.

This is one of those little slackware quirks you have to get used to. Personally I wish Pat would just do away with the 'huge' kernels and have the install dialogs set this up for the user.


All times are GMT -5. The time now is 06:39 PM.