LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 11-20-2007, 12:03 PM   #1
b2bwild
Member
 
Registered: Nov 2007
Location: India
Distribution: Ubuntu, Debian, LFS, Fedora
Posts: 30

Rep: Reputation: 15
Cant enable desktop effects on Fedora 8


I recently upgraded to Fedora 8..
I have nVidia GeForce FX 5200 card..
I cant enable desktop effects in GNOME 2.2
I have tried installing some drives obtained from nvidia site, but still its says Could not enable desktop effects
 
Old 11-22-2007, 12:32 PM   #2
Tomick
LQ Newbie
 
Registered: Nov 2007
Posts: 5

Rep: Reputation: 0
Quote:
Originally Posted by b2bwild View Post
I recently upgraded to Fedora 8..
I have nVidia GeForce FX 5200 card..
I cant enable desktop effects in GNOME 2.2
I have tried installing some drives obtained from nvidia site, but still its says Could not enable desktop effects
I got the same...please help!!
 
Old 11-22-2007, 11:41 PM   #3
MALDATA
Member
 
Registered: Mar 2005
Posts: 103

Rep: Reputation: 17
I have the same hardware and the same problem. I'm using the newest NVIDIA driver also... NVIDIA-Linux-x86-100.14.19

Any ideas?
 
Old 11-23-2007, 09:43 AM   #4
abhianet
LQ Newbie
 
Registered: Nov 2007
Posts: 1

Rep: Reputation: 0
Another one with same prob
 
Old 11-23-2007, 10:35 AM   #5
MALDATA
Member
 
Registered: Mar 2005
Posts: 103

Rep: Reputation: 17
Here's some error output from running it in a terminal:

[username@host ~]$ desktop-effects
True
* Executing: /usr/bin/compiz --replace --sm-disable --ignore-desktop-hints ccp
* nvidia found, exporting: __GL_YIELD="NOTHING"
/usr/bin/compiz (core) - Fatal: No sync extension

Doesn't seem especially helpful.
 
Old 11-24-2007, 12:44 PM   #6
MALDATA
Member
 
Registered: Mar 2005
Posts: 103

Rep: Reputation: 17
Resolved

Here's how I got it to work.

After installing the nVidia driver, I had to make some changes to the xorg.conf file.

Add this stuff to the indicated sections:
Section "Module"
Load "dbe"
Load "extmod"

Section "Device"
Option "XAANoOffscreenPixmaps" "true"
Option "AllowGLXWithComposite" "true"
Option "TripleBuffer" "true"
Option "RenderAccel" "true"

Section "Extensions"
Option "Composite" "Enable"

Section "Screen"
Option "AddARGBGLXVisuals" "true"

Section "ServerLayout"
Option "AIGLX" "true"

Then you should be able to enable the desktop effects. Let me know if that works for you.

Last edited by MALDATA; 11-24-2007 at 04:40 PM.
 
Old 11-25-2007, 08:22 AM   #7
renven700
LQ Newbie
 
Registered: Nov 2007
Posts: 1

Rep: Reputation: 0
Thumbs up

Tens razao MALDATA, fiz isso e funcionou, tenho o fedora core 8 com uma geforce 7600 GS e esta tudo muito "cool"
obrigado.
 
Old 12-02-2007, 05:39 AM   #8
gnu_gcc
LQ Newbie
 
Registered: Dec 2007
Posts: 4

Rep: Reputation: 0
Quote:
Originally Posted by MALDATA View Post
Here's how I got it to work.

After installing the nVidia driver, I had to make some changes to the xorg.conf file.

Add this stuff to the indicated sections:
Section "Module"
Load "dbe"
Load "extmod"

Section "Device"
Option "XAANoOffscreenPixmaps" "true"
Option "AllowGLXWithComposite" "true"
Option "TripleBuffer" "true"
Option "RenderAccel" "true"

Section "Extensions"
Option "Composite" "Enable"

Section "Screen"
Option "AddARGBGLXVisuals" "true"

Section "ServerLayout"
Option "AIGLX" "true"

Then you should be able to enable the desktop effects. Let me know if that works for you.
hi,

thanks for your help. I can activate the desktop effect but how do you know these codes? can you share knowledge with us

regards,
 
Old 12-18-2007, 01:26 PM   #9
angelsapocalypse
LQ Newbie
 
Registered: Dec 2007
Posts: 1

Rep: Reputation: 0
I ve also nVidia Geforce Fx 5200.I m using the newest nVidia driver NVIDIA-Linux-x86-100.14.19.But still i cant enable desktop effect.Checking this forum,i tried to edit xorg.conf file.But i could not edit successfully,as my system crashed.Im new in Linux platform.So can any one post the whole text of the xorg.conf file,after edit it?I want to copy paste just.

Last edited by angelsapocalypse; 12-18-2007 at 01:27 PM.
 
Old 12-27-2007, 03:18 AM   #10
hareeshkumaru
LQ Newbie
 
Registered: Dec 2007
Location: coimbatore-chennai
Distribution: fedora
Posts: 11

Rep: Reputation: 0
i also have nVIDIA GeForce 6200 TM, i hav installed the driver NVIDIA-Linux-x86-169.07-pkg1.run.. that i downloaded from nvidia website.. but could not enable desktop effects.. i did the changes u told to make to the xorg.conf file but my original file didnt hav a Section "Extensions".. so i typed it.. but still its not getting enabled.. i get the following error at the terminal..
[root@localhost ~]# desktop-effects

compiz (core) - Fatal: No sync extension
Xlib:extension "SHAPE" missing on display ":0.0".

Xlib:extension "SHAPE" missing on display ":0.0".

Xlib: extension "SHAPE" missing on display ":0.0".

Xlib: extension "SHAPE" missing on display ":0.0".

Xlib: extension "SHAPE" missing on display ":0.0".

Xlib: extension "SHAPE" missing on display ":0.0".
pls help me..
 
Old 12-27-2007, 06:10 AM   #11
oskar
Senior Member
 
Registered: Feb 2006
Location: Austria
Distribution: Ubuntu 12.10
Posts: 1,138

Rep: Reputation: 49
Quote:
Originally Posted by hareeshkumaru View Post
[root@localhost ~]# desktop-effects

compiz (core) - Fatal: No sync extension
Xlib:extension "SHAPE" missing on display ":0.0"
That's probably because X runs as user. Run the desktop-effects as user too, and it should work.

Last edited by oskar; 12-27-2007 at 06:12 AM.
 
Old 12-27-2007, 08:38 AM   #12
hareeshkumaru
LQ Newbie
 
Registered: Dec 2007
Location: coimbatore-chennai
Distribution: fedora
Posts: 11

Rep: Reputation: 0
i dont understand!! i login as root.. stil i get this error.. can u pls explain
 
Old 12-28-2007, 06:52 AM   #13
akasantos
LQ Newbie
 
Registered: Sep 2003
Location: Portugal
Distribution: Fedora Core 4
Posts: 28

Rep: Reputation: 15
Hello to all.

Currently I'm running a machine with Intel E6750 duo, a XFX GeForce 8400GS 512MB on Fedora Core 8, and I had the same problem, could not have the Desktop Effects working. After reading on the web a little I found some post very usefull.

Here you can find a how-to, explaining what you have to enable/install to put the Desktop Effects working (includes the info for the 3rd party video drivers) - [how-to link].
Basically you update your repo data with the livna, then you update you system for your graphic card (on Applications - Add/Remove Software, go to search and put there nvidia, install whatever is appropriate for you). After this and following the how-to, maybe you still can't run the Desktop Effects (happen to me), I then remembered what MALTADA wrote before, so I went and updated my xorg.conf file, rebooted my system and .... it's amazing. Try it.

Here some other links:
Link 1

currently my xorg.conf file looks like this:
Quote:
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 1.0 (buildmeister@builder3) Thu Dec 13 19:09:35 PST 2007

# Xorg configuration created by pyxf86config

Section "ServerLayout"
Identifier "Default Layout"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
Option "AIGLX" "true"
EndSection

Section "Files"
EndSection

Section "Extensions"
Option "Composite" "Enable"
EndSection

Section "Module"
Load "glx"
Load "dbe"
Load "extmod"
EndSection

Section "InputDevice"
# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/input/mice"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "pt"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Unknown"
ModelName "Unknown"
HorizSync 30.0 - 110.0
VertRefresh 50.0 - 150.0
Option "DPMS"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nvidia"
Option "XAANoOffscreenPixmaps" "true"
Option "AllowGLXWithComposite" "true"
Option "TripleBuffer" "true"
Option "RenderAccel" "true"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
Option "AddARGBGLXVisuals" "true"
EndSection
If you need more information from me please let me know in what way I can help.
Take care to you all and good season.
 
Old 12-28-2007, 08:38 AM   #14
oskar
Senior Member
 
Registered: Feb 2006
Location: Austria
Distribution: Ubuntu 12.10
Posts: 1,138

Rep: Reputation: 49
Quote:
Originally Posted by hareeshkumaru View Post
i dont understand!! i login as root.. stil i get this error.. can u pls explain
You should not log in as root.
Log in as user, and enable the desktop effects as user.
 
Old 01-02-2008, 10:00 PM   #15
hlingler
Member
 
Registered: May 2007
Location: Connellsville, PA, USA
Distribution: Fedora 8/9/10/11
Posts: 71

Rep: Reputation: 15
Hello, All:

I thought that the Fedora stance on the proprietary drivers provided by nvidia (and ATI) was well-known: https://www.redhat.com/archives/fedo.../msg01565.html

You really should get the repackaged drivers from Livna repo (preferred) or FreshRPMs. Here's another HOW-TO link (for F7, I'm sure MJM has one for F8): http://www.mjmwired.net/resources/mj...f7.html#nvidia.

I recall the headaches I had back on FC5 trying to install the drivers binaries from nvidia - you will save yourself a lot of pain by getting the driver packages from Livna or FreshRPMs.

Regards,
Vince
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Want to enable 3D desktop effects using ATI radeaon 200m ddoublee Linux - Desktop 3 09-29-2007 01:17 AM
Cannot enable desktop effects/beryl does nothing - Fedora 7 on geforce 7900gs the big cheese Fedora 5 08-03-2007 08:47 AM
cannot enable desktop effects narcispy Ubuntu 4 06-20-2007 09:27 AM
How do I enable desktop effects in Xubuntu? coolblue Ubuntu 1 04-20-2007 08:29 PM
I canīt enable desktop effects skullhunterph Fedora 3 04-01-2007 05:30 PM


All times are GMT -5. The time now is 05:21 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration