LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (http://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   can't boot with new pci nvidia video card...onboard intel works OK (http://www.linuxquestions.org/questions/linux-hardware-18/cant-boot-with-new-pci-nvidia-video-card-onboard-intel-works-ok-767327/)

flsomerv 11-06-2009 10:04 AM

can't boot with new pci nvidia video card...onboard intel works OK
 
Hello. I am adding a new PCI Nvidia GeForce 6200 video card to my desktop computer. I was previously using the onboard Intel video adapter. The problem is that boot up hangs shortly into the boot process when I try to boot with the new video card. If I switch back to the onboard video in the system BIOS, everything boots fine.

Some information:
System: Dell Dimension 2350 (BIOS Rev. A02)
CPU: Intel Celeron 2.2Ghz
RAM: 1GB
OS: Fedora 11
Kernel: 2.6.30.9-90.fc11.i586
Onboard video: Intel 82845G (64MB)
New video card: Nvidia eVGA e-GeForce 6200 (PCI) (256MB)
Monitor: Acer H213H 21.5"

The video card has VGA and DVI outputs. I have the onboard video connected to the VGA on the monitor. I have the Nvidia card connected to the DVI on the monitor. When I choose "Onboard" as the primary video in the BIOS, everything boots up fine. When I choose "AUTO" for the primary video, the screen goes blank, then I see the white/light blue/dark blue bar at the bottom (Fedora 11 startup) for a split second and then I am left with a cursor blinking in the upper left corner.

I've tried hitting Grub and editing the kernel line. I removed the "rhgb quiet" part and replaced with "3" to boot up in run level 3, but it still hangs before it can finish loading. It seems to stop right before loading kernel modules, but I can't be sure.

Google searching has led me to the option of blacklisting the onboard video. Several posts report that blacklisting "intel_agp" and "agpgart" stop the system from loading the modules for the onboard video, but this didn't work for me.

I also tried installing the Nvidia drivers from their site. Didn't make a difference.

Can someone please give me some more ideas to try? Thank you.
--Logan

More information:
Output from lspci:
00:00.0 Host bridge: Intel Corporation 82845G/GL[Brookdale-G]/GE/PE DRAM Controller/Host-Hub Interface (rev 03)
00:02.0 VGA compatible controller: Intel Corporation 82845G/GL[Brookdale-G]/GE Chipset Integrated Graphics Device (rev 03)
00:1d.0 USB Controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #1 (rev 02)
00:1d.1 USB Controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #2 (rev 02)
00:1d.2 USB Controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #3 (rev 02)
00:1d.7 USB Controller: Intel Corporation 82801DB/DBM (ICH4/ICH4-M) USB2 EHCI Controller (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev 82)
00:1f.0 ISA bridge: Intel Corporation 82801DB/DBL (ICH4/ICH4-L) LPC Interface Bridge (rev 02)
00:1f.1 IDE interface: Intel Corporation 82801DB (ICH4) IDE Controller (rev 02)
00:1f.3 SMBus: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) SMBus Controller (rev 02)
00:1f.5 Multimedia audio controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97 Audio Controller (rev 02)
01:04.0 VGA compatible controller: nVidia Corporation NV44A [GeForce 6200] (rev a1)
01:06.0 Parallel controller: Broadcom Corporation BCM4210 iLine10 HomePNA 2.0 (rev 02)
01:09.0 Ethernet controller: Broadcom Corporation BCM4401 100Base-T (rev 01)

Output from lsmod:
Module Size Used by
fuse 49272 2
sco 16176 2
bridge 43864 0
stp 1972 1 bridge
llc 4944 2 bridge,stp
bnep 14908 2
l2cap 32436 3 bnep
bluetooth 77104 5 sco,bnep,l2cap
sunrpc 155656 1
ip6t_REJECT 4540 2
nf_conntrack_ipv6 17724 2
ip6table_filter 3156 1
ip6_tables 10968 1 ip6table_filter
ipv6 235712 20 ip6t_REJECT,nf_conntrack_ipv6
p4_clockmod 4352 0
dm_multipath 14048 0
uinput 6684 0
dcdbas 8468 0
snd_intel8x0 28092 2
snd_ac97_codec 91936 1 snd_intel8x0
ac97_bus 1416 1 snd_ac97_codec
ppdev 6488 0
snd_pcm 63000 2 snd_intel8x0,snd_ac97_codec
snd_timer 17780 1 snd_pcm
arc4 1604 2
ecb 2476 2
pcspkr 2176 0
nvidia 8864908 0
snd 50292 8 snd_intel8x0,snd_ac97_codec,snd_pcm,snd_timer
soundcore 5484 1 snd
snd_page_alloc 7720 2 snd_intel8x0,snd_pcm
rtl8187 27908 0
mac80211 175100 1 rtl8187
eeprom_93cx6 1760 1 rtl8187
b44 22792 0
cfg80211 51684 2 rtl8187,mac80211
ssb 37008 1 b44
iTCO_wdt 10356 0
iTCO_vendor_support 2760 1 iTCO_wdt
mii 4032 1 b44
i2c_core 25032 1 nvidia
parport_pc 22500 0
parport 28928 2 ppdev,parport_pc
floppy 47228 0
ata_generic 4296 0
pata_acpi 3656 0

tredegar 11-06-2009 10:52 AM

You seem to be doing well so far.

Some things to think about:

- I am not sure having both VGA and DVI connected to the monitor at once is a good idea. Does the monitor have some sort of "Input select" to choose which to use. Try connecting the Nvidia card with a VGA cable. Does EDID (see wikipedia) work over a DVI cable? Maybe not. In which case xorg cannot probe your monitor for its specs.

- Does adding vga=normal to your kernel boot line help at all ?

- You installed the NVIDIA drivers but did you you update your xorg.conf ?

- Please post your /etc/X11/xorg.conf file (In CODE tags please [ Quick reply -> "Go advanced", -> it's the # icon])

Finally, what happens if you disable on-board video driver, connect the nvidia card with VGA cable and boot from a live CD like knoppix or one of the earlier 'buntus (8.04 comes to mind). Does the NVIDIA card work (without the NVIDIA drivers, just the kernel one) ?

lazlow 11-06-2009 11:03 AM

I ran into the same situation when I switched to a new LCD monitor. Mine did not like having both a VGA and a DVI connection to the same machine. Once I unplugged the VGA the DVI worked fine. Oddly enough it will work with both VGA and DVI connected simultaneously as long as they are from two different machines.

flsomerv 11-06-2009 12:01 PM

xorg.conf's
 
When installing the nvidia drivers, the installer generates a new xorg.conf. Is that what you mean my updating the xorg.conf file?

This is the xorg.conf when I am using the onboard video (can't start X if I use onboard video, but have the nvidia xorg.conf):
Code:

# Xorg configuration created by system-config-display

Section "ServerLayout"
        Identifier    "single head configuration"
        Screen      0  "Screen0" 0 0
        InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "InputDevice"
# keyboard added by rhpxl
        Identifier  "Keyboard0"
        Driver      "kbd"
        Option      "XkbModel" "pc105+inet"
        Option      "XkbLayout" "us"
EndSection

Section "Device"
        Identifier  "Videocard0"
        Driver      "intel"
EndSection

Section "Screen"
        Identifier "Screen0"
        Device    "Videocard0"
        DefaultDepth    24
        SubSection "Display"
                Viewport  0 0
                Depth    24
        EndSubSection
EndSection

and here is the nVidia xorg.conf:

Code:

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 1.0  (buildmeister@builder63)  Tue Oct 20 21:00:15 PDT 2009

# Xorg configuration created by system-config-display

Section "ServerLayout"
    Identifier    "single head configuration"
    Screen      0  "Screen0" 0 0
    InputDevice    "Mouse0" "CorePointer"
    InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "InputDevice"
    # generated from default
    Identifier    "Mouse0"
    Driver        "mouse"
    Option        "Protocol" "auto"
    Option        "Device" "/dev/input/mice"
    Option        "Emulate3Buttons" "no"
    Option        "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

# keyboard added by rhpxl
    Identifier    "Keyboard0"
    Driver        "kbd"
    Option        "XkbModel" "pc105+inet"
    Option        "XkbLayout" "us"
EndSection

Section "Monitor"
    Identifier    "Monitor0"
    VendorName    "Unknown"
    ModelName      "Unknown"
    HorizSync      28.0 - 33.0
    VertRefresh    43.0 - 72.0
    Option        "DPMS"
EndSection

Section "Device"
    Identifier    "Videocard0"
    Driver        "nvidia"
EndSection

Section "Screen"
    Identifier    "Screen0"
    Device        "Videocard0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection    "Display"
        Viewport    0 0
        Depth      24
    EndSubSection
EndSection

I'll going to try booting with a Fedora 11 Live CD, and if that doesn't work, I'll make a Knoppix one and try booting with that. Thanks for the replies. I'll post back with updates.

flsomerv 11-06-2009 12:03 PM

Oh yeah...adding vga=normal to the kernel line didn't help...same thing....

worth a try though...

thorkelljarl 11-06-2009 12:15 PM

Also...

You could test the system by downloading and booting a live-cd of PCLinuxOS which has an Nvidia driver already configured, but there may well be no difference in what happens.

Connecting both outputs to the same screen is likely to confuse X, since the output connections are also input connections when linux configures the screen, and two is one too many.

[url]http://pclinuxos.com/?page_id=180

Do you have the latest BIOS?

Working with the modules for the graphics chips seems like the right approach. Are you sure you are blocking the right on-board modules? You can run "lsmod" with the on-board chip activated to see what is loaded.

When the Nvidia card is installed, can you force the loading of an "nv" module at the beginning of the linux boot? Something has to be presented as a module if the graphics device is to be activated.

There may be no solution to this problem if the BIOS only has an "Auto" setting that looks for a Windows driver, and on not finding it, simply boots nothing.

flsomerv 11-06-2009 12:37 PM

Fedora 11 Live CD didn't work
 
Well...I expected as much, but the Fedora 11 Live CD didn't work...it just hangs right after it starts...

I just downloaded Knoppix 6.0.1 Live. I am going to burn the ISO and try booting with it. I have higher hopes for this one since it is supposed to have the nvidia driver setup, right?

Also, I think that blocking the onboard modules is the right way to go, but honestly I'm not sure what modules to block (see previously posted lsmod output).

Thanks for all the help. The 64MB onboard is functional, but I can't do stuff like watch youtube, play movie files in totem, play games via emulators, etc. I'm hoping the 256MB nvidia card improves my system enough to do those things.

tredegar 11-06-2009 12:52 PM

I gave you several suggestions in my post at #2
Other posters have seconded my first suggestion - the cables.

Please just investigate, methodically. You will get it working if you try one thing at a time, and take a moment to discover what helps and what doesn't.

You need to get the nvidia card / your monitor working with the basic linux kernel driver before you can move on to installing the proprietary nvidia driver.

Stay calm, and be methodical. It's just a puzzle that needs to be solved. Perform tests, make assumptions, test those assumptions. Lather, rinse, revise assumptions, repeat.

Edit: DISABLE your on-board video chipset in your BIOS /Edit

flsomerv 11-06-2009 12:53 PM

OK, the Knoppix Live CD didn't work either. It made it far enough to show the Knoppix penguin in the upper left corner and then just got stuck.

How can I determine exactly what modules I need to blacklist in order to prevent the kernel from trying to use the onboard video?

Thanks.

flsomerv 11-06-2009 01:04 PM

@tredegar:

My monitor does have an input select on it to change between VGA, DVI and HDMI. The monitor automatically switches to the input that has signal. When an input has no signal, it moves to the next input. I have dropped the DVI cable out of the equation. I have tried using the VGA cable connected to the nvidia card. Still nothing.

The other thing I notice is that in the BIOS, the option regarding video is called "Primary Video" and the only two options are "Onboard" or "AUTO." There is no option to disable.

The Knoppix Live CD did not work either. Boot process hangs after a few seconds.

I've been using Linux (in one flavor or another) since 1997. I know that it is just a matter of figuring out exactly what Linux wants in order for the system to do what I want.

What should I do next?

thorkelljarl 11-06-2009 01:56 PM

Useful information...

If KNOPPIX started to load, a solution should be possible.

Try to boot a live-cd linux with the on board chip activated and no Nvidia card. Then run the command "lsmod" to see what modules are loaded. They are those you wish to block.

Have you tried a KNOPPIX live-cd trying with the BIOS setting at "Auto", no on-board, and a cheatcode to force the "vesa" or "nv" module? KNOPPIX 5.1.1 has the most cheatcodes and is more contemporary with the hardware.

http://www.knoppix.net/wiki/Cheat_Codes

flsomerv 11-08-2009 05:12 PM

Everything is working now!
 
Thanks for all the helpful replies. It turns out that all I needed to do was add 'agp=off' to the kernel line in grub. The system came up just fine once I added that. I put the 'agp=off' in the /etc/grub.conf file so it will no load the agp every time I boot.

I'm using the DVI cable too. Everything looks a bit more crisp with the DVI cable.

Anyway, problem solved, so thanks for everything.

--Logan

tredegar 11-09-2009 01:49 PM

Quote:

It turns out that all I needed to do was add 'agp=off'
Ahhh! Because it's a PCI card!
Thanks for the follow-up. Pleased it is working.

flsomerv 11-12-2009 01:03 PM

another issue
 
Thanks to all previous posters that helped me getting the nVidia card going! I now have another issue with the card. The graphics are slow to render. This is especially true in video playback. Nautilus is slow to render when changing directories, scrolling in Firefox is choppy, YouTube videos are sometimes choppy, and video playback of HD videos in Totem is choppy.

I'm not looking to do 3D gaming with this card, but the above mentioned items should have no problem with a 256MB graphics card. The performance I am getting is only slightly better than the previous 64MB integrated Intel adapter.

My question is are there optimizations or settings that I need to edit in order to get this card working smoothly? The drivers I installed are the ones from the nVidia site:
NVIDIA-Linux-x86-190.42-pkg1.run

Thanks.

Here is my xorg.conf:
Code:

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 1.0  (buildmeister@builder63)  Tue Oct 20 21:00:15 PDT 2009

Section "ServerLayout"
    Identifier    "Layout0"
    Screen      0  "Screen0"
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
    FontPath        "/usr/share/fonts/default/Type1"
EndSection

Section "InputDevice"
    # generated from default
    Identifier    "Mouse0"
    Driver        "mouse"
    Option        "Protocol" "auto"
    Option        "Device" "/dev/input/mice"
    Option        "Emulate3Buttons" "no"
    Option        "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from data in "/etc/sysconfig/keyboard"
    Identifier    "Keyboard0"
    Driver        "kbd"
    Option        "XkbLayout" "us"
    Option        "XkbModel" "pc105"
EndSection

Section "Monitor"
    Identifier    "Monitor0"
    VendorName    "Unknown"
    ModelName      "Unknown"
    HorizSync      28.0 - 33.0
    VertRefresh    43.0 - 72.0
    Option        "DPMS"
EndSection

Section "Device"
    Identifier    "Device0"
    Driver        "nvidia"
    VendorName    "NVIDIA Corporation"
EndSection

Section "Screen"
    Identifier    "Screen0"
    Device        "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection    "Display"
        Depth      24
    EndSubSection
EndSection


tredegar 11-12-2009 01:17 PM

Quote:

Nautilus is slow to render when changing directories, scrolling in Firefox is choppy, YouTube videos are sometimes choppy, and video playback of HD videos in Totem is choppy.
Points to incorrect video card configuration, no acceleration enabled.

Your xorg.conf seems to be missing a Module stanza:
Code:

Section "Module"
    Load          "dbe"
    Load          "extmod"
    Load          "type1"
    Load          "freetype"
    Load          "glx"
EndSection

The Load "glx" is the really important line.

Try adding it, then restart X with <CTRL><ALT<BACKSPACE>

Any better ?


All times are GMT -5. The time now is 07:01 AM.