LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 05-15-2013, 03:56 AM   #1
turboscrew
Member
 
Registered: Apr 2009
Location: Nokia (town), Finland
Distribution: Debian, Mint, Puppy, Ubuntu, Slackware
Posts: 332

Rep: Reputation: 32
Canon PIXMA MP140 and CUPS - what happened?


I selected the printer when I set up Cups, but the printer driver seems to be broken.
The notorious jamming problem seems to be present.

I'm running Linux Mint 14 (but I haven't got any answers from the Mint forum here nor from the official Mint forum, nor even Ubuntu forum).

I heard there is a fix, but what should I update?

Synaptic didn't find anything with "cnijfilter".

I tried installing the drivers from Canon website, but:

Code:
    $ sudo dpkg -i cnijfilter-common_2.80-1_i386.deb
    (Reading database ... 178707 files and directories currently installed.)
    Preparing to replace cnijfilter-common 2.80-1 (using cnijfilter-common_2.80-1_i386.deb) ...
    Unpacking replacement cnijfilter-common ...
    dpkg: dependency problems prevent configuration of cnijfilter-common:
     cnijfilter-common depends on libcupsys2 (>= 1.2.1).

    dpkg: error processing cnijfilter-common (--install):
     dependency problems - leaving unconfigured
    Errors were encountered while processing:
     cnijfilter-common
I didn't find "libcupsys" in my system at all. Libcups2 was the closest found by Synaptic.

Has the CUPS system changed since 1.5?

BTW, is i386 work with 64-bit Mint 14 anyway?
 
Old 05-16-2013, 01:36 PM   #2
bigrigdriver
LQ Addict
 
Registered: Jul 2002
Location: East Centra Illinois, USA
Distribution: Debian Squeeze
Posts: 5,745

Rep: Reputation: 301Reputation: 301Reputation: 301Reputation: 301
Here is a thread on askubuntu which gives a procedure to make it work.

I hope it works for you as well.
 
Old 05-18-2013, 01:02 AM   #3
lazardo
Member
 
Registered: Feb 2010
Location: SF Bay Area
Posts: 100

Rep: Reputation: Disabled
> Get the more recent version: cnijfilter-common-3.70-1
>
>Cheers,

My error. I just upgraded an MX890 but apparently the MP line does not have v3.70

Last edited by lazardo; 05-19-2013 at 01:49 PM. Reason: correction
 
Old 05-18-2013, 02:11 AM   #4
turboscrew
Member
 
Registered: Apr 2009
Location: Nokia (town), Finland
Distribution: Debian, Mint, Puppy, Ubuntu, Slackware
Posts: 332

Original Poster
Rep: Reputation: 32
Quote:
Originally Posted by lazardo View Post
Get the more recent version: cnijfilter-common-3.70-1

Cheers,
Where?
Like this?
https://launchpad.net/~michael-gruz/...+build/3720344

Last edited by turboscrew; 05-18-2013 at 02:15 AM.
 
Old 05-18-2013, 03:00 AM   #5
turboscrew
Member
 
Registered: Apr 2009
Location: Nokia (town), Finland
Distribution: Debian, Mint, Puppy, Ubuntu, Slackware
Posts: 332

Original Poster
Rep: Reputation: 32
Quote:
Originally Posted by bigrigdriver View Post
Here is a thread on askubuntu which gives a procedure to make it work.

I hope it works for you as well.
Well, not wuite:
Code:
~/Downloads/MP140/MP140Print $ sudo dpkg -i cnijfilter-common_2.80-1_i386.deb
(Reading database ... 178890 files and directories currently installed.)
Preparing to replace cnijfilter-mp140series 2.80-1 (using cnijfilter-common_2.80-1_i386.deb) ...
Unpacking replacement cnijfilter-mp140series ...
dpkg: dependency problems prevent configuration of cnijfilter-mp140series:
 cnijfilter-mp140series depends on libatk1.0-0 (>= 1.9.0).
 cnijfilter-mp140series depends on libcairo2 (>= 1.0.2-2).
 cnijfilter-mp140series depends on libfontconfig1 (>= 2.3.0).
 cnijfilter-mp140series depends on libglib2.0-0 (>= 2.10.0).
 cnijfilter-mp140series depends on libgtk2.0-0 (>= 2.8.0).
 cnijfilter-mp140series depends on libpango1.0-0 (>= 1.12.3).
 cnijfilter-mp140series depends on libpng12-0 (>= 1.2.8rel).
 cnijfilter-mp140series depends on libtiff4.
 cnijfilter-mp140series depends on libx11-6.
 cnijfilter-mp140series depends on libxcursor1 (>> 1.1.2).
 cnijfilter-mp140series depends on libxext6.
 cnijfilter-mp140series depends on libxfixes3.
 cnijfilter-mp140series depends on libxi6.
 cnijfilter-mp140series depends on libxinerama1.
 cnijfilter-mp140series depends on libxml2 (>= 2.6.24).
 cnijfilter-mp140series depends on libxrandr2.
 cnijfilter-mp140series depends on libxrender1.
 cnijfilter-mp140series depends on cnijfilter-c
dpkg: error processing cnijfilter-mp140series (--install):
 dependency problems - leaving unconfigured
Processing triggers for libc-bin ...
ldconfig deferred processing now taking place
Errors were encountered while processing:
 cnijfilter-mp140series
I guess it need not removal but replacement for libcupsys2 (>= 1.2.1) in the dependancies.
But does it still work with 64-bit Linux?
Which package does Quantal use?

The newer packages of cnijfilter-common didn't seem to contain drivers for PIXMA MP140 or PIXMA MP150.

The sad thing here is that I had the printer in shared use with my older HW running Puppy Linux, and it worked fine.
(The the processor was 32-bit then, though.)

Last edited by turboscrew; 05-18-2013 at 03:02 AM.
 
Old 05-18-2013, 01:13 PM   #6
turboscrew
Member
 
Registered: Apr 2009
Location: Nokia (town), Finland
Distribution: Debian, Mint, Puppy, Ubuntu, Slackware
Posts: 332

Original Poster
Rep: Reputation: 32
BTW, I added repos
http://ppa.launchpad.net/michael-gru...-stable/ubuntu quantal main
http://ppa.launchpad.net/michael-gru...-stable/ubuntu raring main
into Synaptic.

There are no 64-bit drivers for MP140 and the install of 32-bit fails due to dependancy:
Code:
cnijfilter-mp140series-32:
 Depends: cnijfilter-mp140series (>= 3.90)
and that cnijfilter-mp140series (without the "-32" postfix) is not found.

Funny, because in the Quantal package description build status includes:

Built files

Code:
Files resulting from this build:

...

cnijfilter-mp140series-32_3.90-63~quantal1_amd64.deb (1.5 KiB)
cnijfilter-mp160series-32_3.90-63~quantal1_amd64.deb (1.5 KiB)
cnijfilter-mp190series-32_3.90-63~quantal1_amd64.deb (1.5 KiB)
...
and raring package:


Code:
 cnijfilter-mp140series-32_3.90-63~raring1_amd64.deb (1.5 KiB)
cnijfilter-mp140series_3.90-63~raring1_i386.deb (1.6 MiB)
cnijfilter-mp160series-32_3.90-63~raring1_amd64.deb (1.5 KiB)
cnijfilter-mp160series_3.90-63~raring1_i386.deb (1.5 MiB)
cnijfilter-mp190series-32_3.90-63~raring1_amd64.deb (1.5 KiB)
cnijfilter-mp190series_3.90-63~raring1_i386.deb (1.6 MiB)
Why are these not found in Synaptic?
Where/whom I should ask? And how?

Last edited by turboscrew; 05-18-2013 at 01:15 PM.
 
Old 06-23-2013, 07:38 AM   #7
turboscrew
Member
 
Registered: Apr 2009
Location: Nokia (town), Finland
Distribution: Debian, Mint, Puppy, Ubuntu, Slackware
Posts: 332

Original Poster
Rep: Reputation: 32
Is there any hope for ever getting the Canon Pixma MP140 to work under linux again?

I tried quite this and that with Linux Mint 14 and 15, Debian 7.0.0 and Fedora 18.
All of them recognized the printer right, but all of them freezed at the end of first page.

The driver 2.80 didn't compile any more (libraries have changed and all) and the Michael Cruz PPAs don't seem to work either.
It used to work fine with Mint 7 and Lucid Puppy 5.2.8 (0000) on my old MoBo (that broke).
My new MoBo has i3 (ivy bridge) so there is no going back to the old Linux releases.

Please, someone, tell me what to do or which program doesn't work. (CUPS? Gutenprint? Foomatic? The driver?)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Canon PIXMA MP140 in 64-bit Mint 14 turboscrew Linux Mint 0 05-06-2013 11:44 AM
installing canon pixma mp140 scrasun Linux - Hardware 7 04-09-2012 10:42 PM
Can't find Cups driver for Canon Pixma IP2200 gw1500se Mandriva 4 12-16-2010 02:34 AM
Canon PIXMA MP140 drivers won't install norm.h Linux - Hardware 11 02-01-2009 02:05 PM
How to Install Canon Pixma IP1800 on a win 98 using CUPS? placa1783 Linux - Newbie 1 03-18-2008 02:05 PM


All times are GMT -5. The time now is 12:13 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration