LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (http://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   Cannot wake from suspend with keyboard or mouse on Dell XPS 17 L702X (http://www.linuxquestions.org/questions/linux-hardware-18/cannot-wake-from-suspend-with-keyboard-or-mouse-on-dell-xps-17-l702x-940367/)

Ahaaa 04-17-2012 11:17 PM

Cannot wake from suspend with keyboard or mouse on Dell XPS 17 L702X
 
Hi, my Dell XPS 17 L702X laptop will only wake from suspend with the power button. I would like to wake up using the keyboard, trackpad buttons, and/or my external keyboard/mouse. Originally, Windows (dual-booted) would not allow wake from keyboard/USB either, so I went into BIOS and enabled wake from USB, which solved the problem in Windows.

Back in Linux, I tried
Code:

$ lspci|grep USB
00:1a.0 USB Controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #2 (rev 05)
00:1d.0 USB Controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #1 (rev 05)
04:00.0 USB Controller: NEC Corporation uPD720200 USB 3.0 Host Controller (rev 04)

Then, I tried
Code:

$ cat /proc/acpi/wakeup
There were no items labelled USB, but it did include the lines
Code:

EHC1      S3    *disabled  pci:0000:00:1d.0
EHC2      S3    *disabled  pci:0000:00:1a.0
PXSX      S4    *disabled  pci:0000:04:00.0

Then, I tried
Code:

$ echo ... > /proc/acpi/wakeup
where "..." was EHC1, EHC2, PXSX. The first two options toggled the items to enabled, but the latter did nothing. In any case, none of these options solved the problem for me.

Would anyone have any suggestions as to how to proceed from here?

Cheers.

Ubuntu 11.10
3.0.0-17-generic
Dell XPS 17 L702X

jefro 04-19-2012 10:03 AM

EHC1 S3 *disabled pci:0000:00:1d.0
EHC2 S3 *disabled pci:0000:00:1a.0
PXSX S4 *disabled pci:0000:04:00.0


Doesn't one of the S states have to be enabled? Not even sure about that since it is all pci. Problem is that it could be pci to usb attached usb device. Never know about laptops. One of the S states needs to provide constant or enough power to the usb so both the OS and the bios have to be in agreement there.


Anyway peek at these for more clues.

http://forums.fedoraforum.org/showthread.php?t=241436

http://halffull.org/2010/03/27/linux-wake-on-keyboard/

http://prodia.co.uk/blog/doahh/entry..._up_from_sleep

Ahaaa 04-20-2012 08:16 PM

Thank you for the reply.
Quote:

Originally Posted by jefro (Post 4657401)
Doesn't one of the S states have to be enabled?

I'm not 100% sure I understand what you mean there, but the threads you linked to are pretty much what I had tried before. I can run the following command:
Code:

$ cat /proc/acpi/wakeup
Device        S-state          Status  Sysfs node
P0P1          S4        *disabled 
EHC1          S3        *disabled  pci:0000:00:1d.0
EHC2          S3        *disabled  pci:0000:00:1a.0
HDEF          S3        *disabled  pci:0000:00:1b.0
RP01          S3        *disabled  pci:0000:00:1c.0
PXSX          S4        *disabled 
RP02          S3        *disabled  pci:0000:00:1c.1
PXSX          S4        *disabled  pci:0000:03:00.0
RP04          S3        *disabled  pci:0000:00:1c.3
PXSX          S4        *disabled  pci:0000:04:00.0
RP05          S3        *disabled  pci:0000:00:1c.4
PXSX          S4        *disabled 
RP06          S4        *disabled  pci:0000:00:1c.5
PXSX          S4        *enabled  pci:0000:0a:00.0
PEG0          S4        *disabled  pci:0000:00:01.0
PEGP          S4        *disabled  pci:0000:01:00.0
LID0          S3        *enabled

Normally, you would expect to see USB0, USB1, etc. in the left column, and then you can toggle them from disabled to enabled using
Code:

echo USB0 > /proc/acpi/wakeup
In my case, the problem is that there is nothing marked USB0, USB1, etc.

Cheers.

Ahaaa 04-30-2012 05:25 AM

No idea why, but the latest Ubuntu update to 12.04 seems to have fixed this for me. I now run
Code:

$ cat /proc/acpi/wakeup
Device        S-state          Status  Sysfs node
P0P1          S4        *disabled 
EHC1          S3        *enabled  pci:0000:00:1d.0
EHC2          S3        *enabled  pci:0000:00:1a.0
HDEF          S3        *disabled  pci:0000:00:1b.0
RP01          S3        *disabled  pci:0000:00:1c.0
PXSX          S4        *disabled 
RP02          S3        *disabled  pci:0000:00:1c.1
PXSX          S4        *disabled  pci:0000:03:00.0
RP04          S3        *disabled  pci:0000:00:1c.3
PXSX          S4        *enabled  pci:0000:04:00.0
RP05          S3        *disabled  pci:0000:00:1c.4
PXSX          S4        *disabled 
RP06          S4        *disabled  pci:0000:00:1c.5
PXSX          S4        *enabled  pci:0000:0a:00.0
PEG0          S4        *disabled  pci:0000:00:01.0
PEGP          S4        *disabled  pci:0000:01:00.0
LID0          S3        *enabled

And the only differences are that EHC1, EHC2 and PXSX are enabled. But for some reason it works! Anyway, thanks for your help.

Ahaaa 05-02-2012 06:19 PM

Sigh. I'm marking this as unsolved again. For some reason it only partially works. I have a laptop with "internal" keyboard and trackpad, and normally I connect an external (Apple aluminium) keyboard and (Razer Deathadder) mouse to the keyboard's hub. The external keyboard can wake up the computer, but not the internal keyboard/trackpad, nor the mouse. It's not a big deal, but it's certainly not "expected" behaviour.


All times are GMT -5. The time now is 11:40 PM.