LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 04-05-2005, 12:13 PM   #1
scrubbit
LQ Newbie
 
Registered: Apr 2005
Posts: 4

Rep: Reputation: 0
cannot start x server after video card upgrade


greetings!

I have recently upgraded my video card from a riva tnt2 to a radeon 9200 se. my o.s. is mandrake 10.0 and while i have reconfigured the system to accomodate the new card (xf86config tells me : Section "Device"
Identifier "device1"
VendorName "ATI"
BoardName "ATI Radeon (fglrx)"
Driver "radeon"
Option "DPMS"
EndSection )
i can not boot into graphical mode and have never been able to ever since i upgraded the card.

can anyone help me??...
 
Old 04-05-2005, 12:31 PM   #2
masand
Guru
 
Registered: May 2003
Location: INDIA
Distribution: Ubuntu, Solaris,CentOS
Posts: 5,522

Rep: Reputation: 58
boot into text mode

run

startx

and post here what u get as error messages

regards
 
Old 04-05-2005, 01:12 PM   #3
scrubbit
LQ Newbie
 
Registered: Apr 2005
Posts: 4

Original Poster
Rep: Reputation: 0
/var/log/Xorg.0.log

these are the contents of /var/log/Xorg.0.log (which is the same i get when i type "startx" at the prompt ):


"This is a pre-release version of the The X.Org Foundation X11.
It is not supported in any way.
Bugs may be filed in the bugzilla at http://bugs.freedesktop.org/.
Select the "xorg" product for bugs you find in this release.
Before reporting bugs in pre-release versions please check the
latest version in the The X.Org Foundation "monolithic tree" CVS
repository hosted at http://www.freedesktop.org/Software/xorg/
X Window System Version 6.8.1.99
Release Date: 2 October 2004 + cvs
X Protocol Version 11, Revision 0, Release 6.8.1.99
Build Operating System: Linux 2.6.7-2.tmb.6mdk i686 [ELF]
Current Operating System: Linux localhost 2.6.7-1.mm.7mdk #1 Mon Oct 11 15:17:01 CEST 2004 i686
Build Date: 14 October 2004
Before reporting problems, check http://wiki.X.Org
to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Tue Oct 29 18:57:07 2002
(==) Using config file: "/etc/X11/xorg.conf"
(==) ServerLayout "layout1"
(**) |-->Screen "screen1" (0)
(**) | |-->Monitor "monitor1"
(**) | |-->Device "device1"
(**) |-->Input Device "Keyboard1"
(**) |-->Input Device "Mouse1"
(**) FontPath set to "unix/:-1"
(==) RgbPath set to "/usr/X11R6/lib/X11/rgb"
(==) ModulePath set to "/usr/X11R6/lib/modules"
(**) Option "AllowMouseOpenFail"
(WW) Open APM failed (/dev/apm_bios) (No such file or directory)
(II) Module ABI versions:
X.Org ANSI C Emulation: 0.2
X.Org Video Driver: 0.7
X.Org XInput driver : 0.4
X.Org Server Extension : 0.2
X.Org Font Renderer : 0.4
(II) Loader running on linux
(II) LoadModule: "bitmap"
(II) Loading /usr/X11R6/lib/modules/fonts/libbitmap.a
(II) Module bitmap: vendor="X.Org Foundation"
compiled for 6.8.1.99, module version = 1.0.0
Module class: X.Org Font Renderer
ABI class: X.Org Font Renderer, version 0.4
(II) Loading font Bitmap
(II) LoadModule: "pcidata"
(II) Loading /usr/X11R6/lib/modules/libpcidata.a
(II) Module pcidata: vendor="X.Org Foundation"
compiled for 6.8.1.99, module version = 1.0.0
ABI class: X.Org Video Driver, version 0.7
Using vt 7
(--) using VT number 7

(II) PCI: Probing config type using method 1
(II) PCI: Config type is 1
(II) PCI: stages = 0x03, oldVal1 = 0x00000000, mode1Res1 = 0x80000000
(II) PCI: PCI scan (all values are in hex)
(II) PCI: 00:00:0: chip 1039,0735 card 0000,0000 rev 01 class 06,00,00 hdr 80
(II) PCI: 00:01:0: chip 1039,0001 card 0000,0000 rev 00 class 06,04,00 hdr 01
(II) PCI: 00:02:0: chip 1039,0018 card 0000,0000 rev 00 class 06,01,00 hdr 80
(II) PCI: 00:02:1: chip 1039,0016 card 0000,0000 rev 00 class 0c,05,00 hdr 00
(II) PCI: 00:02:2: chip 1039,7001 card 1019,0a14 rev 07 class 0c,03,10 hdr 00
(II) PCI: 00:02:3: chip 1039,7001 card 1019,0a14 rev 07 class 0c,03,10 hdr 00
(II) PCI: 00:02:5: chip 1039,5513 card 1039,5513 rev d0 class 01,01,80 hdr 80
(II) PCI: 00:0b:0: chip 1274,5880 card 1274,2000 rev 02 class 04,01,00 hdr 00
(II) PCI: 00:0d:0: chip 11c1,5811 card 11c1,5811 rev 04 class 0c,00,10 hdr 00
(II) PCI: 00:0f:0: chip 10ec,8139 card 149c,139a rev 10 class 02,00,00 hdr 00
(II) PCI: 01:00:0: chip 1002,5964 card 1787,2002 rev 01 class 03,00,00 hdr 00
(II) PCI: End of PCI scan
(II) Host-to-PCI bridge:
(II) Bus 0: bridge is at (0:0:0), (0,0,1), BCTRL: 0x0008 (VGA_EN is set)
(II) Bus 0 I/O range:
[0] -1 0 0x00000000 - 0x0000ffff (0x10000) IX[B]
(II) Bus 0 non-prefetchable memory range:
[0] -1 0 0x00000000 - 0xffffffff (0x0) MX[B]
(II) Bus 0 prefetchable memory range:
[0] -1 0 0x00000000 - 0xffffffff (0x0) MX[B]
(II) PCI-to-PCI bridge:
(II) Bus 1: bridge is at (0:1:0), (0,1,1), BCTRL: 0x000a (VGA_EN is set)
(II) Bus 1 I/O range:
[0] -1 0 0x0000b000 - 0x0000bfff (0x1000) IX[B]
(II) Bus 1 non-prefetchable memory range:
[0] -1 0 0xcfe00000 - 0xcfefffff (0x100000) MX[B]
(II) Bus 1 prefetchable memory range:
[0] -1 0 0xafc00000 - 0xcfcfffff (0x20100000) MX[B]
(II) PCI-to-ISA bridge:
(II) Bus -1: bridge is at (0:2:0), (0,-1,-1), BCTRL: 0x0008 (VGA_EN is set)
(--) PCI:*(1:0:0) ATI Technologies Inc unknown chipset (0x5964) rev 1, Mem @ 0xb0000000/28, 0xcfef0000/16, I/O @ 0xb800/8, BIOS @ 0xcfec0000/17
(II) Addressable bus resource ranges are
[0] -1 0 0x00000000 - 0xffffffff (0x0) MX[B]
[1] -1 0 0x00000000 - 0x0000ffff (0x10000) IX[B]
(II) OS-reported resource ranges:
[0] -1 0 0xffe00000 - 0xffffffff (0x200000) MX[B](B)
[1] -1 0 0x00100000 - 0x3fffffff (0x3ff00000) MX[B]E(B)
[2] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[B]
[3] -1 0 0x000c0000 - 0x000effff (0x30000) MX[B]
[4] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[B]
[5] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[B]
[6] -1 0 0x00000000 - 0x000000ff (0x100) IX[B]
(II) PCI Memory resource overlap reduced 0xd0000000 from 0xd7ffffff to 0xcfffffff
(II) Active PCI resource ranges:
[0] -1 0 0xcfffdf00 - 0xcfffdfff (0x100) MX[B]
[1] -1 0 0xcfffc000 - 0xcfffcfff (0x1000) MX[B]
[2] -1 0 0xcffff000 - 0xcfffffff (0x1000) MX[B]
[3] -1 0 0xcfffe000 - 0xcfffefff (0x1000) MX[B]
[4] -1 0 0xd0000000 - 0xcfffffff (0x0) MX[B]O
[5] -1 0 0xcfec0000 - 0xcfedffff (0x20000) MX[B](B)
[6] -1 0 0xcfef0000 - 0xcfefffff (0x10000) MX[B](B)
[7] -1 0 0xb0000000 - 0xbfffffff (0x10000000) MX[B](B)
[8] -1 0 0x0000d800 - 0x0000d8ff (0x100) IX[B]
[9] -1 0 0x0000dc00 - 0x0000dc3f (0x40) IX[B]
[10] -1 0 0x0000ff00 - 0x0000ff0f (0x10) IX[B]
[11] -1 0 0x00000c00 - 0x00000c1f (0x20) IX[B]
[12] -1 0 0x0000b800 - 0x0000b8ff (0x100) IX[B](B)
(II) Active PCI resource ranges after removing overlaps:
[0] -1 0 0xcfffdf00 - 0xcfffdfff (0x100) MX[B]
[1] -1 0 0xcfffc000 - 0xcfffcfff (0x1000) MX[B]
[2] -1 0 0xcffff000 - 0xcfffffff (0x1000) MX[B]
[3] -1 0 0xcfffe000 - 0xcfffefff (0x1000) MX[B]
[4] -1 0 0xd0000000 - 0xcfffffff (0x0) MX[B]O
[5] -1 0 0xcfec0000 - 0xcfedffff (0x20000) MX[B](B)
[6] -1 0 0xcfef0000 - 0xcfefffff (0x10000) MX[B](B)
[7] -1 0 0xb0000000 - 0xbfffffff (0x10000000) MX[B](B)
[8] -1 0 0x0000d800 - 0x0000d8ff (0x100) IX[B]
[9] -1 0 0x0000dc00 - 0x0000dc3f (0x40) IX[B]
[10] -1 0 0x0000ff00 - 0x0000ff0f (0x10) IX[B]
[11] -1 0 0x00000c00 - 0x00000c1f (0x20) IX[B]
[12] -1 0 0x0000b800 - 0x0000b8ff (0x100) IX[B](B)
(II) OS-reported resource ranges after removing overlaps with PCI:
[0] -1 0 0xffe00000 - 0xffffffff (0x200000) MX[B](B)
[1] -1 0 0x00100000 - 0x3fffffff (0x3ff00000) MX[B]E(B)
[2] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[B]
[3] -1 0 0x000c0000 - 0x000effff (0x30000) MX[B]
[4] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[B]
[5] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[B]
[6] -1 0 0x00000000 - 0x000000ff (0x100) IX[B]
(II) All system resource ranges:
[0] -1 0 0xffe00000 - 0xffffffff (0x200000) MX[B](B)
[1] -1 0 0x00100000 - 0x3fffffff (0x3ff00000) MX[B]E(B)
[2] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[B]
[3] -1 0 0x000c0000 - 0x000effff (0x30000) MX[B]
[4] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[B]
[5] -1 0 0xcfffdf00 - 0xcfffdfff (0x100) MX[B]
[6] -1 0 0xcfffc000 - 0xcfffcfff (0x1000) MX[B]
[7] -1 0 0xcffff000 - 0xcfffffff (0x1000) MX[B]
[8] -1 0 0xcfffe000 - 0xcfffefff (0x1000) MX[B]
[9] -1 0 0xd0000000 - 0xcfffffff (0x0) MX[B]O
[10] -1 0 0xcfec0000 - 0xcfedffff (0x20000) MX[B](B)
[11] -1 0 0xcfef0000 - 0xcfefffff (0x10000) MX[B](B)
[12] -1 0 0xb0000000 - 0xbfffffff (0x10000000) MX[B](B)
[13] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[B]
[14] -1 0 0x00000000 - 0x000000ff (0x100) IX[B]
[15] -1 0 0x0000d800 - 0x0000d8ff (0x100) IX[B]
[16] -1 0 0x0000dc00 - 0x0000dc3f (0x40) IX[B]
[17] -1 0 0x0000ff00 - 0x0000ff0f (0x10) IX[B]
[18] -1 0 0x00000c00 - 0x00000c1f (0x20) IX[B]
[19] -1 0 0x0000b800 - 0x0000b8ff (0x100) IX[B](B)
(II) LoadModule: "dbe"
(II) Loading /usr/X11R6/lib/modules/extensions/libdbe.a
(II) Module dbe: vendor="X.Org Foundation"
compiled for 6.8.1.99, module version = 1.0.0
Module class: X.Org Server Extension
ABI class: X.Org Server Extension, version 0.2
(II) Loading extension DOUBLE-BUFFER
(II) LoadModule: "v4l"
(II) Loading /usr/X11R6/lib/modules/drivers/linux/v4l_drv.o
(II) Module v4l: vendor="X.Org Foundation"
compiled for 6.8.1.99, module version = 0.0.1
ABI class: X.Org Video Driver, version 0.7
(II) LoadModule: "extmod"
(II) Loading /usr/X11R6/lib/modules/extensions/libextmod.a
(II) Module extmod: vendor="X.Org Foundation"
compiled for 6.8.1.99, module version = 1.0.0
Module class: X.Org Server Extension
ABI class: X.Org Server Extension, version 0.2
(II) Loading extension SHAPE
(II) Loading extension MIT-SUNDRY-NONSTANDARD
(II) Loading extension BIG-REQUESTS
(II) Loading extension SYNC
(II) Loading extension MIT-SCREEN-SAVER
(II) Loading extension XC-MISC
(II) Loading extension XFree86-VidModeExtension
(II) Loading extension XFree86-Misc
(II) Loading extension XFree86-DGA
(II) Loading extension DPMS
(II) Loading extension TOG-CUP
(II) Loading extension Extended-Visual-Information
(II) Loading extension XVideo
(II) Loading extension XVideo-MotionCompensation
(II) Loading extension X-Resource
(II) LoadModule: "type1"
(II) Loading /usr/X11R6/lib/modules/fonts/libtype1.a
(II) Module type1: vendor="X.Org Foundation"
compiled for 6.8.1.99, module version = 1.0.2
Module class: X.Org Font Renderer
ABI class: X.Org Font Renderer, version 0.4
(II) Loading font Type1
(II) Loading font CID
(II) LoadModule: "freetype"
(II) Loading /usr/X11R6/lib/modules/fonts/libfreetype.so
(II) Module freetype: vendor="X.Org Foundation & the After X-TT Project"
compiled for 6.8.1.99, module version = 2.1.0
Module class: X.Org Font Renderer
ABI class: X.Org Font Renderer, version 0.4
(II) Loading font FreeType
(II) LoadModule: "glx"
(II) Loading /usr/X11R6/lib/modules/extensions/libglx.a
(II) Module glx: vendor="X.Org Foundation"
compiled for 6.8.1.99, module version = 1.0.0
ABI class: X.Org Server Extension, version 0.2
(II) Loading sub module "GLcore"
(II) LoadModule: "GLcore"
(II) Loading /usr/X11R6/lib/modules/extensions/libGLcore.a
(II) Module GLcore: vendor="X.Org Foundation"
compiled for 6.8.1.99, module version = 1.0.0
ABI class: X.Org Server Extension, version 0.2
(II) Loading extension GLX
(II) LoadModule: "nv"
(II) Loading /usr/X11R6/lib/modules/drivers/nv_drv.o
(II) Module nv: vendor="X.Org Foundation"
compiled for 6.8.1.99, module version = 1.0.1
Module class: X.Org Video Driver
ABI class: X.Org Video Driver, version 0.7
(II) LoadModule: "kbd"
(II) Loading /usr/X11R6/lib/modules/input/kbd_drv.o
(II) Module kbd: vendor="X.Org Foundation"
compiled for 6.8.1.99, module version = 1.0.0
Module class: X.Org XInput Driver
ABI class: X.Org XInput driver, version 0.4
(II) LoadModule: "mouse"
(II) Loading /usr/X11R6/lib/modules/input/mouse_drv.o
(II) Module mouse: vendor="X.Org Foundation"
compiled for 6.8.1.99, module version = 1.0.0
Module class: X.Org XInput Driver
ABI class: X.Org XInput driver, version 0.4
(II) v4l driver for Video4Linux
(II) NV: driver for NVIDIA chipsets: RIVA 128, RIVA TNT, RIVA TNT2,
Unknown TNT2, Vanta, RIVA TNT2 Ultra, RIVA TNT2 Model 64,
Aladdin TNT2, GeForce 256, GeForce DDR, Quadro, GeForce2 MX/MX 400,
GeForce2 MX 100/200, GeForce2 Go, Quadro2 MXR/EX/Go,
GeForce2 Integrated GPU, GeForce2 GTS, GeForce2 Ti, GeForce2 Ultra,
Quadro2 Pro, GeForce4 MX 460, GeForce4 MX 440, GeForce4 MX 420,
GeForce4 MX 440-SE, GeForce4 440 Go, GeForce4 420 Go,
GeForce4 420 Go 32M, GeForce4 460 Go, GeForce4 440 Go 64M,
GeForce4 410 Go 16M, Quadro4 500 GoGL, Quadro4 550 XGL, Quadro4 NVS,
GeForce4 MX 440 with AGP8X, GeForce4 MX 440SE with AGP8X,
GeForce4 MX 420 with AGP8X, GeForce4 448 Go, GeForce4 488 Go,
Quadro4 580 XGL, Quadro4 280 NVS, Quadro4 380 XGL,
GeForce4 MX Integrated GPU, GeForce3, GeForce3 Ti 200,
GeForce3 Ti 500, Quadro DCC, GeForce4 Ti 4600, GeForce4 Ti 4400,
0x0252, GeForce4 Ti 4200, Quadro4 900 XGL, Quadro4 750 XGL,
Quadro4 700 XGL, GeForce4 Ti 4800, GeForce4 Ti 4200 with AGP8X,
GeForce4 Ti 4800 SE, GeForce4 4200 Go, Quadro4 700 GoGL,
Quadro4 980 XGL, Quadro4 780 XGL, GeForce FX 5800 Ultra,
GeForce FX 5800, Quadro FX 2000, Quadro FX 1000,
GeForce FX 5600 Ultra, GeForce FX 5600, 0x0313, GeForce FX 5600SE,
0x0316, 0x0317, GeForce FX Go5600, GeForce FX Go5650,
Quadro FX Go700, 0x031D, 0x031E, 0x031F, GeForce FX 5200,
GeForce FX 5200 Ultra, GeForce FX 5200, GeForce FX 5200SE,
GeForce FX Go5200, GeForce FX Go5250, GeForce FX Go5200 32M/64M,
0x0329, Quadro NVS 280 PCI, Quadro FX 500, GeForce FX Go5300,
GeForce FX Go5100, 0x032F, GeForce FX 5900 Ultra, GeForce FX 5900,
GeForce FX 5900XT, GeForce FX 5950 Ultra, 0x0334, Quadro FX 3000,
GeForce FX 5700 Ultra, GeForce FX 5700, GeForce FX 5700LE,
GeForce FX 5700VE, 0x0345, GeForce FX Go5700, GeForce FX Go5700,
0x0349, 0x034B, Quadro FX Go1000, Quadro FX 1100, 0x034F
(II) Primary Device is: PCI 01:00:0
(EE) No devices detected.

Fatal server error:
no screens found

Please consult the The X.Org Foundation support
at http://wiki.X.Org
for help.
Please also check the log file at "/var/log/Xorg.0.log" for additional information."


one question:

what is the graphical configuration: Xorg.conf or xf86config? Since i noticed that in Xorg.conf the nvidia card is still listed instead of the new one.
 
Old 04-05-2005, 02:22 PM   #4
Phorem
Member
 
Registered: Nov 2003
Location: Toronto, Canada
Distribution: Gentoo AMD64
Posts: 374

Rep: Reputation: 30
xorg.conf will come first then it will try xf86config. Rename xf86config and edit the xorg file and see if that works. If not leave the XF86Config there but rename the xorg.conf to something else. Then make a symbolic link like :

ln -sf /etc/X11/XF86Config /etc/X11/xorg.conf

Try and see if any of that works.
 
Old 04-05-2005, 02:32 PM   #5
masand
Guru
 
Registered: May 2003
Location: INDIA
Distribution: Ubuntu, Solaris,CentOS
Posts: 5,522

Rep: Reputation: 58
post ur " /etc/X11/xorg.conf" file
 
Old 04-05-2005, 02:58 PM   #6
scrubbit
LQ Newbie
 
Registered: Apr 2005
Posts: 4

Original Poster
Rep: Reputation: 0
I tried what Phorem suggested earlier, sadly to no avail...
Gone through drakconf and changed the video card to ati radeon, still not working...
Here is my /etc/X11/xorg.conf:

# File generated by XFdrake.

# **********************************************************************
# Refer to the XF86Config man page for details about the format of
# this file.
# **********************************************************************

Section "Files"
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Mandrake 6.0 and later now use a font server independent of
# the X server to render fonts.
FontPath "unix/:-1"
EndSection

Section "ServerFlags"
#DontZap # disable <Crtl><Alt><BS> (server abort)
AllowMouseOpenFail # allows the server to start up even if the mouse doesn't work
#DontZoom # disable <Crtl><Alt><KP_+>/<KP_-> (resolution switching)
EndSection

Section "Module"
Load "dbe" # Double-Buffering Extension
Load "v4l" # Video for Linux
Load "extmod"
Load "type1"
Load "freetype"
Load "glx" # 3D layer
Load "dri" # direct rendering
EndSection

Section "DRI"
Mode 0666
EndSection

Section "InputDevice"
Identifier "Keyboard1"
Driver "Keyboard"
Option "XkbModel" "pc105"
Option "XkbLayout" "pt"
Option "XkbOptions" ""
EndSection

Section "InputDevice"
Identifier "Mouse1"
Driver "mouse"
Option "Protocol" "ExplorerPS/2"
Option "Device" "/dev/mouse"
Option "ZAxisMapping" "6 7"
EndSection

Section "Monitor"
Identifier "monitor1"
VendorName "Plug'n Play"
ModelName "Sony CPD-A200"
HorizSync 30-70
VertRefresh 48-120

# Sony Vaio C1(X,XS,VE,VN)?
# 1024x480 @ 85.6 Hz, 48 kHz hsync
ModeLine "1024x480" 65.00 1024 1032 1176 1344 480 488 494 563 -hsync -vsync

# TV fullscreen mode or DVD fullscreen output.
# 768x576 @ 79 Hz, 50 kHz hsync
ModeLine "768x576" 50.00 768 832 846 1000 576 590 595 630

# 768x576 @ 100 Hz, 61.6 kHz hsync
ModeLine "768x576" 63.07 768 800 960 1024 576 578 590 616
EndSection

Section "Device"
Identifier "device1"
VendorName "ATI"
BoardName "ATI Radeon (fglrx)"
Driver "radeon"
Option "DPMS"
EndSection

Section "Screen"
Identifier "screen1"
Device "device1"
Monitor "monitor1"
DefaultColorDepth 24

Subsection "Display"
Depth 8
Virtual 1024 768
EndSubsection

Subsection "Display"
Depth 15
Virtual 1024 768
EndSubsection

Subsection "Display"
Depth 16
Virtual 1024 768
EndSubsection

Subsection "Display"
Depth 24
Virtual 1024 768
EndSubsection
EndSection

Section "ServerLayout"
Identifier "layout1"
InputDevice "Keyboard1" "CoreKeyboard"
InputDevice "Mouse1" "CorePointer"
Screen "screen1"
EndSection
 
Old 04-05-2005, 03:13 PM   #7
masand
Guru
 
Registered: May 2003
Location: INDIA
Distribution: Ubuntu, Solaris,CentOS
Posts: 5,522

Rep: Reputation: 58
ur file looks fine to me

did u configuire ur card using
xorgconfig

run this in a shell

regards
 
Old 04-05-2005, 03:41 PM   #8
scrubbit
LQ Newbie
 
Registered: Apr 2005
Posts: 4

Original Poster
Rep: Reputation: 0
it looks fine but i simply cannot boot into graphical mode. i only get a text prompt, it tries to boot into the x server, for a few seconds the screen stutters but in the end all i get is a text prompt with a user login where an experienced user (unlike me!) could work wonders, i , however, am at a loss.
will try the xorgconfig...
nonetheless thanks for replying, people!
 
Old 04-05-2005, 10:52 PM   #9
masand
Guru
 
Registered: May 2003
Location: INDIA
Distribution: Ubuntu, Solaris,CentOS
Posts: 5,522

Rep: Reputation: 58
i do not prefer upgrading the X server packages until they are not from the Linux repository i use

here the problerm i thin is that u are stuck in between 2 major changes in X server packages

regards
 
Old 04-05-2005, 11:00 PM   #10
perfect_circle
Senior Member
 
Registered: Oct 2004
Location: Athens, Greece
Distribution: Slackware, arch
Posts: 1,783

Rep: Reputation: 52
Check your error messages again.
If you type :
Code:
startx &> startx_log
the startx output will be stored in startx_log
It may be really simple.
The new X.org needs :
Driver "kbd" instead of
Driver "Keyboard", but i don't know how old your xorg is...
 
Old 04-06-2005, 10:34 AM   #11
Phorem
Member
 
Registered: Nov 2003
Location: Toronto, Canada
Distribution: Gentoo AMD64
Posts: 374

Rep: Reputation: 30
Well scrubbit, now that i look a little more closely, i noticed a couple things. If you look at the xorg.log dump you have posted above, it mentions nothing of an ATI driver. All i see is your xserver looking for the nvidia card

"(II) NV: driver for NVIDIA chipsets: RIVA 128, RIVA TNT, RIVA TNT2,
Unknown TNT2, Vanta, RIVA TNT2 Ultra, RIVA TNT2 Model 64,
Aladdin TNT2, GeForce 256, GeForce DDR, Quadro, GeForce2 MX/MX 400,
GeForce2 MX 100/200, GeForce2 Go, Quadro2 MXR/EX/Go,
GeForce2 Integrated GPU, GeForce2 GTS, GeForce2 Ti, GeForce2 Ultra,
Quadro2 Pro, GeForce4 MX 460, GeForce4 MX 440, GeForce4 MX 420,
GeForce4 MX 440-SE, GeForce4 440 Go, GeForce4 420 Go,
GeForce4 420 Go 32M, GeForce4 460 Go, GeForce4 440 Go 64M.................."


It looks like you might have the remnants of an old XF86Config file or an old xorg.conf file lying around that it keeps getting loaded instead of the ati xorg.conf.

At the command line (where you're at now :-D )do

ls -a /etc/X11/

See if there is more than one XF86Config or xorg.conf -
there should ONLY be one or the other. In mandrake, it uses the XF86Config file for the xserver settings. So, your xorg.conf is really just a XF86Config renamed to xorg.conf (which is fine as the xserver can handle this). Where the problem might lie is having both of these files in the same directory (symbolic links are ok). It appears that it's using the old xorg.conf or XF86Config. So, if you have a symbolic of say the xorg.conf pointing to the XF86Config file, that is ok (like what we did above ln -sf /etc...blah). What i would do, is make sure it's loading only ONE config file. All i can say right now is check to make sure that there is only one and that it's the right one that has the ATI changes. See if that works.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
x800 video card, x server won't start Mr. Mojo Risin Linux - Hardware 1 06-06-2005 02:26 PM
video card change and start-up pcandpc Linux - Newbie 7 05-12-2005 04:44 PM
Installed new Video card and X wont start.. need help please! Fear58 Linux - Hardware 1 07-18-2004 10:01 AM
Video card upgrade on an old computer OMV Linux - Hardware 1 05-02-2004 04:22 PM
video card upgrade crashed gnome TakuanSo_Ho Linux - Software 5 02-09-2003 06:41 PM


All times are GMT -5. The time now is 01:08 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration