LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 08-03-2005, 03:12 PM   #1
gros777
LQ Newbie
 
Registered: Aug 2005
Location: El Salvador, Central America
Posts: 7

Rep: Reputation: 0
Question cannot open tv card and /dev/video0 device on suse 9.3


ok people i need some help, i have some troubles with my tv card, is a new one and i've never had one before, its my first time configuring this kind of hard ware.... at first time i use yast to configure the card and i thougt that it works 'couse i find the model in auto detection.... is a FlyVideo2000 FM card, then i've tried to initialize the tv card with xawtv and send me this message:
This is xawtv-3.94, running on Linux/i686 (2.6.11.4-20a-default)
can't open /dev/video0: No such device
v4l-conf had some trouble, trying to continue anyway
v4l2: open /dev/video0: No existe tal dispositivo
v4l2: open /dev/video0: No existe tal dispositivo
v4l: open /dev/video0: No existe tal dispositivo
no video grabber device available


i chek the kernel modules and its fine i think and i've think that i have to make the device by may self, but i've never doit before... some body can help me please.....
 
Old 08-05-2005, 12:12 PM   #2
otchie1
Registered User
 
Registered: Apr 2004
Posts: 560

Rep: Reputation: 30
I have a Fly Video TV card and it works fine.

i needed to have appropriate modules though including tuner, saa7134, v4l & i2c.

Once that was all sorted it was just a case of checking the /dev/video0 actually existed
Code:
cd /dev
ls | grep vid
and making sure the permissions were okay. I think it defaults as a root device so you might need to chmod 666 it or add yourself to a video group.

reading through http://www.exploits.org/v4l/ will help you loads

Last edited by otchie1; 08-05-2005 at 12:14 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
/dev/video0: No such device meranto Linux - Hardware 5 11-12-2005 10:38 AM
please help! Couldn't open /dev/video0 jrmontg Linux - Hardware 3 10-30-2005 06:47 PM
Failed to open device /dev/usb/ttyUSB0: No such device efm Linux - Newbie 2 04-04-2005 08:46 PM
V4L: "cat /dev/video0: no such device"; to be sure not supported? jago25_98 Linux - Hardware 1 01-27-2005 04:04 PM
Can't install TV-card: /dev/v4l/video0 missing christian-s Linux - Hardware 8 08-19-2004 10:14 AM


All times are GMT -5. The time now is 10:39 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration