LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices



Reply
 
Search this Thread
Old 06-14-2005, 01:32 PM   #1
Gerard_2009
LQ Newbie
 
Registered: Jan 2005
Location: Switzerland
Distribution: debain lenny, slackware 10.0, vectorlinux 4.3, kubuntu feisty
Posts: 23

Rep: Reputation: 15
cannot find usb-storage with fdisk -l


hello,

i just installed Knoppix 3.9 to my harddisk, now most of it runs fine, but if I want to mount my usb memory stick, I dont find it with

fdisk -l,
(same for an usb HD drive)

i only see the partitions of
/dev/hda

the stick is formated with vfat,
in /proc/filesystems i have an entry vfat

lsmod gives

usb_storage
ohci_hcd
uhci_hcd
ehci_hcd
usbcore
usbhid


my usb mouse is working fine...

can anybody help.

thanks a lot
 
Old 06-14-2005, 02:11 PM   #2
Gerard_2009
LQ Newbie
 
Registered: Jan 2005
Location: Switzerland
Distribution: debain lenny, slackware 10.0, vectorlinux 4.3, kubuntu feisty
Posts: 23

Original Poster
Rep: Reputation: 15
alright, some more info,

just trying to mount /dev/sda1 or sdb1 or something like it doesnt work!

I checked with apt-get
udev
usbmount
initscripts
are NOT installed

installed is sysvinit, if I want to install udev, usbmount and initscripts there is an error processing initscripts_2.86.ds1-1_i386.deb

----------------
trying to overwrite '/etc/init.d/checkroot.sh', which is also in package sysvinit
---------------

so apt-get -f install
doesnt work either!

I didnt dare removing sysvinit as it depends on some important looking stuff


------------------
home/gerard# apt-get remove sysvinit
Reading Package Lists... Done
Building Dependency Tree... Done
The following packages will be REMOVED:
bluez-utils btpin-knoppix console-common console-data console-tools euro-support-console
firewall-knoppix ipw2100-modules-2.6.11 ipw2200-modules-2.6.11 knoppix-terminalserver
madwifi-modules-2.6.11 modutils nfs-common nfs-kernel-server nis sysvinit
WARNING: The following essential packages will be removed
This should NOT be done unless you know exactly what you are doing!
sysvinit
0 upgraded, 0 newly installed, 16 to remove and 13 not upgraded.
Need to get 0B of archives.
After unpacking 14.2MB disk space will be freed.
You are about to do something potentially harmful
To continue type in the phrase 'Yes, do as I say!'
-----------------------------------------------------

however I dont know if I need that stuff,
for my cisco pcmcia wireless card i think the modules used are
airo
airo_cs
is that what's in the madwifi-modules package?
and concerning the rest, i dont need nfs, and the knoppix firewall i dont need either,
but the console stuff looks important (apart from euro-support-console..)

hope that helps to find the problem
 
Old 06-14-2005, 03:12 PM   #3
Gerard_2009
LQ Newbie
 
Registered: Jan 2005
Location: Switzerland
Distribution: debain lenny, slackware 10.0, vectorlinux 4.3, kubuntu feisty
Posts: 23

Original Poster
Rep: Reputation: 15
alright, I kind of shifted the problem... :-)

after doing the above, and Not removing sysvinit, so i didnt really change anything:

I cant log in as user anymore (in xdm)

if I want to log in into a virutal terminal ttyX as user, I get:

"bash: /dev/null: Permission denied"

and that like 50 times, all over the screen....

I found out that I have to change permissions on
/dev/null

to be able to log in again as user, but I can still only log into the virtual terminal,

logging in into X is only possible for root....
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
After plug in apacer ht202 usb mass storage into usb port. Nothing appear. tellmeimhong Linux - Hardware 3 02-04-2006 03:32 AM
sure, fdisk -l to find devices ... stabu Slackware 7 10-02-2005 02:10 AM
Can't find fdisk Add1Sun Linux - Newbie 5 04-22-2004 02:38 PM
Can't find USB storage ld5221 Linux - Newbie 4 03-19-2004 12:24 AM
can't find fdisk? nigham Linux - Newbie 4 02-06-2004 02:57 AM


All times are GMT -5. The time now is 12:15 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration