LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (http://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   Cannot find DVD-Burner (/dev/hda) (http://www.linuxquestions.org/questions/linux-hardware-18/cannot-find-dvd-burner-dev-hda-346344/)

logosys 07-24-2005 05:45 PM

Cannot find DVD-Burner (/dev/hda)
 
I have 2 hard drives on my IDE2 - so they're listed as /dev/hdc and /dev/hdd
My DVD-ROM is listed as /dev/hdb - but there is no /dev/hda - therefore, I can't burn DVD's (only read them) the device is registering in the boot sequence...

I'm running debian sarge for AMD64

Any advice as to what I should do? Thanks so much

aikidoist72 07-24-2005 07:20 PM

Wow! This looks like a mess.

Here is what I get from your info

hda - nothing on it
hdb - DVD
hdc - hard drive 1
hdd - hard drive 2

Is this correct?

The problem exists here that you are booting from a setup that you will need to tweak. Without a bit of experience up your sleeve you will find this a little hard in the future. Your BIOS must allow you to boot from any hard drive, so you have not noticed that you have the ide cables on the wrong channels.

Primary Master = /dev/hda
Primary Slave = /dev/hdb
Secondary Master = /dev/hdc
Secondary Slave = /dev/hdd

hda should be your main hard drive whether Windows or Linux.
hdb should be your second hard drive again with Windows or Linux.
hdc should be your DVD rom
hdd spare.

If you go switching hard drives, your fstab file will be incorrect and you will not be able to boot up. To change this problem your fstab file should be edited before changing anything and should reflect the hdx that is appropriate. Here is a snippet from mine running Slackware on hda with my prefered partitioning scheme.
Code:

#Slackware 10.1
/dev/hda1        /boot            ext3        defaults        1  1
/dev/hda3        /home            reiserfs    defaults        1  1
/dev/hda4        /data            reiserfs    defaults        1  2
/dev/hda5        /                reiserfs    defaults        0  0
/dev/hda6        swap            swap        defaults        0  0
/dev/hda7        /var            reiserfs    defaults        1  2
/dev/hda8        /opt            reiserfs    defaults        1  2
/dev/hda9        /usr            reiserfs    defaults        1  2
/dev/cdrom      /mnt/dvd        auto        noauto,owner,users,rw  0  0
/dev/dvd        /mnt/dvd        auto        noauto,owner,users,rw  0  0

Your fstab file is located under the /etc folder. I don't really know what you are after from your question. You can get k3b or what ever you burning software is to recognise your DVD on the hdb channel, just go into the settings and change the device section to /dev/hdb

logosys 07-24-2005 07:27 PM

unfortunately, my IDE cable doesn't reach from the IDE2 slot to my DVD drives, thus them being on the first IDE controller.

hda - DVD-RW (not found anywhere)
hdb - DVD-ROM (working fine)
hdc - HDD1 (used for different OS)
hdd - HDD2 (my debian HDD)

My fstab looks like:
Code:

# /etc/fstab: static file system information.
#
# <file system> <mount point>  <type>  <options>      <dump>  <pass>
proc            /proc          proc    defaults        0      0
/dev/hdd3      /              ext3    defaults,errors=remount-ro 0      1
/dev/hdd2      /boot          ext3    defaults        0      2
/dev/hdd5      /home          ext3    defaults        0      2
/dev/hdd11      /opt            ext3    defaults        0      2
/dev/hdd10      /srv            ext3    defaults        0      2
/dev/hdd6      /tmp            ext3    defaults        0      2
/dev/hdd7      /usr            ext3    defaults        0      2
/dev/hdd9      /usr/local      ext3    defaults        0      2
/dev/hdd8      /var            ext3    defaults        0      2
/dev/hdd1      none            swap    sw              0      0
/dev/hdb        /media/cdrom0  iso9660 ro,user,noauto  0      0
/dev/hda        /media/cdrom1  iso9660 ro,user,noauto  0      0
/dev/fd0        /media/floppy0  auto    rw,user,noauto  0      0

When I put a DVD in the drive (or a CD for that matter) it doesn't mount it, and I can't find a way to access it at all....


aikidoist72 07-24-2005 07:35 PM

To confirm, you are talking about two separate DVD roms.

I would say you need to check the jumper switch at the back of the DVD roms. They should be located next to your power inlets, and they look like a small plastic cover connecting two pins. There will be instructions on the DVD rom top for the various combinations.

eg
:::|: - may be Slave
::|:: - may be Cable Select
:|::: - may be Master Only.............. etc

You will need to place both on cable select for a trouble free setting.

aikidoist72 07-24-2005 07:41 PM

Also I would alter your fstab file to look like this
Code:

# /etc/fstab: static file system information.
#
# <file system> <mount point>  <type>  <options>      <dump>  <pass>
proc            /proc          proc    defaults        0      0
/dev/hdd3      /              ext3    defaults,errors=remount-ro 0      1
/dev/hdd2      /boot          ext3    defaults        0      2
/dev/hdd5      /home          ext3    defaults        0      2
/dev/hdd11      /opt            ext3    defaults        0      2
/dev/hdd10      /srv            ext3    defaults        0      2
/dev/hdd6      /tmp            ext3    defaults        0      2
/dev/hdd7      /usr            ext3    defaults        0      2
/dev/hdd9      /usr/local      ext3    defaults        0      2
/dev/hdd8      /var            ext3    defaults        0      2
/dev/hdd1      none            swap    sw              0      0
/dev/hdb        /media/cdrom1  iso9660,udf ro,user,noauto  0      0
/dev/hda        /media/cdrom0  auto rw,user,noauto  0      0
/dev/fd0        /media/floppy0  auto    rw,user,noauto  0      0


logosys 07-24-2005 07:58 PM

yes, I have 2 DVD drives (one RW, one ROM) one is set to master, one is set to slave. I know this setup works, because I used it to burn the DVD that I installed debian off of. It's odd that it's showing up in the fstab file, but there is no /dev/hda file....

aikidoist72 07-24-2005 08:14 PM

Now I feel realllyyyyyy silly!!!!

Go to your /dev folder and look for cdrom and cdrom0. We are trying to make hda = cdrom. hda stands for "hard disk a". We want cdrom
Code:

# /etc/fstab: static file system information.
#
# <file system> <mount point>  <type>  <options>      <dump>  <pass>
proc            /proc          proc    defaults        0      0
/dev/hdd3      /              ext3    defaults,errors=remount-ro 0      1
/dev/hdd2      /boot          ext3    defaults        0      2
/dev/hdd5      /home          ext3    defaults        0      2
/dev/hdd11      /opt            ext3    defaults        0      2
/dev/hdd10      /srv            ext3    defaults        0      2
/dev/hdd6      /tmp            ext3    defaults        0      2
/dev/hdd7      /usr            ext3    defaults        0      2
/dev/hdd9      /usr/local      ext3    defaults        0      2
/dev/hdd8      /var            ext3    defaults        0      2
/dev/hdd1      none            swap    sw              0      0
/dev/cdrom0        /media/cdrom1  iso9660,udf ro,user,noauto  0      0
/dev/cdrom        /media/cdrom0  auto rw,user,noauto  0      0
/dev/fd0        /media/floppy0  auto    rw,user,noauto  0      0



All times are GMT -5. The time now is 08:13 AM.