LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (http://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   can only print text with hp photosmart premium series c309 (http://www.linuxquestions.org/questions/linux-hardware-18/can-only-print-text-with-hp-photosmart-premium-series-c309-765147/)

joel2001k 10-28-2009 07:36 PM

can only print text with hp photosmart premium series c309
 
I have a new printer and want it to work with GNU/Linux but I don't know what driver to select with foomatic-gui. I tried it with hp-setup but had no success. Then I tried to following command `gtklp file.c` and the printer began to print but didn't work with pdf. As I looked at
http://localhost:631/printers/Photos...remium_C309g-m, I saw that the Driver is Generic text-only printer (grayscale)

Could someone help me to get it to work correctly

here is my output of `lsusb`

Code:

Bus 003 Device 002: ID 03f0:171d Hewlett-Packard Wireless (Bluetooth + WLAN) Interface [Integrated Module]
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 008 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 002: ID 08ff:2810 AuthenTec, Inc.
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 003: ID 03f0:7d11 Hewlett-Packard
Bus 002 Device 002: ID 059b:0470 Iomega Corp.
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 004: ID 04f2:b059 Chicony Electronics Co., Ltd
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub


tredegar 10-30-2009 02:04 PM

HP are generally good with linux support.

Do you have the following packages installed: hpijs foomatic-db-hpijs hplip hplip-data hplip-gui ?

If not, install them and then try installing your printer again.

imatechguy 11-02-2009 10:56 PM

My wife just ordered this device and it was actually fairly easy to set up. Your problem is probably that the hplip version in your distro's repository isn't current enough to support the device, it is a fairly new one.

You can solve this by going to http://hplipopensource.com/hplip-web/index.html, click the big green "Get HPLIP" button, answer the questions to get the right version and and once the file downloads follow the instructions displayed on the site to complete the install.


All times are GMT -5. The time now is 09:01 PM.