LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 02-19-2010, 06:51 AM   #1
dbbolton
LQ Newbie
 
Registered: Sep 2009
Location: WV
Distribution: Debian
Posts: 28

Rep: Reputation: 15
Can't write to floppy


I am trying to write a floppy boot image to my floppy drive (as root):
Code:
dd if=boot.img of=/dev/fd0
dd: opening `/dev/fd0': Read-only file system
But it is mounted as rw in my fstab:
Code:
/dev/fd0        /media/floppy0  auto    rw,user,noauto  0       0
When I try to mount it manually:
Code:
mount /dev/fd0
mount: block device /dev/fd0 is write-protected, mounting read-only
And it appears root has rw privileges:
Code:
ll /dev/fd0
brw-rw---- 1 root floppy 2, 0 2010-02-18 21:50 /dev/fd0


I also tried uncommenting the line in /etc/fstab, rebooting, then mounting it manually:
Code:
mount -t vfat /dev/fd0 /media/floppy
mount: block device /dev/fd0 is write-protected, mounting read-only
mount: /dev/fd0: can't read superblock
Here is the dmesg output:
Code:
[ 4775.928065] last result at 4296085528
[ 4775.928067] last redo_fd_request at 4296085528
[ 4775.928068] 20  0
[ 4775.928077] status=50
[ 4775.928079] fdc_busy=1
[ 4775.928080] do_floppy=ffffffffa01283bc
[ 4775.928082] fd_timer.function=ffffffffa012bb6b
[ 4775.928083] cont=ffffffffa012fe50
[ 4775.928085] current_req=ffff88005d4e4d20
[ 4775.928087] command_status=-1
[ 4775.928088]
[ 4775.928091] floppy0: floppy timeout called
[ 4775.928096] end_request: I/O error, dev fd0, sector 0
I have tried several disks, with the safety tab in both positions (to ensure that I tried it when it was unlocked), but it is always the same result.

What is the problem here?

Last edited by dbbolton; 02-19-2010 at 06:57 AM.
 
Old 02-19-2010, 07:02 AM   #2
allend
Senior Member
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 3,395

Rep: Reputation: 828Reputation: 828Reputation: 828Reputation: 828Reputation: 828Reputation: 828Reputation: 828
From 'man mount':
Quote:
Mount options for msdos
See mount options for fat. If the msdos file system detects an inconsistency, it reports an error and sets the file system read-only. The file system can be made writeable again by remounting it.
You may have the disk formatted as FAT16 rather than FAT32.
Try 'mount -t msdos /dev/fd0 /media/floppy'.
 
Old 02-19-2010, 07:04 AM   #3
HasC
Member
 
Registered: Oct 2009
Location: South America - Paraguay
Distribution: Debian 5 - Slackware 13.1 - Arch - Some others linuxes/*BSDs through KVM and Xen
Posts: 329

Rep: Reputation: 55
Floppy drive busted, perhaps?

Could you get another drive? Surely could not be very hard to do
 
Old 02-19-2010, 07:06 AM   #4
HasC
Member
 
Registered: Oct 2009
Location: South America - Paraguay
Distribution: Debian 5 - Slackware 13.1 - Arch - Some others linuxes/*BSDs through KVM and Xen
Posts: 329

Rep: Reputation: 55
Quote:
Originally Posted by allend View Post
From 'man mount':

You may have the disk formatted as FAT16 rather than FAT32.
Try 'mount -t msdos /dev/fd0 /media/floppy'.
But that doesn't explain the dd error.

Unless, its user isn't root nor member of group "floppy"
 
Old 02-19-2010, 07:10 AM   #5
allend
Senior Member
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 3,395

Rep: Reputation: 828Reputation: 828Reputation: 828Reputation: 828Reputation: 828Reputation: 828Reputation: 828
@HasC
Quote:
But that doesn't explain the dd error.
Ah, doh! Good point.
 
Old 02-19-2010, 07:21 AM   #6
dbbolton
LQ Newbie
 
Registered: Sep 2009
Location: WV
Distribution: Debian
Posts: 28

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by allend View Post
From 'man mount':

You may have the disk formatted as FAT16 rather than FAT32.
Try 'mount -t msdos /dev/fd0 /media/floppy'.
Code:
 mount -t msdos /dev/fd0 /media/floppy
mount: block device /dev/fd0 is write-protected, mounting read-only
mount: /dev/fd0: can't read superblock
 
Old 02-19-2010, 07:28 AM   #7
michaelk
Moderator
 
Registered: Aug 2002
Posts: 11,850

Rep: Reputation: 736Reputation: 736Reputation: 736Reputation: 736Reputation: 736Reputation: 736Reputation: 736
As already suggested I suspect the drive is bad.
Is this a dual boot PC where you can check it with another OS?
 
Old 02-19-2010, 07:34 AM   #8
dbbolton
LQ Newbie
 
Registered: Sep 2009
Location: WV
Distribution: Debian
Posts: 28

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by michaelk View Post
As already suggested I suspect the drive is bad.
Is this a dual boot PC where you can check it with another OS?
The drive very well could be bad. It's fairly old.

It is a dual boot machine: Debian amd64 and Debian i386. I suspect that I will get the same results on the i386 system, but I will try it anyway.
 
Old 02-19-2010, 10:18 AM   #9
dbbolton
LQ Newbie
 
Registered: Sep 2009
Location: WV
Distribution: Debian
Posts: 28

Original Poster
Rep: Reputation: 15
I tried in the i386 system and got the same messages.
 
Old 01-12-2012, 11:39 PM   #10
lexrexus
LQ Newbie
 
Registered: Jan 2007
Posts: 6

Rep: Reputation: 0
Arrow Floppy tests? Here's one:

Above someone said dos sets to read only when something isn't working right, or close to that - w/out giving an error? And in another post says something about can't read a block - or something like that. So, try fsck - Used to check and repair a filesystem.
fsck is a front end to a filesystem type specific fsck.ext2, fsck.minix, and fsck.msdos.
Syntax: fsck -t type device
Like fsck -t msdos /dev/fd0

This post is still here, so this is a timely reply.
I've noticed that few will help w/floppy problems anymore
So the odds r great that this will benefit someone stuck w/legacy tools, reading through what their search came up with. : ]
Tnx!!
 
Old 01-13-2012, 06:50 AM   #11
business_kid
Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 6,266

Rep: Reputation: 540Reputation: 540Reputation: 540Reputation: 540Reputation: 540Reputation: 540
From my experience, you can mount a msdos/vfat system with either option and they sort themselves out - if you have them in the kernel.

You need kernel based floppy support, (perhaps including some legacy stuff) and msdos & vfat support (vfat supports msdos anyhow).

I suspect
1. You don't have kernel support
2. The read/write function in the floppy is bad.
 
Old 01-14-2012, 05:21 AM   #12
nigelc
Member
 
Registered: Oct 2004
Location: Sydney, Australia
Distribution: Mageia 4
Posts: 302
Blog Entries: 4

Rep: Reputation: 52
Hello,
Have you tried to read from the floppy?
Try & see if will read first as writing is harder to do.

cheers
 
  


Reply

Tags
floppy, protected, read, write


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't Write to floppy foysol_bgd Linux - Newbie 3 02-15-2007 12:10 AM
Can't write to floppy TxLonghorn Linux - Newbie 4 03-17-2005 08:03 PM
can't write to the floppy ??!?? safrout Mandriva 2 11-16-2004 12:08 PM
Still can't write to floppy - why? jhecht Linux - Software 6 06-28-2004 11:36 AM
Write to a CD-RW like a floppy... harrkev Linux - General 1 10-26-2001 12:29 PM


All times are GMT -5. The time now is 10:03 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration