LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 10-07-2010, 10:45 PM   #1
bonixavier
Member
 
Registered: Sep 2010
Distribution: Slackware
Posts: 320

Rep: Reputation: 60
Can't install NVIDIA proprietary driver in Slackware 13.1


I've been trying to install the driver for my NVIDIA GeForce 6150SE nForce 430 in Slackware 13.1 with no success. I always get the same error report: the module you're trying to build does not match the kernel source or something like that. The result: unable to build module and the installation crashes.

I have tried to:
  • set a custom kernel source path,
  • install it with the slackbuilds driver and kernel,
  • extract the contents and trying to compile it myself,
  • find possibly conflicting drivers or modules,
  • use different versions of the same driver (I've tried installing the versions 256.53, 256.44, 195.36.31 and 173.14.27)
  • recompile the Linux kernel in an attempt to make sure that the tools used to build the kernel were the same used o build the module.

The only time I got a different error message was when I used the slackbuild packages. It built the 'nvidia.ko' module, but it didn't work. I got a version magic notice when booting and, when I tried to start x, a fatal error "no screens were found."

Just to be sure, I made a clean full install of Slackware (only added WICD to be able to download the drivers and ran slackpkg update and upgrade all) and tried again. It didn't work.

I have browsed as much as I could, but now I gave up. Can anybody help me, please? If you need me to post any logs, the actual messages that were displayed, etc. I'll do it ASAP. Just don't ask me to recompile the kernel again unless you're damn sure it will work because it takes forever to do that and it would be frustrating to go through that for the third time without success.

Thanks in advance!
Attached Files
File Type: log syslog.log (15.8 KB, 6 views)

Last edited by bonixavier; 10-08-2010 at 07:04 AM.
 
Old 10-07-2010, 11:48 PM   #2
Nikosis
Member
 
Registered: Dec 2005
Location: In front of the monitor
Distribution: Slackware
Posts: 310

Rep: Reputation: 59
I assume you use 32bit version. So you should use only 256.53 or one of the previous versions, not 195.x.x nor 173.x.x.
Can you post xorg log
 
1 members found this post helpful.
Old 10-08-2010, 12:02 AM   #3
disturbed1
Senior Member
 
Registered: Mar 2005
Location: USA
Distribution: Slackware
Posts: 1,133
Blog Entries: 6

Rep: Reputation: 223Reputation: 223Reputation: 223
/proc/config.gz
/boot/config
and
/usr/src/linux/.config
Should all match.
/usr/src/linux should be or link to the current running kernel.
/usr/src/linux should be in a ready state --- make prepare.
 
1 members found this post helpful.
Old 10-08-2010, 07:02 AM   #4
bonixavier
Member
 
Registered: Sep 2010
Distribution: Slackware
Posts: 320

Original Poster
Rep: Reputation: 60
Quote:
Originally Posted by Nikosis View Post
I assume you use 32bit version. So you should use only 256.53 or one of the previous versions, not 195.x.x nor 173.x.x.
Can you post xorg log
I installed the slackbuilds package again (256.44) so I posted 2 logs: one from before it was installed and the current one.
Looking at it now, I see that X has been trying to load "dri", but I commented it out in the xorg.conf. That might be the cause of my problems because the nvidia readme file states that that module should be disabled. Or maybe it's something else. It also asks me to check the kernel log for details so I attached it too on the OP because I couldn't do it here.
By the way, should I use another format for them? It seems they still keep the same permissions requirements they had. Maybe copy/paste would be better?

Quote:
Originally Posted by disturbed1 View Post
/proc/config.gz
/boot/config
and
/usr/src/linux/.config
Should all match.
/usr/src/linux should be or link to the current running kernel.
/usr/src/linux should be in a ready state --- make prepare.
So, /usr/src/linux is a link to /usr/src/linux/2.6.33.4. Is that the running kernel? I ran make prepare there. I have a question: how can I make sure that /proc/config.gz is the same as the other two files? I tried to open it to check, but it's a binary.

Guys, thanks for the support. Any other information you need, just ask.
Attached Files
File Type: log Xorg.0.log (5.1 KB, 4 views)
File Type: txt Xorg.0.log.pre.slackbuild.txt (36.1 KB, 2 views)
 
Old 10-08-2010, 07:20 AM   #5
brianL
LQ 5k Club
 
Registered: Jan 2006
Location: Oldham, Lancs, England
Distribution: Slackware & Slackware64 14.1
Posts: 6,963
Blog Entries: 52

Rep: Reputation: Disabled
Quote:
NVIDIA GeForce 6150SE nForce 430
Same as mine, in my desktop. I didn't use the SlackBuild, but downloaded and ran (as root, at runlevel 3) the latest driver from the NVidia website. And everything is OK.
 
1 members found this post helpful.
Old 10-08-2010, 07:24 AM   #6
bonixavier
Member
 
Registered: Sep 2010
Distribution: Slackware
Posts: 320

Original Poster
Rep: Reputation: 60
Quote:
Originally Posted by brianL View Post
Same as mine, in my desktop. I didn't use the SlackBuild, but downloaded and ran (as root, at runlevel 3) the latest driver from the NVidia website. And everything is OK.
I envy you so much! grrr...
 
Old 10-08-2010, 07:28 AM   #7
brianL
LQ 5k Club
 
Registered: Jan 2006
Location: Oldham, Lancs, England
Distribution: Slackware & Slackware64 14.1
Posts: 6,963
Blog Entries: 52

Rep: Reputation: Disabled
Well, try it yourself, get the 256.53 from here:
http://www.nvidia.com/object/unix.html
 
1 members found this post helpful.
Old 10-08-2010, 07:32 AM   #8
bonixavier
Member
 
Registered: Sep 2010
Distribution: Slackware
Posts: 320

Original Poster
Rep: Reputation: 60
Quote:
Originally Posted by brianL View Post
Well, try it yourself, get the 256.53 from here:
http://www.nvidia.com/object/unix.html
I did. That's where I started. I began experimenting different paths when it was not working. The installer always crashes - it is unable to build the kernel. Apparently, the slackbuilds script could do it, but I can't get X to start without some further tweaking that I don't know how to do.
 
Old 10-08-2010, 07:43 AM   #9
brianL
LQ 5k Club
 
Registered: Jan 2006
Location: Oldham, Lancs, England
Distribution: Slackware & Slackware64 14.1
Posts: 6,963
Blog Entries: 52

Rep: Reputation: Disabled
I don't know the solution, but it might be better if you got this thread moved to the Slackware forum.
 
1 members found this post helpful.
Old 10-09-2010, 03:09 PM   #10
Nikosis
Member
 
Registered: Dec 2005
Location: In front of the monitor
Distribution: Slackware
Posts: 310

Rep: Reputation: 59
What exactly did you do, when recompiling the kernel?
Did you have it working before?
 
Old 10-09-2010, 05:00 PM   #11
bonixavier
Member
 
Registered: Sep 2010
Distribution: Slackware
Posts: 320

Original Poster
Rep: Reputation: 60
Quote:
Originally Posted by Nikosis View Post
What exactly did you do, when recompiling the kernel?
Did you have it working before?
Just changed some settings, such as adding the appropriate processor, but keeping the rest of the config unaltered. However, I am NOT running a recompiled kernel. I am trying to install this friendly driver in a clean install of Slackware 13.1. The only things that are different from what came from the full install are:
1-installed wicd.
2-slackpkg update and slackpkg upgrade-all,
3-slackbuilds driver and kernel + the executable from nvidia's website.

As to the other question, it has never worked in Slackware. I could get it working in Ubuntu 10.04.
 
Old 10-09-2010, 05:21 PM   #12
GazL
Senior Member
 
Registered: May 2008
Posts: 3,380

Rep: Reputation: 913Reputation: 913Reputation: 913Reputation: 913Reputation: 913Reputation: 913Reputation: 913Reputation: 913
I prefer to use the NVIDIA.run installer rather than the slackbuilds.org packages and it's always worked for me.

Have you switched to running the 'generic' kernel, initrd & modules rather than the initial 'huge' install kernel. If not then you might want to do that before trying to install the proprietary nvidia driver. Have a read of /boot/README.initrd if you need any guidance on that.

You also need to ensure that the kernel source for your running kernel is installed or the nvidia kernel module won't build.
 
1 members found this post helpful.
Old 10-09-2010, 05:21 PM   #13
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 5,234

Rep: Reputation: Disabled
You are running a non-SMP kernel in 32-bit Slackware ("/boot/vmlinuz-huge-2.6.33.4" according to your X.Org logfile).

If you run a non-SMP kernel (why? it would only be required on old hardware usually) you have to tweak the installed kernel source. SLackware's kernel source package has been pre-configured to generate kernel modules for a SMP kernel. That is why you get those "version magic" errors.
If you want to build kernel modules for a non-SMP kernel, then use the information you find here: http://slackware.osuosl.org/slackwar...3.4-nosmp-sdk/ to "patch" your copy of the kernel source.

After you do that, building a NVIDIA kernel module will no longer fail.

Eric
 
1 members found this post helpful.
Old 10-09-2010, 05:34 PM   #14
bonixavier
Member
 
Registered: Sep 2010
Distribution: Slackware
Posts: 320

Original Poster
Rep: Reputation: 60
Quote:
Originally Posted by Alien Bob View Post
If you run a non-SMP kernel (why? it would only be required on old hardware usually) you have to tweak the installed kernel source.
I also wonder why. I didn't type in the huge option when installing. I chose a full install and might have missed it when I got the option to select the kernel. Is there anyway I can switch to the SMP one? I suppose most things I try to install will bring me the same problems. Is that something I can still do or is it an installation option?

Either way, I'll look into what was suggested and report back.

Thanks guys!
 
Old 10-09-2010, 05:47 PM   #15
GazL
Senior Member
 
Registered: May 2008
Posts: 3,380

Rep: Reputation: 913Reputation: 913Reputation: 913Reputation: 913Reputation: 913Reputation: 913Reputation: 913Reputation: 913
Converting to use the 'generic-smp' (or just 'generic' on x86_64) kernel is a manual step you have to do post install. The details are in that README.initrd file I mentioned in my post above.

This is one of those little slackware quirks you have to get used to. Personally I wish Pat would just do away with the 'huge' kernels and have the install dialogs set this up for the user.
 
1 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
NVIDIA Driver issues (Proprietary drivers wont install properly) SgtATON Linux - Newbie 9 04-20-2010 09:11 AM
Has anyone tried the proprietary driver with an Nvidia gt310m? damgar Linux - Hardware 1 04-18-2010 03:05 AM
proprietary nvidia driver crashes slackware 13 x86_64 fancylad Slackware 15 01-24-2010 02:04 PM
NVidia proprietary driver + suspend to ram (Slackware 12.1) El Nigromante Slackware 6 10-15-2008 11:16 AM
does the vesa console framebuffer driver conflict with the proprietary nvidia driver? mr.v. Linux - Hardware 2 01-28-2007 06:51 AM


All times are GMT -5. The time now is 01:27 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration