LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices



Reply
 
Search this Thread
Old 08-22-2005, 08:42 AM   #1
hartigan
LQ Newbie
 
Registered: Aug 2005
Posts: 2

Rep: Reputation: 0
can't hear cd sound


All seems to work correctly, but I can't hear any sound from cd
Amarok, xmms, juk and kscd all seem to play the cd (time is running), but no sound.

yes, I turned the required lights on in Kmix
yes, I did install my soundcard properly
and yes, it DOES work in that other crappy operating system
there's nothing wrong with cables or something like that

I'm using the very popular mandrake 10.1, i think playing a cd is not the most complicated thing.

I'm very frustrated, for it's just such a simple thing
 
Old 08-22-2005, 09:38 AM   #2
camorri
Senior Member
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.1
Posts: 4,873

Rep: Reputation: 434Reputation: 434Reputation: 434Reputation: 434Reputation: 434
Can you play sounds from any other source, like an mp3 file or web radio? Since you know your CD player works on some other OS, (that eliminates the cables and hardware) some setting may be muted, volume truned down, or your sound card not configured correctly.

Would you please post the results of teh command "lsmod" ( as su ). You should see the sound modules that are loaded. If not, that may be the source of your problems. Here is a sample of what it may look like.

Quote:
snd-seq-oss 31232 0
snd-seq-midi-event 6080 1 snd-seq-oss
snd-seq 47440 4 snd-seq-oss,snd-seq-midi-event
snd-pcm-oss 49480 1
snd-mixer-oss 17376 2 snd-pcm-oss
snd-es18xx 27084 3
snd-pcm 81800 2 snd-pcm-oss,snd-es18xx
snd-page-alloc 7400 1 snd-pcm
snd-opl3-lib 8448 1 snd-es18xx
snd-timer 20356 3 snd-seq,snd-pcm,snd-opl3-lib
snd-hwdep 6916 1 snd-opl3-lib
snd-mpu401-uart 5856 1 snd-es18xx
snd-rawmidi 19300 1 snd-mpu401-uart
snd-seq-device 6344 4 snd-seq-oss,snd-seq,snd-opl3-lib,snd-rawmidi
snd 45988 14 snd-seq-oss,snd-seq,snd-pcm-oss,snd-mixer-oss,snd-es18xx,snd-pcm,snd-opl3-lib,snd-timer,snd-hwdep,snd-mpu401-uart,snd-rawmidi,snd-seq-device
soundcore 7008 3 snd
 
Old 08-22-2005, 02:39 PM   #3
hartigan
LQ Newbie
 
Registered: Aug 2005
Posts: 2

Original Poster
Rep: Reputation: 0
thanks for reacting!

yeah, mp3's, radio's and audio from movies are working fine. Hope you can decifer something from this:

[root@x1722033180 helmer]# lsmod
Module Size Used by
binfmt_misc 9992 1
ppp_synctty 9088 0
ppp_async 10208 1
crc-ccitt 2656 1 ppp_async
ppp_generic 27028 6 ppp_synctty,ppp_async
slhc 7104 1 ppp_generic
md5 4576 1
ipv6 249412 10
rfcomm 34456 0
l2cap 22368 5 rfcomm
bluetooth 42436 4 rfcomm,l2cap
snd-seq-oss 33728 0
snd-seq-midi-event 7328 1 snd-seq-oss
snd-seq 52560 4 snd-seq-oss,snd-seq-midi-event
snd-pcm-oss 51080 0
snd-mixer-oss 18592 1 snd-pcm-oss
snd-intel8x0 31660 1
snd-ac97-codec 70736 1 snd-intel8x0
snd-pcm 86948 2 snd-pcm-oss,snd-intel8x0
snd-timer 22724 2 snd-seq,snd-pcm
snd-page-alloc 8392 2 snd-intel8x0,snd-pcm
gameport 4416 1 snd-intel8x0
snd-mpu401-uart 7168 1 snd-intel8x0
snd-rawmidi 21188 1 snd-mpu401-uart
snd-seq-device 7336 3 snd-seq-oss,snd-seq,snd-rawmidi
snd 49028 13 snd-seq-oss,snd-seq,snd-pcm-oss,snd-mixer-oss,snd-intel8x0,snd-ac97-codec,snd-pcm,snd-t
imer,snd-mpu401-uart,snd-rawmidi,snd-seq-device
soundcore 8288 1 snd
af_packet 17864 6
eth1394 18792 0
8139too 22816 0
mii 5216 1 8139too
ide-cd 38528 0
cdrom 38844 1 ide-cd
ohci1394 32676 0
ieee1394 294872 2 eth1394,ohci1394
loop 13896 0
joydev 9056 0
nls_iso8859-1 4672 1
evdev 8672 0
tsdev 6848 0
ntfs 149980 1
usbmouse 5216 0
usbhid 43328 0
intel-agp 20608 1
agpgart 29036 1 intel-agp
sd_mod 20320 0
usb-storage 67040 0
scsi_mod 107428 3 sd_mod,usb-storage
ehci-hcd 27972 0
uhci-hcd 30448 0
usbcore 107396 7 usbmouse,usbhid,usb-storage,ehci-hcd,uhci-hcd
ext3 123496 2
jbd 56600 1 ext3
 
Old 08-22-2005, 03:46 PM   #4
camorri
Senior Member
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.1
Posts: 4,873

Rep: Reputation: 434Reputation: 434Reputation: 434Reputation: 434Reputation: 434
I don't see any problems with the loaded modules, and since you can play mp3's and web radio, they must be O.K.

The only other thing that comes to my mind is the User and Group the devices for the CD player are set for. I can remember changing mine on 10.1 to group "audio", but I can't remember why I did it. To check that out, if you click on the Home icon on the desktop, and navigate to /dev/sound you should see about 5 icons. I changes the group to "audio" You can make sure your user, and any other user wanting to play CD's belongs to group audio.

One other question, when you try to play a CD, does the disk light for the CD player go on and off? It should.
 
Old 08-22-2005, 11:51 PM   #5
J.W.
LQ Veteran
 
Registered: Mar 2003
Location: Milwaukee, WI
Distribution: Mint
Posts: 6,642

Rep: Reputation: 69
There is a small cable that runs from the CD drive to your sound card. Is it installed correctly? The reason Windows can work without it is because it uses "digital extraction", which is also avaiable in Linux, but not by default -- J.W.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
I can't hear any sound when I play a cd or mp3...but tested with system tools->Sound Niceman2005 Linux - General 6 10-31-2005 10:51 AM
Sound Card - can hear sounds and test fine - no cd sound PAB Linux - Hardware 11 10-27-2004 07:23 AM
I still can't hear sound morrisset Red Hat 3 07-21-2004 10:38 PM
sound card configured. can hear testsound. cant hear cd's tdr_nj Red Hat 2 04-19-2004 10:36 PM
Canít hear sound after running Sound Config Al Bundy Linux - General 27 07-31-2003 06:38 AM


All times are GMT -5. The time now is 07:18 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration