LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 02-12-2007, 03:40 PM   #1
argt
LQ Newbie
 
Registered: Apr 2005
Distribution: Debian/sid
Posts: 3

Rep: Reputation: 0
Can't use module mach64 with xorg


Hi,

I am trying to enable 3d acceleration on Gentoo kernel 2.6.18-gentoo-r6.

lspci gives me:
01:00.0 VGA compatible controller: ATI Technologies Inc 3D Rage Pro AGP 1X/2X (rev 5c)

and a quick research told me I should use the mach64 module to have 3d acceleration.
So I followed the how-to:
http://www.gentoo.org/doc/en/dri-howto.xml#doc_chap5

First problem, there isn't (or isn't anymore) anything like a insecure-driver use flag for xorg-x11.
I did not have any trouble to emerge x11-drm and it did build the module mach64.ko in /usr/lib/modules/<kernel-version>.

But when I try to launch X, it crashes with the following error:
(WW) Warning, couldn't open module mach64
(II) UnloadModule: "mach64"
(EE) Failed to load module "mach64" (module does not exist, 0)

I can modprobe mach64 before but it does not change anything.

X works (but without dri) if I use:

Driver "ati"

instead of:
Driver "mach64"

I haven't tried to use the cvs snapshots so far.

I only have basic knowledge of Gentoo, but have been using a Debian for several years before.

Thanks for any help.
 
Old 04-18-2007, 06:06 PM   #2
lambchops468
Member
 
Registered: Mar 2007
Location: New Jersey, USA
Distribution: Archlinux
Posts: 165

Rep: Reputation: 30
Troubleshooting page on the DRI wiki

Hi,

Just yesterday I was trying to get a mach64 video card to work on SUSE 10.2, but I didn't do it right and I have to start over again, but I found a nice interesting troubleshooting page here

http://dri.freedesktop.org/wiki/DriTroubleshooting

Anyways, the only Linux distro I ever used was SUSE, so I can't exactly help much, but I'm pretty sure you need the driver "ati" in xorg.conf.

(Yesterday, I did use the driver "ati", which allowed DRI to try and start on my xorg server, but I had version inconsistencies which caused xorg to not start.)

And then you should follow the troubleshooting, I guess...
Go poke around /var/log/Xorg.0.log and try looking for signs of trouble.
 
Old 08-20-2007, 09:39 PM   #3
angryjoe
LQ Newbie
 
Registered: Nov 2004
Posts: 4

Rep: Reputation: 0
I know I have an old video card, I installed gentoo on an HP Pavillion 8260.

I have a mach64 vt chip that uses the ati driver for xorg. I'm having trouble getting it to dri. The dri.freedesktop.org says they don't support vt chips. I've tried to install mach64 from the git repository(anyway) and still no dri. Has anyone gotten the mach64 vt to do direct rendering?
 
Old 08-22-2007, 06:29 PM   #4
angryjoe
LQ Newbie
 
Registered: Nov 2004
Posts: 4

Rep: Reputation: 0
Unhappy nevermind it can't be done

ran command: #less /var/log/Xorg.0.log | grep rendering
gave out put
{
(WW) ATI(0): Direct rendering is not supported for ATI chips earlier than the ATI 3D Rage....
(II) ATI(0): Direct rendering disabled
}
anyway glxgears gives me 67fps tops any other way to increase this?
watching youtube is like reading a comic strip...
 
  


Reply

Tags
gentoo


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Xorg input driver module howto CrazyGenie Linux - Desktop 0 12-14-2006 12:53 AM
xorg: Failed to load module... NullDevice23 Linux - Hardware 4 08-05-2006 10:01 AM
Xorg.conf type1 module slackernewb Slackware 2 06-05-2006 08:25 PM
nvidia module fails after upgrade to xorg coyopil Debian 2 06-04-2006 07:40 AM
Xorg - (EE) Failed to load module "i810".... frogboy Linux - Laptop and Netbook 1 10-17-2004 01:11 AM


All times are GMT -5. The time now is 03:35 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration