LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
LinkBack Search this Thread
Old 10-16-2008, 07:56 PM   #1
themrrobert
Member
 
Registered: Feb 2007
Distribution: Debian Sid
Posts: 47

Rep: Reputation: 16
Angry Can't get framebuffer working at boot.


Hey everyone.
Ok so I've spent several hours searching google with as many searches as i could muster, and have tried numerous solutions, all of which to no avail.

I am running debian Sid 2.6.26-1-686 with an nVidia GeForce FX 5200

I hope I am placing this in the right place.

When I boot (grub-legacy-sid) and try to boot in a fb console, it never works, example: i try vga=791 and it gives me the ol' Screen not found [0x]317. Please select a video mode blah blah blah.

I checked the .config in the Kernel headers /usr/src/linux/.config, and FB_VESA=y and FB_UVESA=m.

I tried as many vga modes as I could, but could not get the framebuffer with the tux logo. I then tried to get uvesa working, by making sure klibc was installed and v86d and changed the kernel line to video=uvesafb:1024x768-32 also with no luck. I'm driving myself crazy trying to get this to work, any help would be much appreciated.

Oh yes... I am running the latest nVidia proprietary drivers [tsk i know], and also, I am showing a /dev/fb0 once i'm in X, which makes me think its something so simple I'm going to want to throw my keyboard off a cliff, but i will try to remain composed.

Thank you again.

-Robert



lspci
Code:
00:00.0 Host bridge: VIA Technologies, Inc. VT8366/A/7 [Apollo KT266/A/333]
00:01.0 PCI bridge: VIA Technologies, Inc. VT8366/A/7 [Apollo KT266/A/333 AGP]
00:09.0 FireWire (IEEE 1394): Agere Systems FW323 (rev 61)
00:0b.0 PCI bridge: PicoPower Technology PT86C525 [Nile-II] PCI-to-PCI Bridge (rev 01)
00:10.0 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 80)
00:10.1 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 80)
00:10.2 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 80)
00:10.3 USB Controller: VIA Technologies, Inc. USB 2.0 (rev 82)
00:11.0 ISA bridge: VIA Technologies, Inc. VT8235 ISA Bridge
00:11.1 IDE interface: VIA Technologies, Inc. VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE (rev 06)
00:11.5 Multimedia audio controller: VIA Technologies, Inc. VT8233/A/8235/8237 AC97 Audio Controller (rev 50)
00:12.0 Ethernet controller: VIA Technologies, Inc. VT6102 [Rhine-II] (rev 74)
01:00.0 VGA compatible controller: nVidia Corporation NV34 [GeForce FX 5200] (rev a1)
02:08.0 SCSI storage controller: Advanced System Products, Inc ABP940-U / ABP960-U (rev 03)
02:09.0 Multimedia video controller: Zoran Corporation ZR36057PQC Video cutting chipset (rev 02)
dmesg
Code:
[    0.000000] Initializing cgroup subsys cpuset
[    0.000000] Initializing cgroup subsys cpu
[    0.000000] Linux version 2.6.26-1-686 (Debian 2.6.26-8) (waldi@debian.org) (gcc version 4.1.3 20080623 (prerelease) (Debian 4.1.2-23)) #1 SMP Thu Oct 9 15:18:09 UTC 2008
[    0.000000] BIOS-provided physical RAM map:
[    0.000000]  BIOS-e820: 0000000000000000 - 000000000009f800 (usable)
[    0.000000]  BIOS-e820: 000000000009f800 - 00000000000a0000 (reserved)
[    0.000000]  BIOS-e820: 00000000000f0000 - 0000000000100000 (reserved)
[    0.000000]  BIOS-e820: 0000000000100000 - 000000001fff0000 (usable)
[    0.000000]  BIOS-e820: 000000001fff0000 - 000000001fff3000 (ACPI NVS)
[    0.000000]  BIOS-e820: 000000001fff3000 - 0000000020000000 (ACPI data)
[    0.000000]  BIOS-e820: 00000000ffff0000 - 0000000100000000 (reserved)
[    0.000000] 0MB HIGHMEM available.
[    0.000000] 511MB LOWMEM available.
[    0.000000] Entering add_active_range(0, 0, 131056) 0 entries of 256 used
[    0.000000] Zone PFN ranges:
[    0.000000]   DMA             0 ->     4096
[    0.000000]   Normal       4096 ->   131056
[    0.000000]   HighMem    131056 ->   131056
[    0.000000] Movable zone start PFN for each node
[    0.000000] early_node_map[1] active PFN ranges
[    0.000000]     0:        0 ->   131056
[    0.000000] On node 0 totalpages: 131056
[    0.000000]   DMA zone: 32 pages used for memmap
[    0.000000]   DMA zone: 0 pages reserved
[    0.000000]   DMA zone: 4064 pages, LIFO batch:0
[    0.000000]   Normal zone: 992 pages used for memmap
[    0.000000]   Normal zone: 125968 pages, LIFO batch:31
[    0.000000]   HighMem zone: 0 pages used for memmap
[    0.000000]   Movable zone: 0 pages used for memmap
[    0.000000] DMI 2.2 present.
[    0.000000] ACPI: RSDP 000F6A20, 0014 (r0 VIA694)
[    0.000000] ACPI: RSDT 1FFF3000, 0028 (r1 VIA694 AWRDACPI 42302E31 AWRD        0)
[    0.000000] ACPI: FACP 1FFF3040, 0074 (r1 VIA694 AWRDACPI 42302E31 AWRD        0)
[    0.000000] ACPI: DSDT 1FFF30C0, 3147 (r1 VIA694 AWRDACPI     1000 MSFT  100000E)
[    0.000000] ACPI: FACS 1FFF0000, 0040
[    0.000000] ACPI: PM-Timer IO Port: 0x4008
[    0.000000] Allocating PCI resources starting at 30000000 (gap: 20000000:dfff0000)
[    0.000000] PM: Registered nosave memory: 000000000009f000 - 00000000000a0000
[    0.000000] PM: Registered nosave memory: 00000000000a0000 - 00000000000f0000
[    0.000000] PM: Registered nosave memory: 00000000000f0000 - 0000000000100000
[    0.000000] SMP: Allowing 0 CPUs, 0 hotplug CPUs
[    0.000000] PERCPU: Allocating 37960 bytes of per cpu data
[    0.000000] NR_CPUS: 8, nr_cpu_ids: 1
[    0.000000] Built 1 zonelists in Zone order, mobility grouping on.  Total pages: 130032
[    0.000000] Kernel command line: root=UUID=17475b68-4c97-4320-a495-a53838d73537 ro quiet video=uvesafb:1024x768-32 splash 
[    0.000000] Local APIC disabled by BIOS -- you can enable it with "lapic"
[    0.000000] mapped APIC to ffffb000 (0140d000)
[    0.000000] Enabling fast FPU save and restore... done.
[    0.000000] Enabling unmasked SIMD FPU exception support... done.
[    0.000000] Initializing CPU#0
[    0.000000] PID hash table entries: 2048 (order: 11, 8192 bytes)
[    0.000000] Detected 1907.381 MHz processor.
[    0.004000] Console: colour VGA+ 80x25
[    0.004000] console [tty0] enabled
[    0.004000] Dentry cache hash table entries: 65536 (order: 6, 262144 bytes)
[    0.004000] Inode-cache hash table entries: 32768 (order: 5, 131072 bytes)
[    0.004000] Memory: 508620k/524224k available (1768k kernel code, 15028k reserved, 749k data, 244k init, 0k highmem)
[    0.004000] virtual kernel memory layout:
[    0.004000]     fixmap  : 0xfff4c000 - 0xfffff000   ( 716 kB)
[    0.004000]     pkmap   : 0xff800000 - 0xffc00000   (4096 kB)
[    0.004000]     vmalloc : 0xe0800000 - 0xff7fe000   ( 495 MB)
[    0.004000]     lowmem  : 0xc0000000 - 0xdfff0000   ( 511 MB)
[    0.004000]       .init : 0xc037d000 - 0xc03ba000   ( 244 kB)
[    0.004000]       .data : 0xc02ba053 - 0xc0375620   ( 749 kB)
[    0.004000]       .text : 0xc0100000 - 0xc02ba053   (1768 kB)
[    0.004000] Checking if this processor honours the WP bit even in supervisor mode...Ok.
[    0.004000] CPA: page pool initialized 1 of 1 pages preallocated
[    0.084035] Calibrating delay using timer specific routine.. 3818.82 BogoMIPS (lpj=7637649)
[    0.084082] Security Framework initialized
[    0.084089] SELinux:  Disabled at boot.
[    0.084094] Capability LSM initialized
[    0.084114] Mount-cache hash table entries: 512
[    0.084296] Initializing cgroup subsys ns
[    0.084301] Initializing cgroup subsys cpuacct
[    0.084304] Initializing cgroup subsys devices
[    0.084326] CPU: L1 I Cache: 64K (64 bytes/line), D cache 64K (64 bytes/line)
[    0.084329] CPU: L2 Cache: 512K (64 bytes/line)
[    0.084334] Intel machine check architecture supported.
[    0.084337] Intel machine check reporting enabled on CPU#0.
[    0.084354] Checking 'hlt' instruction... OK.
[    0.100201] SMP alternatives: switching to UP code
[    0.107631] Freeing SMP alternatives: 16k freed
[    0.107637] ACPI: Core revision 20080321
[    0.113785] ACPI: setting ELCR to 0200 (from 0e28)
[    0.120007] weird, boot CPU (#0) not listedby the BIOS.
[    0.120007] SMP motherboard not detected.
[    0.120007] Local APIC not detected. Using dummy APIC emulation.
[    0.120007] SMP disabled
[    0.120007] Brought up 1 CPUs
[    0.120007] Total of 1 processors activated (3818.82 BogoMIPS).
[    0.120007] CPU0 attaching sched-domain:
[    0.120007]  domain 0: span 0
[    0.120007]   groups: 0
[    0.120007] net_namespace: 660 bytes
[    0.120007] Booting paravirtualized kernel on bare hardware
[    0.120007] NET: Registered protocol family 16
[    0.120007] ACPI: bus type pci registered
[    0.121731] PCI: PCI BIOS revision 2.10 entry at 0xfb3e0, last bus=2
[    0.121734] PCI: Using configuration type 1 for base access
[    0.121746] Setting up standard PCI resources
[    0.132008] ACPI: EC: Look up EC in DSDT
[    0.136008] ACPI: Interpreter enabled
[    0.136008] ACPI: (supports S0 S1 S4 S5)
[    0.136008] ACPI: Using PIC for interrupt routing
[    0.139518] ACPI: PCI Root Bridge [PCI0] (0000:00)
[    0.140004] pci 0000:00:11.0: quirk: region 4000-407f claimed by vt8235 PM
[    0.140008] pci 0000:00:11.0: quirk: region 5000-500f claimed by vt8235 SMB
[    0.140417] ACPI: PCI Interrupt Routing Table [\_SB_.PCI0._PRT]
[    0.157429] ACPI: PCI Interrupt Link [LNKA] (IRQs 1 3 4 5 6 7 *10 11 12 14 15)
[    0.157608] ACPI: PCI Interrupt Link [LNKB] (IRQs 1 *3 4 5 6 7 10 11 12 14 15)
[    0.157789] ACPI: PCI Interrupt Link [LNKC] (IRQs 1 3 4 *5 6 7 10 11 12 14 15)
[    0.157968] ACPI: PCI Interrupt Link [LNKD] (IRQs 1 3 4 5 6 7 10 *11 12 14 15)
[    0.158123] Linux Plug and Play Support v0.97 (c) Adam Belay
[    0.158160] pnp: PnP ACPI init
[    0.158169] ACPI: bus type pnp registered
[    0.161208] pnp: PnP ACPI: found 12 devices
[    0.161211] ACPI: ACPI bus type pnp unregistered
[    0.161215] PnPBIOS: Disabled by ACPI PNP
[    0.161543] PCI: Using ACPI for IRQ routing
[    0.161780] ACPI: RTC can wake from S4
[    0.161812] system 00:00: iomem range 0xdb000-0xdbfff has been reserved
[    0.161816] system 00:00: iomem range 0xf0000-0xf7fff could not be reserved
[    0.161819] system 00:00: iomem range 0xf8000-0xfbfff could not be reserved
[    0.161822] system 00:00: iomem range 0xfc000-0xfffff could not be reserved
[    0.161826] system 00:00: iomem range 0x1fff0000-0x1fffffff could not be reserved
[    0.161829] system 00:00: iomem range 0xffff0000-0xffffffff could not be reserved
[    0.161832] system 00:00: iomem range 0x0-0x9ffff could not be reserved
[    0.161836] system 00:00: iomem range 0x100000-0x1ffeffff could not be reserved
[    0.161839] system 00:00: iomem range 0xfee00000-0xfee00fff has been reserved
[    0.161843] system 00:00: iomem range 0xfff80000-0xfffeffff has been reserved
[    0.161850] system 00:02: ioport range 0x4000-0x407f has been reserved
[    0.161854] system 00:02: ioport range 0x5000-0x500f has been reserved
[    0.161862] system 00:03: ioport range 0x4d0-0x4d1 has been reserved
[    0.161865] system 00:03: ioport range 0x800-0x805 has been reserved
[    0.161869] system 00:03: ioport range 0x290-0x297 has been reserved
[    0.192313] PCI: Bridge: 0000:00:01.0
[    0.192316]   IO window: disabled.
[    0.192321]   MEM window: 0xe0000000-0xe1ffffff
[    0.192325]   PREFETCH window: 0x00000000d0000000-0x00000000dfffffff
[    0.192331] PCI: Bridge: 0000:00:0b.0
[    0.192334]   IO window: c000-cfff
[    0.192338]   MEM window: 0xe2000000-0xe3ffffff
[    0.192342]   PREFETCH window: 0x0000000030000000-0x00000000300fffff
[    0.192360] PCI: Setting latency timer of device 0000:00:01.0 to 64
[    0.192388] NET: Registered protocol family 2
[    0.192488] IP route cache hash table entries: 4096 (order: 2, 16384 bytes)
[    0.192755] TCP established hash table entries: 16384 (order: 5, 131072 bytes)
[    0.193010] TCP bind hash table entries: 16384 (order: 5, 131072 bytes)
[    0.193257] TCP: Hash tables configured (established 16384 bind 16384)
[    0.193260] TCP reno registered
[    0.193336] NET: Registered protocol family 1
[    0.193475] checking if image is initramfs... it is
[    0.696048] Switched to high resolution mode on CPU 0
[    0.816566] Freeing initrd memory: 7229k freed
[    0.817412] audit: initializing netlink socket (disabled)
[    0.817433] type=2000 audit(1224202627.816:1): initialized
[    0.817586] Total HugeTLB memory allocated, 0
[    0.817671] VFS: Disk quotas dquot_6.5.1
[    0.817709] Dquot-cache hash table entries: 1024 (order 0, 4096 bytes)
[    0.817758] msgmni has been set to 1007
[    0.817885] Block layer SCSI generic (bsg) driver version 0.4 loaded (major 253)
[    0.817890] io scheduler noop registered
[    0.817892] io scheduler anticipatory registered
[    0.817894] io scheduler deadline registered
[    0.817904] io scheduler cfq registered (default)
[    0.817918] PCI: VIA PCI bridge detected.Disabling DAC.
[    0.817996] pci 0000:01:00.0: Boot video device
[    0.818418] isapnp: Scanning for PnP cards...
[    1.172554] isapnp: No Plug & Play device found
[    1.175738] Serial: 8250/16550 driver $Revision: 1.90 $ 4 ports, IRQ sharing enabled
[    1.175869] serial8250: ttyS0 at I/O 0x3f8 (irq = 4) is a 16550A
[    1.176367] 00:09: ttyS0 at I/O 0x3f8 (irq = 4) is a 16550A
[    1.178271] brd: module loaded
[    1.178378] PNP: PS/2 Controller [PNP0303:PS2K] at 0x60,0x64 irq 1
[    1.178382] PNP: PS/2 appears to have AUX port disabled, if this is incorrect please boot with i8042.nopnp
[    1.178520] serio: i8042 KBD port at 0x60,0x64 irq 1
[    1.178679] mice: PS/2 mouse device common for all mice
[    1.178825] rtc_cmos 00:05: rtc core: registered rtc_cmos as rtc0
[    1.178848] rtc0: alarms up to one year, y3k
[    1.178891] cpuidle: using governor ladder
[    1.178894] cpuidle: using governor menu
[    1.178900] No iBFT detected.
[    1.179424] TCP cubic registered
[    1.179429] NET: Registered protocol family 17
[    1.179438] Using IPI No-Shortcut mode
[    1.179589] registered taskstats version 1
[    1.179773] rtc_cmos 00:05: setting system clock to 2008-10-17 00:17:08 UTC (1224202628)
[    1.180228] Freeing unused kernel memory: 244k freed
[    1.196288] input: AT Translated Set 2 keyboard as /class/input/input0
[    1.381956] splashy[340]: segfault at c ip b7f3d2ad sp bfb60010 error 4 in libsplashy.so.1[b7f3b000+5000]
[    1.438030] ACPI: PNP0C0B:00 is registered as cooling_device0
[    1.438042] ACPI: Fan [FAN] (on)
[    1.444983] ACPI: CPU0 (power states: C1[C1] C2[C2])
[    1.445048] ACPI: ACPI0007:00 is registered as cooling_device1
[    1.446860] ACPI: LNXTHERM:01 is registered as thermal_zone0
[    1.447004] ACPI: Thermal Zone [THRM] (40 C)
[    2.114518] ACPI: PCI Interrupt Link [LNKB] enabled at IRQ 3
[    2.114524] PCI: setting IRQ 3 as level-triggered
[    2.114529] ACPI: PCI Interrupt 0000:00:09.0[A] -> Link [LNKB] -> GSI 3 (level, low) -> IRQ 3
[    2.166381] ohci1394: fw-host0: OHCI-1394 1.0 (PCI): IRQ=[3]  MMIO=[e4000000-e40007ff]  Max Packet=[2048]  IR/IT contexts=[8/8]
[    2.228637] usbcore: registered new interface driver usbfs
[    2.228675] usbcore: registered new interface driver hub
[    2.228713] usbcore: registered new device driver usb
[    2.240351] USB Universal Host Controller Interface driver v3.0
[    2.291825] SCSI subsystem initialized
[    2.326802] No dock devices found.
[    2.348945] libata version 3.00 loaded.
[    2.353247] via-rhine.c:v1.10-LK1.4.3 2007-03-06 Written by Donald Becker
[    2.353253] via-rhine: Broken BIOS detected, avoid_D3 enabled.
[    2.379751] ACPI: PCI Interrupt Link [LNKA] enabled at IRQ 10
[    2.379758] PCI: setting IRQ 10 as level-triggered
[    2.379763] ACPI: PCI Interrupt 0000:00:10.0[A] -> Link [LNKA] -> GSI 10 (level, low) -> IRQ 10
[    2.379779] uhci_hcd 0000:00:10.0: UHCI Host Controller
[    2.379951] uhci_hcd 0000:00:10.0: new USB bus registered, assigned bus number 1
[    2.379980] uhci_hcd 0000:00:10.0: irq 10, io base 0x0000d000
[    2.380132] usb usb1: configuration #1 chosen from 1 choice
[    2.380170] hub 1-0:1.0: USB hub found
[    2.380179] hub 1-0:1.0: 2 ports detected
[    2.454786] Floppy drive(s): fd0 is 1.44M
[    2.473760] FDC 0 is a post-1991 82077
[    2.484233] usb usb1: New USB device found, idVendor=1d6b, idProduct=0001
[    2.484239] usb usb1: New USB device strings: Mfr=3, Product=2, SerialNumber=1
[    2.484242] usb usb1: Product: UHCI Host Controller
[    2.484244] usb usb1: Manufacturer: Linux 2.6.26-1-686 uhci_hcd
[    2.484246] usb usb1: SerialNumber: 0000:00:10.0
[    2.484325] ACPI: PCI Interrupt 0000:00:10.1[B] -> Link [LNKB] -> GSI 3 (level, low) -> IRQ 3
[    2.484340] uhci_hcd 0000:00:10.1: UHCI Host Controller
[    2.484371] uhci_hcd 0000:00:10.1: new USB bus registered, assigned bus number 2
[    2.484396] uhci_hcd 0000:00:10.1: irq 3, io base 0x0000d400
[    2.484504] usb usb2: configuration #1 chosen from 1 choice
[    2.484538] hub 2-0:1.0: USB hub found
[    2.484551] hub 2-0:1.0: 2 ports detected
[    2.576726] Marking TSC unstable due to: TSC halts in idle.
[    2.588190] usb usb2: New USB device found, idVendor=1d6b, idProduct=0001
[    2.588194] usb usb2: New USB device strings: Mfr=3, Product=2, SerialNumber=1
[    2.588197] usb usb2: Product: UHCI Host Controller
[    2.588199] usb usb2: Manufacturer: Linux 2.6.26-1-686 uhci_hcd
[    2.588201] usb usb2: SerialNumber: 0000:00:10.1
[    2.588674] ACPI: PCI Interrupt Link [LNKC] enabled at IRQ 5
[    2.588678] PCI: setting IRQ 5 as level-triggered
[    2.588684] ACPI: PCI Interrupt 0000:00:10.2[C] -> Link [LNKC] -> GSI 5 (level, low) -> IRQ 5
[    2.588699] uhci_hcd 0000:00:10.2: UHCI Host Controller
[    2.588732] uhci_hcd 0000:00:10.2: new USB bus registered, assigned bus number 3
[    2.588758] uhci_hcd 0000:00:10.2: irq 5, io base 0x0000d800
[    2.588864] usb usb3: configuration #1 chosen from 1 choice
[    2.588901] hub 3-0:1.0: USB hub found
[    2.588913] hub 3-0:1.0: 2 ports detected
[    2.692130] usb usb3: New USB device found, idVendor=1d6b, idProduct=0001
[    2.692134] usb usb3: New USB device strings: Mfr=3, Product=2, SerialNumber=1
[    2.692137] usb usb3: Product: UHCI Host Controller
[    2.692139] usb usb3: Manufacturer: Linux 2.6.26-1-686 uhci_hcd
[    2.692142] usb usb3: SerialNumber: 0000:00:10.2
[    2.692593] ACPI: PCI Interrupt Link [LNKD] enabled at IRQ 11
[    2.692597] PCI: setting IRQ 11 as level-triggered
[    2.692602] ACPI: PCI Interrupt 0000:00:10.3[D] -> Link [LNKD] -> GSI 11 (level, low) -> IRQ 11
[    2.692621] ehci_hcd 0000:00:10.3: EHCI Host Controller
[    2.692653] ehci_hcd 0000:00:10.3: new USB bus registered, assigned bus number 4
[    2.692705] ehci_hcd 0000:00:10.3: irq 11, io mem 0xe4001000
[    2.724037] usb 1-1: new low speed USB device using uhci_hcd and address 2
[    2.736031] ehci_hcd 0000:00:10.3: USB 2.0 started, EHCI 1.00, driver 10 Dec 2004
[    2.736115] usb usb4: configuration #1 chosen from 1 choice
[    2.736147] hub 4-0:1.0: USB hub found
[    2.736161] hub 4-0:1.0: 6 ports detected
[    2.792060] hub 1-0:1.0: unable to enumerate USB device on port 1
[    2.840128] usb usb4: New USB device found, idVendor=1d6b, idProduct=0002
[    2.840132] usb usb4: New USB device strings: Mfr=3, Product=2, SerialNumber=1
[    2.840134] usb usb4: Product: EHCI Host Controller
[    2.840136] usb usb4: Manufacturer: Linux 2.6.26-1-686 ehci_hcd
[    2.840139] usb usb4: SerialNumber: 0000:00:10.3
[    2.841366] ACPI: PCI Interrupt 0000:02:08.0[A] -> Link [LNKD] -> GSI 11 (level, low) -> IRQ 11
[    6.113142] scsi0 : AdvanSys SCSI 3.4: PCI Ultra: IO 0xC000-0xC00F, IRQ 0xB
[    6.115711] ACPI: PCI Interrupt 0000:00:12.0[A] -> Link [LNKA] -> GSI 10 (level, low) -> IRQ 10
[    6.119995] eth0: VIA Rhine II at 0x1e800, 00:0d:87:b1:67:f3, IRQ 10.
[    6.124015] eth0: MII PHY found at address 1, status 0x7849 advertising 05e1 Link 0000.
[    6.130877] Uniform Multi-Platform E-IDE driver
[    6.130884] ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
[    6.131631] VP_IDE: IDE controller (0x1106:0x0571 rev 0x06) at  PCI slot 0000:00:11.1
[    6.131664] ACPI: PCI Interrupt 0000:00:11.1[A] -> Link [LNKA] -> GSI 10 (level, low) -> IRQ 10
[    6.131672] VIA_IDE 0000:00:11.1: VIA VLink IRQ fixup, from 255 to 10
[    6.131699] VP_IDE: not 100% native mode: will probe irqs later
[    6.131718] VP_IDE: VIA vt8235 (rev 00) IDE UDMA133 controller on pci0000:00:11.1
[    6.131731]     ide0: BM-DMA at 0xdc00-0xdc07
[    6.131741]     ide1: BM-DMA at 0xdc08-0xdc0f
[    6.131745] Probing IDE interface ide0...
[    6.384200] ieee1394: Host added: ID:BUS[0-00:1023]  GUID[00601d0000000502]
[    6.544126] hda: IC35L090AVV207-0, ATA DISK drive
[    6.824131] hdb: WDC AC313000R, ATA DISK drive
[    6.880094] hda: host max PIO5 wanted PIO255(auto-tune) selected PIO4
[    6.880280] hda: UDMA/100 mode selected
[    6.880459] hdb: host max PIO5 wanted PIO255(auto-tune) selected PIO4
[    6.887357] hdb: drive side 80-wire cable detection failed, limiting max speed to UDMA33
[    6.887360] hdb: UDMA/33 mode selected
[    6.894318] Probing IDE interface ide1...
[    7.112040] usb 4-2: new high speed USB device using ehci_hcd and address 3
[    7.246620] usb 4-2: configuration #1 chosen from 1 choice
[    7.247250] usb 4-2: New USB device found, idVendor=1058, idProduct=0701
[    7.247254] usb 4-2: New USB device strings: Mfr=89, Product=76, SerialNumber=63
[    7.247257] usb 4-2: Product: External HDD
[    7.247259] usb 4-2: Manufacturer: Western Digital
[    7.247262] usb 4-2: SerialNumber: DEF10C8C8EE7
[    7.276482] Initializing USB Mass Storage driver...
[    7.484042] usb 4-4: new high speed USB device using ehci_hcd and address 4
[    7.616864] usb 4-4: configuration #1 chosen from 1 choice
[    7.617241] usb 4-4: New USB device found, idVendor=0ace, idProduct=1215
[    7.617245] usb 4-4: New USB device strings: Mfr=16, Product=32, SerialNumber=0
[    7.617247] usb 4-4: Product: USB2.0 WLAN
[    7.617250] usb 4-4: Manufacturer: ZyDAS
[    7.617407] scsi1 : SCSI emulation for USB Mass Storage devices
[    7.617498] usbcore: registered new interface driver usb-storage
[    7.617502] USB Mass Storage support registered.
[    7.621200] usb-storage: device found at 3
[    7.621205] usb-storage: waiting for device to settle before scanning
[    7.756142] hdc: ATAPI 52X CDROM, ATAPI CD/DVD-ROM drive
[    7.856041] usb 1-1: new low speed USB device using uhci_hcd and address 3
[    8.032254] usb 1-1: configuration #1 chosen from 1 choice
[    8.036101] usb 1-1: New USB device found, idVendor=046d, idProduct=c012
[    8.036106] usb 1-1: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[    8.036109] usb 1-1: Product: USB-PS/2 Optical Mouse
[    8.036111] usb 1-1: Manufacturer: Logitech
[    8.067729] usbcore: registered new interface driver hiddev
[    8.080347] input: Logitech USB-PS/2 Optical Mouse as /class/input/input1
[    8.080582] input,hidraw0: USB HID v1.10 Mouse [Logitech USB-PS/2 Optical Mouse] on usb-0000:00:10.0-1
[    8.080608] usbcore: registered new interface driver usbhid
[    8.080612] usbhid: v2.6:USB HID core driver
[    8.540140] hdd: DVDRW IDE 16X, ATAPI CD/DVD-ROM drive
[    8.596099] hdc: host max PIO5 wanted PIO255(auto-tune) selected PIO4
[    8.596167] hdc: UDMA/33 mode selected
[    8.596232] hdd: host max PIO5 wanted PIO255(auto-tune) selected PIO4
[    8.596328] hdd: drive side 80-wire cable detection failed, limiting max speed to UDMA33
[    8.596331] hdd: UDMA/33 mode selected
[    8.596499] ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
[    8.634030] ide1 at 0x170-0x177,0x376 on irq 15
[    8.684273] hda: max request size: 512KiB
[    8.688051] hda: 180941040 sectors (92641 MB) w/1821KiB Cache, CHS=16383/255/63
[    8.691746] hda: cache flushes supported
[    8.691803]  hda: hda1 hda2 hda3 hda4 < hda5 >
[    8.729908] hdb: max request size: 128KiB
[    8.729908] hdb: 25429824 sectors (13020 MB) w/512KiB Cache, CHS=25228/16/63
[    8.729908] hdb: cache flushes not supported
[    8.729908]  hdb: hdb1
[    8.735994] hdc: ATAPI 48X CD-ROM drive, 128kB Cache
[    8.736049] Uniform CD-ROM driver Revision: 3.20
[    8.739363] hdd: ATAPI 48X DVD-ROM DVD-R CD-R/RW drive, 2048kB Cache
[    9.345845] PM: Starting manual resume from disk
[    9.391031] EXT3-fs: INFO: recovery required on readonly filesystem.
[    9.391036] EXT3-fs: write access will be enabled during recovery.
 
Old 10-16-2008, 07:56 PM   #2
themrrobert
Member
 
Registered: Feb 2007
Distribution: Debian Sid
Posts: 47

Original Poster
Rep: Reputation: 16
Post Dmesg part 2 (just to be safe)

Code:
[   12.620279] usb-storage: device scan complete
[   12.622250] scsi 1:0:0:0: Direct-Access     WDC WD12 00UE-00KVT0      0000 PQ: 0 ANSI: 0
[   12.640526] Driver 'sd' needs updating - please use bus_type methods
[   12.641478] sd 1:0:0:0: [sda] 234441648 512-byte hardware sectors (120034 MB)
[   12.642352] sd 1:0:0:0: [sda] Write Protect is off
[   12.642359] sd 1:0:0:0: [sda] Mode Sense: 27 00 00 00
[   12.642362] sd 1:0:0:0: [sda] Assuming drive cache: write through
[   12.643473] sd 1:0:0:0: [sda] 234441648 512-byte hardware sectors (120034 MB)
[   12.644356] sd 1:0:0:0: [sda] Write Protect is off
[   12.644362] sd 1:0:0:0: [sda] Mode Sense: 27 00 00 00
[   12.644365] sd 1:0:0:0: [sda] Assuming drive cache: write through
[   12.644417]  sda: sda1
[   13.021700] sd 1:0:0:0: [sda] Attached SCSI disk
[   17.745487] kjournald starting.  Commit interval 5 seconds
[   17.745487] EXT3-fs: hda1: orphan cleanup on readonly fs
[   17.745487] ext3_orphan_cleanup: deleting unreferenced inode 420999
[   17.768926] ext3_orphan_cleanup: deleting unreferenced inode 717896
[   17.768926] EXT3-fs: hda1: 2 orphan inodes deleted
[   17.768926] EXT3-fs: recovery complete.
[   17.777343] EXT3-fs: mounted filesystem with ordered data mode.
[   19.971093] splashy[1123]: segfault at c ip b7f982ad sp bfbd1fd0 error 4 in libsplashy.so.1.0.0[b7f96000+5000]
[   20.252765] udevd version 125 started
[   21.764571] input: Power Button (FF) as /class/input/input2
[   21.795780] ACPI: Power Button (FF) [PWRF]
[   21.795884] input: Power Button (CM) as /class/input/input3
[   21.816779] ACPI: Power Button (CM) [PWRB]
[   21.816871] input: Sleep Button (CM) as /class/input/input4
[   21.848656] ACPI: Sleep Button (CM) [SLPB]
[   22.604657] Linux agpgart interface v0.103
[   22.606616] agpgart: Detected VIA KT266/KY266x/KT333 chipset
[   22.621767] agpgart: AGP aperture is 256M @ 0xc0000000
[   22.637481] pci_hotplug: PCI Hot Plug PCI Core version: 0.5
[   22.639521] shpchp: Standard Hot Plug PCI Controller Driver version: 0.4
[   22.849851] NET: Registered protocol family 23
[   22.961806] Linux video capture interface: v2.00
[   22.962971] Linux video codec intermediate layer: v0.2
[   23.100791] Zoran MJPEG board driver version 0.9.5
[   23.100823] ACPI: PCI Interrupt 0000:02:09.0[A] -> Link [LNKA] -> GSI 10 (level, low) -> IRQ 10
[   23.100831] MJPEG[0]: Zoran ZR36067 (rev 2) irq: 10, memory: 0xe3001000
[   23.100835] MJPEG[0]: subsystem vendor=0x13ca id=0x4231
[   23.324440] usb 4-4: reset high speed USB device using ehci_hcd and address 4
[   23.345087] input: PC Speaker as /class/input/input5
[   23.453931] ZORAN: 1 card(s) found
[   23.453938] Buz[0]: zr36057_init() - initializing card[0], zr=e0a4fa20
[   23.492520] phy0: Selected rate control algorithm 'pid'
[   23.646751] ACPI: PCI Interrupt 0000:00:11.5[C] -> Link [LNKC] -> GSI 5 (level, low) -> IRQ 5
[   23.646897] PCI: Setting latency timer of device 0000:00:11.5 to 64
[   23.766098] parport_pc 00:0a: reported by Plug and Play ACPI
[   23.766171] parport0: PC-style at 0x378 (0x778), irq 7 [PCSPP,TRISTATE]
[   23.853419] zd1211rw 4-4:1.0: phy0
[   23.853447] usbcore: registered new interface driver zd1211rw
[   24.056157] udev: renamed network interface wlan0 to eth1
[   25.028598] Adding 1951888k swap on /dev/hda2.  Priority:-1 extents:1 across:1951888k
[   25.332378] EXT3 FS on hda1, internal journal
[   25.977159] loop: module loaded
[   26.166475] nvidia: module license 'NVIDIA' taints kernel.
[   26.423219] ACPI: PCI Interrupt 0000:01:00.0[A] -> Link [LNKA] -> GSI 10 (level, low) -> IRQ 10
[   26.423861] NVRM: loading NVIDIA UNIX x86 Kernel Module  173.14.09  Wed Jun  4 23:43:17 PDT 2008
[   27.784961] kjournald starting.  Commit interval 5 seconds
[   27.785037] EXT3 FS on hda5, internal journal
[   27.785037] EXT3-fs: mounted filesystem with ordered data mode.
[   27.814250] kjournald starting.  Commit interval 5 seconds
[   27.814416] EXT3 FS on hda3, internal journal
[   27.814420] EXT3-fs: mounted filesystem with ordered data mode.
[   30.990616] NET: Registered protocol family 10
[   30.991225] lo: Disabled Privacy Extensions
[   31.227346] lp0: using parport0 (interrupt-driven).
[   31.248510] ppdev: user-space parallel port driver
[   32.612800] RPC: Registered udp transport module.
[   32.612807] RPC: Registered tcp transport module.
[   32.660363] Installing knfsd (copyright (C) 1996 okir@monad.swb.de).
[   32.744052] NFSD: Using /var/lib/nfs/v4recovery as the NFSv4 state recovery directory
[   32.752358] NFSD: starting 90-second grace period
[   35.513969] firmware: requesting zd1211/zd1211b_ub
[   35.571535] firmware: requesting zd1211/zd1211b_uphr
[   35.633932] zd1211rw 4-4:1.0: firmware version 4725
[   35.678907] zd1211rw 4-4:1.0: zd1211b chip 0ace:1215 v4810 high 00-11-a3 AL2230_RF pa0 ---NS
[   35.698305] ADDRCONF(NETDEV_UP): eth1: link is not ready
[   35.800419] eth0: link down
[   35.800822] ADDRCONF(NETDEV_UP): eth0: link is not ready
[   36.859936] NET: Registered protocol family 5
[   38.724673] agpgart: Found an AGP 2.0 compliant device at 0000:00:00.0.
[   38.724693] agpgart: Putting AGP V2 device at 0000:00:00.0 into 4x mode
[   38.724749] agpgart: Putting AGP V2 device at 0000:01:00.0 into 4x mode
[  176.371614] kjournald starting.  Commit interval 5 seconds
[  176.371959] EXT3-fs warning: maximal mount count reached, running e2fsck is recommended
[  176.373017] EXT3 FS on sda1, internal journal
[  176.373023] EXT3-fs: recovery complete.
[  176.373028] EXT3-fs: mounted filesystem with journal data mode.
[  179.467840] eth1: Initial auth_alg=0
[  179.467851] eth1: authenticate with AP 00:1c:f0:ff:ad:9e
[  179.469477] eth1: RX authentication from 00:1c:f0:ff:ad:9e (alg=0 transaction=2 status=0)
[  179.469483] eth1: authenticated
[  179.469487] eth1: associate with AP 00:1c:f0:ff:ad:9e
[  179.472595] eth1: RX AssocResp from 00:1c:f0:ff:ad:9e (capab=0x421 status=0 aid=2)
[  179.472602] eth1: associated
[  179.472615] eth1: switched to short barker preamble (BSSID=00:1c:f0:ff:ad:9e)
[  179.472660] eth1 (WE) : Wireless Event too big (320)
[  179.472756] ADDRCONF(NETDEV_CHANGE): eth1: link becomes ready
[  195.096034] eth1: no IPv6 routers present
 
Old 10-18-2008, 11:11 PM   #3
themrrobert
Member
 
Registered: Feb 2007
Distribution: Debian Sid
Posts: 47

Original Poster
Rep: Reputation: 16
any ideas?

has anyone else seen this problem, does any one have ANY ideas? this is driving me crazy, as i've searched all over the internet and it seems it should work, and i've tried all of the fixes i could find.

but please, give me any ideas you can
 
Old 10-22-2008, 07:53 PM   #4
themrrobert
Member
 
Registered: Feb 2007
Distribution: Debian Sid
Posts: 47

Original Poster
Rep: Reputation: 16
more info

ok i've got a little more information. I reinstalled the 2.6.24 kernel, and it works without a hitch. at this point i'm thinking maybe even though the config file in the source says FB_VESA=1, in the actual binary, it may have been left out, or its just not supported in the kernel anymore at all.

let me know if you have any thoughts
 
Old 10-22-2008, 09:11 PM   #5
Quakeboy02
Senior Member
 
Registered: Nov 2006
Distribution: Debian Squeeze 2.6.32.9 SMP AMD64
Posts: 3,192

Rep: Reputation: 120Reputation: 120
I don't know what to tell you. Your post caused me some worry, as I had a new motherboard coming with a built-in NVIDIA 7050. But, it worked with no problems. I guess sometime you're the windshield and...
 
Old 10-22-2008, 10:03 PM   #6
lwasserm
Member
 
Registered: Mar 2008
Location: Baltimore Md
Distribution: ubuntu
Posts: 184

Rep: Reputation: 41
Glad you got it working. Just FYI, I recall that when I added framebuffer support to my initram, I had to add the "fbcon" module as well as vesafb. Perhaps it must be added to you rkernel config as well.
 
  


Reply

Tags
framebuffer, nvidia, vesa, video


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
can't get the framebuffer working erikash Slackware 2 09-22-2005 09:09 AM
How to get the bloody framebuffer working? black hole sun Slackware 11 12-01-2004 06:29 AM
got framebuffer working, now i can't scroll marlor Slackware 4 07-26-2004 08:25 PM
Framebuffer and logo working with kernel 2.6.5? theo_ianus Linux - Newbie 1 05-05-2004 02:35 PM
got vesa framebuffer console working teacup LinuxQuestions.org Member Success Stories 0 05-26-2003 01:16 PM


All times are GMT -5. The time now is 07:06 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration