LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
LinkBack Search this Thread
Old 02-20-2010, 11:59 AM   #1
Mark_667
Member
 
Registered: Aug 2005
Location: Manchester, England
Distribution: Ubuntu 12.10
Posts: 257

Rep: Reputation: 25
Can't connect to WRT54g wirelessly


I've got a Linksys WRT54G v2.2 and a SmartAX MT882 modem I can connect to the Internet by connecting a Ethernet cable from the computer to the router but not wirelessly. I did the following to get it setup from my computer, can anyone see what I may have missed?

Quote:
http://forums.linksys.com/linksys/bo...ssage.id=96655

On the Router:
Connect it via ethernet and went to 192.168.1.1 to login.

Disabled the DHCP server and change the address of the WRT54G to 192.168.1.200
Change timezone.
Once applied, change IP address to 192.168.200.5 on computer, connect back in using the new IP address.

Switch the Advanced Dynamic routing on the WRT54G to the Router mode

In the advanced dynamic routing mode turned on the the Dynamic Routing (RIP) to LAN+Wireless because we will plug in the MT882 into the LAN port (Not the WAN/Internet port) of the WRT54G

In Wireless> Basic Wireless settings changed the Wireless Network Mode to G only. Set the wireless channel to 11.

Wireless>Wireless Security
WPA PSK, AES

On the modem:
Plug in your MT882 directly into the computer via Ethernet or USB and log into the administration panel via http://192.168.1.1.

In the MT882 administration in the advanced setting turn on/enable RIP (Dynamic routing) for eth-0 (its most likely already enabled for ppp-0, ie. your provider, but now it is enabled with the Ethernet too).

To input the account details for the ISP goto Basic>WAN Settings edit under the Action(s) menu.
http://www.talktalk.co.uk/help/broad...demrouter.html

Now connect the MT882 Ethernet cable directly into one of the WRT54G's LAN ports. Now once the computers are connected they will ask for an IP address and the WRT54G will forward them to the MT882's DHCP server for an address and thus you will get multiple computers through wireless connected to the MT882 and the Internet.
 
Old 02-20-2010, 01:17 PM   #2
MS3FGX
Guru
 
Registered: Jan 2004
Location: NJ, USA
Distribution: Slackware, Debian
Posts: 5,850

Rep: Reputation: 350Reputation: 350Reputation: 350Reputation: 350
Is the WLAN hardware up? Meaning, are you able to actually see and connect to the AP, just not able to get online?

If you can associate with the AP, are you then able to pull a DHCP lease? If you can get a lease then the next step would be to check the information given to you by the DHCP server, such as gateway and DNS servers.

But I am guessing you probably aren't getting a lease in the first place, so in that case I would try setting a static IP after authentication and then see if you can ping the modem and get anything on the WAN.
 
Old 02-20-2010, 02:03 PM   #3
Mark_667
Member
 
Registered: Aug 2005
Location: Manchester, England
Distribution: Ubuntu 12.10
Posts: 257

Original Poster
Rep: Reputation: 25
I can see the AP but never get connected to it. The DHCP lease looks interesting but I get a lease when connecting to the router directly with the DNS server set to the router so I'm not sure that that's the cause.
 
Old 02-20-2010, 02:10 PM   #4
MS3FGX
Guru
 
Registered: Jan 2004
Location: NJ, USA
Distribution: Slackware, Debian
Posts: 5,850

Rep: Reputation: 350Reputation: 350Reputation: 350Reputation: 350
If you can't authenticate with the AP, the problem must be either in the wireless security settings (WPA settings, MAC filter, etc), or the actual over the air settings like channel and operating mode.

Try connecting with all security settings off, channel 6, and mode back to mix. If that works, start turning the settings back on one by one until you find which one causes the problem.
 
1 members found this post helpful.
Old 02-20-2010, 05:45 PM   #5
Mark_667
Member
 
Registered: Aug 2005
Location: Manchester, England
Distribution: Ubuntu 12.10
Posts: 257

Original Poster
Rep: Reputation: 25
Thanks, turned out to be the channel setting, I changed it to 6 on the router (had set it to 11) and it worked from the remote computer first time.
 
  


Reply

Tags
wrt54g


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
NetworkManager won't connect wirelessly... jonrpick Linux - Newbie 3 05-19-2008 11:14 PM
Cannot connect wirelessly to router -Ay- Linux - Wireless Networking 4 09-30-2007 11:43 PM
Could not connect wirelessly wlaw Linux - Wireless Networking 2 05-24-2007 07:49 PM
Can not connect wirelessly bob3dan Ubuntu 1 03-14-2007 11:43 AM
How To Connect Wirelessly snowboard4fod Linux - Wireless Networking 1 10-18-2005 04:47 AM


All times are GMT -5. The time now is 05:11 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration