Share your knowledge at the LQ Wiki.
Go Back > Forums > Linux Forums > Linux - Hardware
User Name
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?


  Search this Thread
Old 08-20-2003, 12:24 PM   #1
Registered: Jul 2003
Location: British Columbia, Canada
Distribution: CollegeLinux 2.5
Posts: 148

Rep: Reputation: 15
Bringing up interface eth0.... failed

All of a sudden, when my RH9 box boots up, it can't seem to bring up eth0. It gets to that stage, pauses for a LONG time, then eventually says [FAILED].

I don't know what could have caused this. It was working fine. Then, at some point, I rebooted, and after that, nothing. I've tried rebooting again to see if it was a one time only dealie, but no such luck. It continues to fail to bring up eth0.

Does anybody have any ideas about how this might have happened, or better yet, how to fix it? I tried using RH's graphical network tools to activate the network but all of that fails as well.

Old 08-20-2003, 12:29 PM   #2
Registered: Feb 2001
Location: Atlanta, GA
Distribution: Slackware
Posts: 1,823

Rep: Reputation: 120Reputation: 120
How is the interface configured? DHCP or static IP? It sounds like the dhcpcd process is trying to find a dhcp server (long pause) to set the IP address and can't find one. This would be one reason why it does not start. I'd start by trying to run the eht0 init script from the command line and watch the output so you can see where it fails.
Old 08-20-2003, 01:39 PM   #3
Registered: Jul 2003
Location: British Columbia, Canada
Distribution: CollegeLinux 2.5
Posts: 148

Original Poster
Rep: Reputation: 15
It his DHCP... Well it seems to be working now, though I am not sure why.

I am still getting this error though:
Starting lm_sensors: i2c-core.o: i2c core module
i2c-proc.o version 2.6.1 (20010825)
Starting up sensors: can't access lproc file /proc/sys/dev/sensors/chips or /proc/bus/i2c unreadable

(Then there is something else too but it went by too fast for me to write it down).



Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
bringing up interface eth0: [FAILED] Birgi Linux - Networking 33 10-07-2004 06:00 AM
bringing up interface eth0 [FAILED] 0ver12ide Linux - Newbie 3 06-27-2004 03:31 PM
Bringing up interface eth0... failed Commish66 Linux - Networking 10 02-20-2004 12:27 AM
Bringing up interface eth0: failed Commish66 Mandriva 11 02-17-2004 08:15 PM
Bringing up interface eth0: determining ip information for eth0... failed ralphethomas Linux - Networking 0 01-24-2004 06:33 PM

All times are GMT -5. The time now is 01:38 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration