LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (http://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   br2684ctl Invalid argument (http://www.linuxquestions.org/questions/linux-hardware-18/br2684ctl-invalid-argument-545060/)

kenjiru 04-11-2007 05:02 AM

br2684ctl Invalid argument
 
I try to configure a Speedtouch 330 ADSL modem on USB. I'm working in an embedded environment using OpenWrt distribution, with 2.6.19.2 kernel.

Here are the dmesg messages when I plugin the modem:
Code:

hub 2-0:1.0: USB hub found
hub 2-0:1.0: 2 ports detected
usbcore: registered new interface driver speedtch
speedtch 1-2:1.0: found stage 1 firmware speedtch-1.bin
speedtch 1-2:1.0: found stage 2 firmware speedtch-2.bin
ATM dev 0: ADSL line is synchronising
ATM dev 0: ADSL line is up (2560 kb/s down | 512 kb/s up)

Everything looks fine, but I can't get the br2684ctl to work:
Code:

root@OpenWrt:~# br2684ctl -b -c 0 -a 0.35
RFC1483/2684 bridge: Interface "nas0" could not be created, reason: File exists

RFC1483/2684 bridge: Communicating over ATM 0.0.35, encapsulation: LLC

RFC1483/2684 bridge: Could not configure interface:Invalid argument

With dmesg spiting:
Code:

usbcore: registered new interface driver speedtch
ATM dev 0: ADSL line is synchronising
br2684: br2684_create
br2684: registered netdev nas0
br2684_create: register_netdev failed

Everything I though was necessary I've compiled as modules:
Code:

root@OpenWrt:~# lsmod
Module                  Size  Used by    Tainted: P 
br2684                  5616  0
speedtch              10000  0
usbatm                13952  1 speedtch
uhci_hcd              18480  0
ath_pci                68288  0
wlan_xauth              480  0
wlan_wep                4320  0
wlan_tkip              9984  0
wlan_ccmp              5856  0
wlan_acl                2208  0
ath_rate_sample        8000  1 ath_pci
ath_hal              222016  2 ath_pci,ath_rate_sample
wlan_scan_sta          8224  0
wlan_scan_ap            2720  0
wlan                  135488  9 ath_pci,wlan_xauth,wlan_wep,wlan_tkip,wlan_ccmp,wlan_acl,ath_rate_sample,wlan_scan_sta,wlan_scan_ap
ip_conntrack_tftp      1680  0
ip_nat_irc              960  0
ip_conntrack_irc        2832  1 ip_nat_irc
ip_nat_ftp              1696  0
ip_conntrack_ftp        4016  1 ip_nat_ftp
ppp_async              9504  0
ppp_generic            20480  1 ppp_async
slhc                    5472  1 ppp_generic
crc_ccitt              1024  1 ppp_async
atm                    43056  2 br2684,usbatm
usbcore              102016  4 speedtch,usbatm,uhci_hcd
switch_robo            4048  0
switch_core            5056  1 switch_robo
diag                    7696  0

Do you have any idea why I get the "Invalid argument" message from br2684ctl?

PS: the same line with the same modem works fine on my desktop PC.

kenjiru 04-14-2007 03:51 AM

I still haven't solved the problem :(


All times are GMT -5. The time now is 07:06 AM.