LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 11-13-2008, 03:06 AM   #1
blesbok
LQ Newbie
 
Registered: May 2008
Posts: 21

Rep: Reputation: 1
Question ? boot ubuntu with (monitor) flatronL1719S off and find resolution correct; /etc/X11/


how do i configure /etc/X11/xorg.conf to have my computer start up without the monitor on?

i have tried adding these lines to the .conf file but that simply results in the message that the computer's running the monitor in low res mode and the failsafe defaults are applied:

HorizSync 30-83
VertRefresh 56-75
(these seem correct for the flatron L1719S)

any advice? i'd really like to save energy and my monitor by only switching on once i've booted. this is done by a certain commercial operating system and i'd like to see my box do it with ubuntu linux.

please post your /etc/X11/xorg.conf if you have this one nailed.
 
Old 11-13-2008, 06:07 AM   #2
bathory
Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 10,899

Rep: Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322
You can try to disable the edid function of the driver, by adding
Code:
Option "UseEDID" "FALSE"
in the "Device" section of xorg.conf.
 
Old 11-14-2008, 03:40 AM   #3
blesbok
LQ Newbie
 
Registered: May 2008
Posts: 21

Original Poster
Rep: Reputation: 1
Post some success

thank you bathory, i followed your advice and it could boot up without low res mode being invoked.

Here's my .conf file:


Code:
Section "Device"
        Identifier      "nVidia Corporation NV6 [Vanta/Vanta LT]"
        Option          "UseEDID" "FALSE"
        Driver          "nv"
        BusID           "PCI:1:0:0"
EndSection

Section "Monitor"
        Identifier      "L1719S"
        Option          "DPMS"
EndSection

Section "Screen"
        Identifier      "Default Screen"
        Device          "nVidia Corporation NV6 [Vanta/Vanta LT]"
        Monitor         "L1719S"
        HorizSync       30-83
        VertRefresh     56-75
        DefaultDepth    24
        SubSection "Display"
                Modes           "1280x1024" "1024x768" "800x600" "720x400" "640x480"
        EndSubSection
EndSection

Section "ServerLayout"
        Identifier      "Default Layout"
        Screen          "Default Screen"
        InputDevice     "Generic Keyboard"
        InputDevice     "Configured Mouse"
with the monitor off, however, the resolution's still out

after looking at /var/log/Xorg.0.log

where HorizSync was listed as hsync and VertRefresh as vrefresh, i changed these accordingly; read in log:

Code:
(II) VESA(0): Total Memory: 256 64KB banks (16384kB)
(II) VESA(0): Failsafe Monitor: Using hsync range of 30.00-83.00 kHz
(II) VESA(0): Failsafe Monitor: Using vrefresh range of 56.00-75.00 Hz
(II) VESA(0): Not using built-in mode "1600x1200" (width too large for virtual size)
(II) VESA(0): Not using built-in mode "1280x1024" (width too large for virtual size)
(II) VESA(0): Not using built-in mode "1024x768" (width too large for virtual size)
(II) VESA(0): Not using built-in mode "640x400" (no mode of this name)
(II) VESA(0): Not using built-in mode "320x400" (no mode of this name)
(II) VESA(0): Not using built-in mode "320x240" (no mode of this name)
(II) VESA(0): Not using built-in mode "320x200" (no mode of this name)
(--) VESA(0): Virtual size is 800x600 (pitch 800)
(**) VESA(0): *Built-in mode "800x600"
(**) VESA(0):  Built-in mode "640x480"
(**) VESA(0): Display dimensions: (340, 270) mm
(**) VESA(0): DPI set to (59, 56)
(II) VESA(0): Attempting to use 72Hz refresh for mode "800x600" (114)
(II) VESA(0): Attempting to use 73Hz refresh for mode "640x480" (111)
(**) VESA(0): Using "Shadow Framebuffer"
(II) Loading sub module "shadow"
(II) LoadModule: "shadow"
(II) Loading /usr/lib/xorg/modules//libshadow.so
(II) Module shadow: vendor="X.Org Foundation"
        compiled for 1.3.0, module version = 1.1.0
        ABI class: X.Org ANSI C Emulation, version 0.3
(II) Loading sub module "fb"
(II) LoadModule: "fb"
(II) Loading /usr/lib/xorg/modules//libfb.so
(II) Module fb: vendor="X.Org Foundation"
        compiled for 1.3.0, module version = 1.0.0
        ABI class: X.Org ANSI C Emulation, version 0.3
(II) do I need RAC?  No, I don't.
for 1280x1024 resolution, there's this "width too large for virtual size" msg. any idea how to deal with it?
 
Old 11-14-2008, 05:16 AM   #4
bathory
Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 10,899

Rep: Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322
I see you're using the generic "nv" driver and not the "nvidia" driver, probably because of your card model. Maybe you can try a legacy nvidia driver for this, because I don't know if nv supports the UseEDID or it uses the deprecated IgnoreEDID option. You can try to set IgnoreEDID to "true" and see if it works.
According to nvidia manual you can try also to use "UseEDIDFreqs", "UseEDIDDpi" and "ModeValidation" options instead of UseEDID.
Another thing you can try is to use this in Screen section:
Code:
Section "Screen"
       Identifier      "Default Screen"
        Device          "nVidia Corporation NV6 [Vanta/Vanta LT]"
        Monitor         "L1719S"
        DefaultDepth    24
        Option         "metamodes" "1280x1024_75 +0+0; 1280x1024 +0+0; 1024x768 +0+0; 800x600 +0+0"
EndSection

Last edited by bathory; 11-14-2008 at 05:19 AM.
 
Old 11-16-2008, 04:11 AM   #5
blesbok
LQ Newbie
 
Registered: May 2008
Posts: 21

Original Poster
Rep: Reputation: 1
Thumbs up thanks, i'll try

thanks bathory for your time and knowhow; i'll try what you've said and let you know
 
Old 11-17-2008, 02:08 AM   #6
blesbok
LQ Newbie
 
Registered: May 2008
Posts: 21

Original Poster
Rep: Reputation: 1
replacing driver "nv" with "nvidia" got things straight into low res mode

your suggestion:
use "UseEDIDFreqs", "UseEDIDDpi" and "ModeValidation" options

did not result in low res mode separately, nor when i tried them together, but with the monitor off, got a lower resolution, same as with unmodified /etc/X11/xorg.conf tried changing the default depth but <15 results in low res mode. with 15, it looked right for the fraction of a second i saw my login screen, but there was a complaint about the greeter screen and boot could not continue. >/= 16 just gives lower resolution.

there are still some things to try and combinations of settings; restarting the box each time complicates things (best way?). will advise if successful
 
Old 11-18-2008, 03:17 AM   #7
blesbok
LQ Newbie
 
Registered: May 2008
Posts: 21

Original Poster
Rep: Reputation: 1
hi

hi bathory
 
Old 11-18-2008, 03:22 AM   #8
blesbok
LQ Newbie
 
Registered: May 2008
Posts: 21

Original Poster
Rep: Reputation: 1
Talking gtf?

will try (further) to use the bash gtf command and paste its output to /etc/ .conf under Monitor which is described in a thread like this one
here

sometime, i'll get it right!
 
  


Reply

Tags
command, default, line, low, resolution


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Find screen resolution in X11 VlnChemE Linux - General 6 09-19-2006 06:38 PM
correct resolution for wide aspect monitor crowmobe Linux - Hardware 2 03-12-2006 09:03 PM
Ubuntu not displaying correct resolution garyozzy Ubuntu 1 12-10-2005 11:58 PM
X11 Monitor Resolution. DdTComp Slackware 5 10-17-2004 11:31 PM
XF86Config - Settings For Correct Resolution On Second Monitor Svha Linux - Software 3 10-03-2003 10:57 AM


All times are GMT -5. The time now is 04:47 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration