LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (http://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   ? boot ubuntu with (monitor) flatronL1719S off and find resolution correct; /etc/X11/ (http://www.linuxquestions.org/questions/linux-hardware-18/boot-ubuntu-with-monitor-flatronl1719s-off-and-find-resolution-correct%3B-etc-x11-683075/)

blesbok 11-13-2008 04:06 AM

? boot ubuntu with (monitor) flatronL1719S off and find resolution correct; /etc/X11/
 
how do i configure /etc/X11/xorg.conf to have my computer start up without the monitor on?

i have tried adding these lines to the .conf file but that simply results in the message that the computer's running the monitor in low res mode and the failsafe defaults are applied:

HorizSync 30-83
VertRefresh 56-75
(these seem correct for the flatron L1719S)

any advice? i'd really like to save energy and my monitor by only switching on once i've booted. this is done by a certain commercial operating system and i'd like to see my box do it with ubuntu linux.

please post your /etc/X11/xorg.conf if you have this one nailed.

bathory 11-13-2008 07:07 AM

You can try to disable the edid function of the driver, by adding
Code:

Option "UseEDID" "FALSE"
in the "Device" section of xorg.conf.

blesbok 11-14-2008 04:40 AM

some success
 
thank you bathory, i followed your advice and it could boot up without low res mode being invoked.

Here's my .conf file:


Code:

Section "Device"
        Identifier      "nVidia Corporation NV6 [Vanta/Vanta LT]"
        Option          "UseEDID" "FALSE"
        Driver          "nv"
        BusID          "PCI:1:0:0"
EndSection

Section "Monitor"
        Identifier      "L1719S"
        Option          "DPMS"
EndSection

Section "Screen"
        Identifier      "Default Screen"
        Device          "nVidia Corporation NV6 [Vanta/Vanta LT]"
        Monitor        "L1719S"
        HorizSync      30-83
        VertRefresh    56-75
        DefaultDepth    24
        SubSection "Display"
                Modes          "1280x1024" "1024x768" "800x600" "720x400" "640x480"
        EndSubSection
EndSection

Section "ServerLayout"
        Identifier      "Default Layout"
        Screen          "Default Screen"
        InputDevice    "Generic Keyboard"
        InputDevice    "Configured Mouse"

with the monitor off, however, the resolution's still out

after looking at /var/log/Xorg.0.log

where HorizSync was listed as hsync and VertRefresh as vrefresh, i changed these accordingly; read in log:

Code:

(II) VESA(0): Total Memory: 256 64KB banks (16384kB)
(II) VESA(0): Failsafe Monitor: Using hsync range of 30.00-83.00 kHz
(II) VESA(0): Failsafe Monitor: Using vrefresh range of 56.00-75.00 Hz
(II) VESA(0): Not using built-in mode "1600x1200" (width too large for virtual size)
(II) VESA(0): Not using built-in mode "1280x1024" (width too large for virtual size)
(II) VESA(0): Not using built-in mode "1024x768" (width too large for virtual size)
(II) VESA(0): Not using built-in mode "640x400" (no mode of this name)
(II) VESA(0): Not using built-in mode "320x400" (no mode of this name)
(II) VESA(0): Not using built-in mode "320x240" (no mode of this name)
(II) VESA(0): Not using built-in mode "320x200" (no mode of this name)
(--) VESA(0): Virtual size is 800x600 (pitch 800)
(**) VESA(0): *Built-in mode "800x600"
(**) VESA(0):  Built-in mode "640x480"
(**) VESA(0): Display dimensions: (340, 270) mm
(**) VESA(0): DPI set to (59, 56)
(II) VESA(0): Attempting to use 72Hz refresh for mode "800x600" (114)
(II) VESA(0): Attempting to use 73Hz refresh for mode "640x480" (111)
(**) VESA(0): Using "Shadow Framebuffer"
(II) Loading sub module "shadow"
(II) LoadModule: "shadow"
(II) Loading /usr/lib/xorg/modules//libshadow.so
(II) Module shadow: vendor="X.Org Foundation"
        compiled for 1.3.0, module version = 1.1.0
        ABI class: X.Org ANSI C Emulation, version 0.3
(II) Loading sub module "fb"
(II) LoadModule: "fb"
(II) Loading /usr/lib/xorg/modules//libfb.so
(II) Module fb: vendor="X.Org Foundation"
        compiled for 1.3.0, module version = 1.0.0
        ABI class: X.Org ANSI C Emulation, version 0.3
(II) do I need RAC?  No, I don't.

for 1280x1024 resolution, there's this "width too large for virtual size" msg. any idea how to deal with it?

bathory 11-14-2008 06:16 AM

I see you're using the generic "nv" driver and not the "nvidia" driver, probably because of your card model. Maybe you can try a legacy nvidia driver for this, because I don't know if nv supports the UseEDID or it uses the deprecated IgnoreEDID option. You can try to set IgnoreEDID to "true" and see if it works.
According to nvidia manual you can try also to use "UseEDIDFreqs", "UseEDIDDpi" and "ModeValidation" options instead of UseEDID.
Another thing you can try is to use this in Screen section:
Code:

Section "Screen"
      Identifier      "Default Screen"
        Device          "nVidia Corporation NV6 [Vanta/Vanta LT]"
        Monitor        "L1719S"
        DefaultDepth    24
        Option        "metamodes" "1280x1024_75 +0+0; 1280x1024 +0+0; 1024x768 +0+0; 800x600 +0+0"
EndSection


blesbok 11-16-2008 05:11 AM

thanks, i'll try
 
thanks bathory for your time and knowhow; i'll try what you've said and let you know

blesbok 11-17-2008 03:08 AM

replacing driver "nv" with "nvidia" got things straight into low res mode

your suggestion:
use "UseEDIDFreqs", "UseEDIDDpi" and "ModeValidation" options

did not result in low res mode separately, nor when i tried them together, but with the monitor off, got a lower resolution, same as with unmodified /etc/X11/xorg.conf tried changing the default depth but <15 results in low res mode. with 15, it looked right for the fraction of a second i saw my login screen, but there was a complaint about the greeter screen and boot could not continue. >/= 16 just gives lower resolution.

there are still some things to try and combinations of settings; restarting the box each time complicates things (best way?). will advise if successful

blesbok 11-18-2008 04:17 AM

hi
 
hi bathory

blesbok 11-18-2008 04:22 AM

gtf?
 
will try (further) to use the bash gtf command and paste its output to /etc/ .conf under Monitor which is described in a thread like this one
here

sometime, i'll get it right!:scratch:


All times are GMT -5. The time now is 07:01 PM.