LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices



Reply
 
Search this Thread
Old 08-27-2010, 10:57 AM   #1
Vilenski
LQ Newbie
 
Registered: Nov 2008
Posts: 2

Rep: Reputation: 0
Boot init waiting for HDA to appear


Hi guys,

Please help!

My motherboard failed and we had to clone the IDE drive to a SATA to try and recover on a new system, now linux init waits for /dev/hda[x] to appear.

1) is it possible to start the OS on the new cloned drive,
if so how do I point it to see the new SATA drive?

Distro: OpenSuse 10.2

Thanks! Any help / advice appreciated.
 
Old 08-27-2010, 12:28 PM   #2
business_kid
Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 6,635

Rep: Reputation: 586Reputation: 586Reputation: 586Reputation: 586Reputation: 586Reputation: 586
If you have a sata drive, it's sda. hda will never appear

when grub comes up, hit e twice. Change the root=option to root=/dev/sdax. Press return to finish editing, abd b to boot.

Only / will mount, and you'll throw all sorts of errors but you might get started. Edit /etc/fstab, removing hdxx and putting in sdax for the first drive. You can also use /dev/disk/by-something which lets you specify definitely
 
Old 08-27-2010, 12:31 PM   #3
amani
Senior Member
 
Registered: Jul 2006
Location: Kolkata, India
Distribution: 64-bit GNU/Linux, Kubuntu64, Fedora QA, Slackware,
Posts: 2,758

Rep: Reputation: Disabled
Use the cd/dvd to rescue system ... reinstall grub bootloader.

But do this if your old and new main-boards are of the same type. Otherwise it makes sense to reinstall keeping /home intact for example

suse-10.2 is too old get the latest Mandriva/*buntu
 
  


Reply

Tags
boot, fstab, hda, ide, opensuse, sata, sda


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Init script in /etc/init.d does not start at boot tdnnash25 Linux - Server 4 12-18-2009 05:40 PM
Waiting for /sys/block/hda/dev to come up davcefai Debian 3 11-29-2007 05:06 PM
My browser, all day today: 'waiting for linuxquestions.org...' ..waiting.. waiting .. GrapefruiTgirl LQ Suggestions & Feedback 18 05-25-2007 06:35 AM
waiting for device to appear boot problem Cogvos Suse/Novell 2 10-17-2005 08:37 PM
kernel panic:no init found after changing from hda to hdc janjack Linux - General 10 11-12-2003 08:19 PM


All times are GMT -5. The time now is 10:39 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration