LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices



Reply
 
Search this Thread
Old 05-02-2005, 07:48 PM   #1
Viper168
Member
 
Registered: Oct 2003
Distribution: Gentoo
Posts: 54

Rep: Reputation: 15
Best Data 56K Serial Modem installation


I bought a Best Data 56K eternal modem (serial) today to try and solve this whole connection problem after a winmodem decided to throw a fit.

I have to be missing something, because things just aren't working.

I hooked up the modem and all, and fired up kppp. Kppp can query the modem just fine and everything seems great, but when I try to connect it freezes at "initializing modem" and eventually appears to segfault.

I noticed the modem commands section was void of entries, so poking around I tried putting in some values that were in the modem commands section of the winmodem in for the serial modem. After trying to connect it dialed and started making its noises, but disconnected partway through.


This is on a fresh 2005.0 Gentoo installation (without internet access, so no sync-ing or updating has been done).


If anyone could guide me towards getting it working I'd really appreciate it.

Edit: Also should mention, the cd labels the modem as a "56SX-92"

Last edited by Viper168; 05-02-2005 at 07:55 PM.
 
Old 05-02-2005, 08:39 PM   #2
kencaz
Senior Member
 
Registered: Mar 2005
Location: Las Vegas, NV
Distribution: Mandriva Slackware FreeBSD
Posts: 1,468

Rep: Reputation: 48
Well, if you got it to dial then you've pretty much gotten over the hard part. Sounds like a handshake issue. Using the winmodems init string might work but here is a general string for your modem:

ATM0&D0&K0&W0

There are probably many others depending on your ISP. Have you tried some other POP's (numbers), in your area. Also try adding some comma's ",,,," after the number kppp is dialing. This drops the v.90 protocol which could be an issue. If it connects (most likely a lower cps rate), then try to find a string to enable the k56Flex protocol. It's not used much anymore but who knows what your ISP is using.

I would contact your ISP as well and see if they may have a specific Init string for your modem.

KC
 
Old 05-02-2005, 09:47 PM   #3
Viper168
Member
 
Registered: Oct 2003
Distribution: Gentoo
Posts: 54

Original Poster
Rep: Reputation: 15
I've gone back and messed about but I've been unable to even duplicate my dialing results I got before.

With the ATM0&D0&K0&W0 for the init, and OK in the init response it just hangs at "modem ready" (not frozen), but without the OK it freezes at init.


What fields do I need to have filled for it to connect successfully? Do I need anything specific installed? Do I need to enable or set permissions on anything generally to get these things to work?



Any other ideas?
 
Old 05-03-2005, 07:47 PM   #4
Viper168
Member
 
Registered: Oct 2003
Distribution: Gentoo
Posts: 54

Original Poster
Rep: Reputation: 15
Ok, I've made more progress than ever, I just need a little help on filling out the rest of these. I managed to get it to dial and show up asking for a login on the log window. For the record I used ATZ1 for my init string, and ATDT for the dial string.


I need commands for the fields:


No dial tone detection :

Busy response :

No dial tone response :

Hangup String : (Might be ATH??)

Answer string :

Ring response :

Answer response :

Escape string : (Maybe +++ ??)

Escape response :



If anyone has any idea on these, I would really appreciate it.
 
Old 05-03-2005, 08:08 PM   #5
kencaz
Senior Member
 
Registered: Mar 2005
Location: Las Vegas, NV
Distribution: Mandriva Slackware FreeBSD
Posts: 1,468

Rep: Reputation: 48
Great to see you got it to dial up again. Here are some of the AT commands you wanted. They should have been put there for you, however...

Quote:
I need commands for the fields:

No dial tone detection :ATX3

Busy response :BUSY

No dial tone response :NO DIALTONE

Hangup String : +++ATH

Answer string : ATA

Ring response :RING

Answer response :CONNECT

Escape string : +++

Escape response : OK

Have you Setup the account login information: Authentication PAP/CHAP, IP on Dynamic, Gatway at Default. Have you entered the DNS server settings for your IP's authentication server?

KC
 
Old 05-03-2005, 09:01 PM   #6
Viper168
Member
 
Registered: Oct 2003
Distribution: Gentoo
Posts: 54

Original Poster
Rep: Reputation: 15
Thanks for the commands and whatnot. I still ended up at the same place though, at least the list is complete.

What it does is connect most of the way now, and in the log window it goes until it displays "Login:". From there it just sits and does nothing, eventually appears to reset, the dialing window changes back to Initializing and the log displays ATZ1 after login (Login: ATZ1, like if it were using that for a username).

To check things out, I followed the procedure in the modem terminal kppp provides:

ATZ1

ATDT insert_number_here

then eventually it gives me:


Login :

So I enter the username, then it promted for the password, guess what I entered for that.


Got logged in, it seemed to assign me an IP.

Though, mozilla couldn't seem to access anything, so I closed down shop with +++ATH.



As for the last few things you mentioned, everything is set except for DNS, which is on auto as it was on the other modem that works.



Any ideas on where to go from here?
 
Old 05-03-2005, 10:01 PM   #7
kencaz
Senior Member
 
Registered: Mar 2005
Location: Las Vegas, NV
Distribution: Mandriva Slackware FreeBSD
Posts: 1,468

Rep: Reputation: 48
Are you using the MiniTerminal that is in the configuration? This is not the prefered method of connecting to an ISP. When you first start KPPP you should have a screen that says

Connect To: <your account>
Login ID: <your ID>
Password: <your PW>

Under "Configure" button should have the account you setup. Under "edit" should have the IP DNS etc... Most ISP's use Dynamic IP but you will need a DNS server to connect. They don't use server assigned or DHCP.

What ISP are you using. I may be able to find the logon info for you?

KC
 
Old 05-03-2005, 10:18 PM   #8
Viper168
Member
 
Registered: Oct 2003
Distribution: Gentoo
Posts: 54

Original Poster
Rep: Reputation: 15
Yes, I was using the terminal in the configure options menu, but only to check if it would log in to see where the hold up was happening from.

Do I really need to set a DNS server even though I've connected before in windows and linux without touching anything to do with DNS?



Edit:

Also, perhaps I can find the problem at its root, what might someone think could be the reason all of this information and configuration wasn't automatically entered as it seems it was supposed to be? Maybe if what went wrong there was fixed it might solve everything easier.

Last edited by Viper168; 05-03-2005 at 10:30 PM.
 
Old 05-03-2005, 11:48 PM   #9
kencaz
Senior Member
 
Registered: Mar 2005
Location: Las Vegas, NV
Distribution: Mandriva Slackware FreeBSD
Posts: 1,468

Rep: Reputation: 48
Yes, normaly the AT commands and response are automatically put there by Kppp when the modem is queried, however, I don't think you have to clear everything and start over.

As for the DNS, I don't know how you were connecting in windows. Using your ISP's software you would not need to setup the DNS and other information. That is why thet create their own software so people wont have to do that. If you were connecting using DUN (Dial-Up-Networking) then you would have to enter that information.

Kppp is kind of like using DUN in windows. Without a DNS server you may be able to connect but your browser would not know how to convert the WWW addresses we use to IP numbers computers use.

What ISP are you using? There Home page support can tell you what Authentication they use and what the DNS servers are... as well as the mail (POP3) and news (NNTP) servers it uses.

KC
 
Old 05-04-2005, 04:31 PM   #10
Viper168
Member
 
Registered: Oct 2003
Distribution: Gentoo
Posts: 54

Original Poster
Rep: Reputation: 15
I've found their DNS server information, but I don't think that would be it, as it doesn't seem to log in as it should when it tries to connect.

In windows I use DUN, and it has worked in kppp before on a different modem (all without messing with DNS settings).


Might there be some problem with permissions that is causing kppp to be unable to get an automatic configuration? Just throwing whatever I can out there, any ideas are welcome.

Last edited by Viper168; 05-04-2005 at 04:33 PM.
 
Old 05-07-2005, 04:32 PM   #11
DW49
LQ Newbie
 
Registered: May 2005
Location: USA-Florida
Posts: 1

Rep: Reputation: 0
Viper168,
I have the exact same modem as you..and so far..it's worked well with the linspire distro. . Is your modem connected to the COM1 serial port ? If so, at least in linspire..you have to select /dev/ttyS0 in the modem device field for your modem to work properly. On the installation cd that your modem came with, in the manual on the cd, there are specific instructions how to set up the modem using linux. I hope this helps.
David
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Zoom 56k external serial modem problems Xon Linux - Hardware 4 09-09-2006 08:31 PM
Best Data 56k usb modem installation Geocritter Slackware 3 07-19-2005 08:29 AM
Best Data 56K External Serial Modem undetected on Fedora Core edeb Linux - Newbie 4 04-24-2005 12:48 PM
56k External Serial Modem Problems with Linux No Dialtone cylob Linux - Hardware 3 04-22-2004 10:43 PM
Looking for a driver for Viking 56k data,fax,voice modem William Linux - Newbie 0 08-13-2001 07:55 AM


All times are GMT -5. The time now is 08:24 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration