LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 02-27-2005, 12:20 PM   #1
whited
Member
 
Registered: Feb 2005
Distribution: Slackware 11
Posts: 109

Rep: Reputation: 15
Bad Resolution with a good Graphics Card


I have a Geforce 4 Ti 4600 agp 128mb video card. 1.5 Ghz P4 and a good monitor that can surport up to 1600x1200. I have downloaded and installed the nvidia driver for linux, and have changed my xorg.conf to look like this....


Section "Device"
Identifier "nvidia0"
Driver "nvidia"
#VideoRam 4096
# Insert Clocks lines here if appropriate
EndSection

# **********************************************************************
# Screen sections
# **********************************************************************

# Any number of screen sections may be present. Each describes
# the configuration of a single screen. A single specific screen section
# may be specified from the X server command line with the "-screen"
# option.
Section "Screen"
Identifier "Screen 1"
Device "nvidia0"
Monitor "My Monitor"

# If your card can handle it, a higher default color depth (like 24 or 32)
# is highly recommended.

# DefaultDepth 8
# DefaultDepth 16
DefaultDepth 24
# DefaultDepth 32

# "1024x768" is also a conservative usable default resolution. If you
# have a better monitor, feel free to try resolutions such as
# "1152x864", "1280x1024", "1600x1200", and "1800x1400" (or whatever your
# card/monitor can produce)

Subsection "Display"
Depth 8
Modes "1600x1200" "1280x1024" "1024x768"
EndSubsection
Subsection "Display"
Depth 16
Modes "1600x1200" "1280x1024" "1024x768"
EndSubsection
Subsection "Display"
Depth 24
Modes "1600x1200" "1280x1024" "1024x768"
EndSubsection
Subsection "Display"
Depth 32
Modes "1600x1200" "1280x1024" "1024x768"
EndSubsection

EndSection


But whenever i go into my configure desktop in kde It only says 1024x768 and smaller. Can anyone piont me in any direction to fix this. The only reason why it bothers me so much is because there are two black space on the left and right side of my screen about a 1/2 inch and it is annoying. Thanks for you help.
 
Old 02-27-2005, 01:12 PM   #2
J.W.
LQ Veteran
 
Registered: Mar 2003
Location: Milwaukee, WI
Distribution: Mint
Posts: 6,642

Rep: Reputation: 69
One thing I'd recommend would be to modify your xorg.conf file to reflect that you've got 128Mg of video RAM. Uncomment the VideoRAM line and add the correct value. Exit X, then startx again. If that doesn't work, try changing the default color depth to 16. Hopefully that will have a positive effect; if not, post back. Good luck with it -- J.W.


Section "Device"
Identifier "nvidia0"
Driver "nvidia"
VideoRam 131072
 
Old 02-27-2005, 05:30 PM   #3
whited
Member
 
Registered: Feb 2005
Distribution: Slackware 11
Posts: 109

Original Poster
Rep: Reputation: 15
I changed the default to 16 and I also tried a few numbers in the ram size none of them worked. The only time I could get it to boot without having that line commented out was when i didn't use parathesis on the number like you did. I am still getting the same resolution sizes and I am not sure what the exact number is and where you can get it. I tried my bios, and windows. Here is a picture of the closest thing I could find under windows to ram size.
http://home.earthlink.net/~brianbu01/ramsize.gif

Thanks for you help. Do you know where i can find the exact number or and other ideas?
 
Old 02-27-2005, 07:05 PM   #4
J.W.
LQ Veteran
 
Registered: Mar 2003
Location: Milwaukee, WI
Distribution: Mint
Posts: 6,642

Rep: Reputation: 69
Things look like they're generally in order, so it's a little puzzling why you aren't getting the higher resolution. Let's do this: post the full specs of your monitor, plus the full xorg.conf file Also, which version of Slack are you using? (Slack v10 uses xorg.conf, earlier versions use XF86Config) -- J.W.
 
Old 02-27-2005, 08:06 PM   #5
whited
Member
 
Registered: Feb 2005
Distribution: Slackware 11
Posts: 109

Original Poster
Rep: Reputation: 15
http://home.earthlink.net/~brianbu01/xorg.conf
http://home.earthlink.net/~brianbu01/Image1.jpg
http://home.earthlink.net/~brianbu01/Image2.jpg


Those are the images from over in windows. The second one show only the usable hz rates. I am guessing that the solution is to change the monitor values in xorg.conf. I have no idea what to change them to so I am still depending on your advice. BTW I am using slack 10.1 just installed yesterday.

Last edited by whited; 02-27-2005 at 08:09 PM.
 
Old 02-27-2005, 09:54 PM   #6
J.W.
LQ Veteran
 
Registered: Mar 2003
Location: Milwaukee, WI
Distribution: Mint
Posts: 6,642

Rep: Reputation: 69
If you are using a Dell P780 monitor, then according to Dell's tech specs your vertical and horizontal refresh rates do not reflect their ranges. Your xorg.cong shows that they are set to:

Horiz = 31.5 - 50
Vert = 40 - 90

but Dell's info shows that the ranges are:

Horiz = 30 - 85
Vert = 48 - 120

You might consider editing your xorg.conf file to reflect those values. DISCLAIMER: Using video settings that are incompatible with a monitor's capabilities may damage it. As the LQ Rules state, do NOT make any changes unless *you* understand and accept their effect and possible impact.

Note that according to the documentation, this monitor's "optimal resolution" is 1024x768@85Hz, so trying to use 1600x1200 is therefore *not* optimal according to the manufacturer. Personally, based on that comment from the manufacturer, I would leave things alone. If you want to do otherwise, it's 100% up to you, so proceed with caution. -- J.W.
 
Old 02-27-2005, 09:54 PM   #7
jmajor
Member
 
Registered: Nov 2004
Location: Australia
Distribution: Fedora, Ubuntu
Posts: 55
Blog Entries: 2

Rep: Reputation: 17
Try searching for 'DDC' in /var/log/Xorg.0.log to see if X has asked your monitor what it can do. Your vrefresh and hrefresh values seem quite low for a 1600x1200 monitor. Your Xorg.0.log is probably chock full of messages like:

Not using default mode "NNNNxNNNN" (hsync out of range)

My reasonably old monitor that will do about 1200x1024 reports this via DDC:

Ranges: V min: 50 V max: 120 Hz, H min: 30 H max: 72 kHz, PixClock max 110 MHz

Try finding the correct values for your monitor or even commenting those lines in the config and hoping X will work it out.
 
Old 02-27-2005, 11:12 PM   #8
whited
Member
 
Registered: Feb 2005
Distribution: Slackware 11
Posts: 109

Original Poster
Rep: Reputation: 15
Wow thanks it looks good now no more bars on the side. I am glad you helped me I didn't know what to do. Thanks a ton
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
good diagnotics tools for processor & graphics card sought vees Linux - Hardware 2 11-10-2005 09:55 PM
What is a good graphics card for Suse? TroyR Suse/Novell 3 02-10-2005 02:07 PM
Works too good - How do I turn off 1 of 2 graphics card skibum58 Linux - Newbie 3 07-20-2004 06:21 AM
good entry level graphics card with stable drivers dukeinlondon Linux - Hardware 2 01-27-2004 05:31 AM
a good tv tuner card and graphics card match mpo Linux - Hardware 2 03-01-2003 01:45 PM


All times are GMT -5. The time now is 02:24 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration