LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 11-01-2008, 12:08 PM   #1
tadeas
Member
 
Registered: Jul 2008
Location: Prague
Distribution: Opensuse
Posts: 40

Rep: Reputation: 5
Azalia SBx00 problem


No sound with Azalia SBx00, what else ?
The Amarok, Kaffeine etc. seems to be playing the music without any problem, Kmix is unmuted, but there comes no sound. One weird thing in kmix, there isn't that green point for muting or unmuting the second bar (the one with that little blue sound graph).

lspci:
Code:
Krason:~# lspci
00:00.0 Host bridge: Advanced Micro Devices [AMD] RS780 Host Bridge
00:01.0 PCI bridge: Advanced Micro Devices [AMD] RS780 PCI to PCI bridge (int gfx)
00:04.0 PCI bridge: Advanced Micro Devices [AMD] RS780 PCI to PCI bridge (PCIE port 0)
00:05.0 PCI bridge: Advanced Micro Devices [AMD] RS780 PCI to PCI bridge (PCIE port 1)
00:06.0 PCI bridge: Advanced Micro Devices [AMD] RS780 PCI to PCI bridge (PCIE port 2)
00:11.0 SATA controller: ATI Technologies Inc SB700/SB800 SATA Controller [IDE mode]
00:12.0 USB Controller: ATI Technologies Inc SB700/SB800 USB OHCI0 Controller
00:12.1 USB Controller: ATI Technologies Inc SB700 USB OHCI1 Controller
00:12.2 USB Controller: ATI Technologies Inc SB700/SB800 USB EHCI Controller
00:13.0 USB Controller: ATI Technologies Inc SB700/SB800 USB OHCI0 Controller
00:13.1 USB Controller: ATI Technologies Inc SB700 USB OHCI1 Controller
00:13.2 USB Controller: ATI Technologies Inc SB700/SB800 USB EHCI Controller
00:14.0 SMBus: ATI Technologies Inc SBx00 SMBus Controller (rev 3a)
00:14.1 IDE interface: ATI Technologies Inc SB700/SB800 IDE Controller
00:14.2 Audio device: ATI Technologies Inc SBx00 Azalia (Intel HDA)
00:14.3 ISA bridge: ATI Technologies Inc SB700/SB800 LPC host controller
00:14.4 PCI bridge: ATI Technologies Inc SBx00 PCI to PCI Bridge
00:14.5 USB Controller: ATI Technologies Inc SB700/SB800 USB OHCI2 Controller
00:18.0 Host bridge: Advanced Micro Devices [AMD] Family 11h HyperTransport Configuration (rev 40)
00:18.1 Host bridge: Advanced Micro Devices [AMD] Family 11h Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] Family 11h DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] Family 11h Miscellaneous Control
00:18.4 Host bridge: Advanced Micro Devices [AMD] Family 11h Link Control
01:05.0 VGA compatible controller: ATI Technologies Inc RS780M/RS780MN [Radeon HD 3200 Graphics]
02:00.0 Ethernet controller: Atheros Communications Inc. AR242x 802.11abg Wireless PCI Express Adapter (rev 01)
03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 02)
The system is Debian Sid with 2.6.26 kernel.
Modprobing snd-hda-intel finishes, but this appears in dmesg:
Code:
[ 1799.049364] hda_codec: Unknown model for ALC662, trying auto-probe from BIOS...
[ 1817.578289] hda-intel: Invalid position buffer, using LPIB read method instead.
Alsaconf finds the card and says it was successfully set.
But there is no sound and that kmix issue continues...

Any ideas?
Thanks in advance..
 
Old 11-04-2008, 08:57 AM   #2
tadeas
Member
 
Registered: Jul 2008
Location: Prague
Distribution: Opensuse
Posts: 40

Original Poster
Rep: Reputation: 5
No ideas?
I tried to upgrade to 2.6.27 kernel, but it made no difference.
Here's what kmix looks like:
http://lord-thaddeusz.ic.cz/kmix.png
It seems like it didn't detect the headphones output (maybe it's a nonsense...). There's no sound from headphones as well as from the in-built repro-boxes (it's a laptop)...

Shall I provide with any more info?
 
Old 11-20-2008, 10:45 PM   #3
malikperera
LQ Newbie
 
Registered: Aug 2004
Location: Australia
Distribution: Kubuntu
Posts: 10

Rep: Reputation: 0
Check alsamixer working or not
 
  


Reply

Tags
azalia, sound


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
ALSA and Azalia soundcard mary Linux - Hardware 10 03-31-2011 08:17 PM
volume problem with sbx00 azalia dreamscaper Ubuntu 1 08-06-2008 12:20 PM
unresolved nightmare sound problem - inspiron 1721, card=SB600, SBx00 Azalia dreamscaper Linux - Hardware 2 08-04-2008 11:53 PM
ATI Technologies Inc SBx00 Azalia kafnir Linux - Hardware 1 01-11-2008 08:25 PM


All times are GMT -5. The time now is 02:57 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration