LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (http://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   Automount - HAL - udev - Xfce - Konqueror - Slackware - help requested (http://www.linuxquestions.org/questions/linux-hardware-18/automount-hal-udev-xfce-konqueror-slackware-help-requested-587320/)

Linux.tar.gz 09-25-2007 03:43 PM

Automount - HAL - udev - Xfce - Konqueror - Slackware - help requested
 
Hi !

I use Xfce as desktop and konqueror as file manager.
I don't use the Xfce automounter on desktop because i prefer access usb keys and cdrom via konqueror. I already associated all files types and i don't want to "manage" two file managers.
I also dislike icons on desktop. In fact i hate the desktop folder and i think it's a very bad concept. The desktop should be /home/me.

So as no window automagically appears, i made two konqueror favorites. One is "media:/" other is "system:/media". I don't know which is best and i doubt they're EXACTLY the same.
I always have to do a refresh when i'm in one of these folders because it's empty when i go in it.
And it's annoying.
Worst, when i umount keys, sometimes it shows that the device is unmounted but the writing is not finished !!!

So i have three questions:

1 - Is there a way to have the same appearing screen as KDE when inserting a device ?

2 - Is there a way to make Xfce file manager use the konqueror file association config ? (in case no satisfying solution comes)

3 - Do someone have some suggestion ?

Linux.tar.gz 03-04-2008 02:16 PM

4 - I bump :)

dive 03-04-2008 02:21 PM

5. This isn't an answer to your q's but I just wondered if you knew about removing icons from desktop.

Code:

cat .config/xfce4/desktop/xfdesktoprc

[file-icons]
show-filesystem=false
show-home=false
show-trash=false
show-removable=false

If you already knew this I apologise. Like you I don't like desktop icons except for removable (therefore I have the last option true).

Linux.tar.gz 04-25-2008 10:03 AM

Not really what i look for, but thanks anyway.

I finally solved this problem. It works with Slackware 12.1 rc 1. Under the 12.0, the kdeinit /usr/share/services/kded/medianotifier.desktop won't launch the corresponding service.

To umount the device, i recommend to use this shortcut in konqueror : media:/

Here's the script we need to launch at xfce startup :

#!/bin/sh
kdeinit
killall kded
kded
dcop kded medianotifier
dcop kded mediamanager

Linux.tar.gz 06-02-2008 04:51 PM

Here it is.

I edited the previous script in order to make it clean.

It works on Slackware 12.1 under Xfce.

It should work on previous version.

Have fun.

Linux.tar.gz 06-19-2008 09:49 AM

Grrr it don't works ... again.
I don't know how i managed to get it ok !!!

bash-3.1$ dcop kded medianotifier
object 'medianotifier' in application 'kded' not accessible

Any KDE expert here ?


All times are GMT -5. The time now is 07:58 AM.