LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 09-18-2008, 05:04 AM   #1
Mogli
Member
 
Registered: Jun 2008
Posts: 41

Rep: Reputation: 15
auto mount problem and fstab


Hi I recently installed Fedora-9 in my SONY VAIO laptop. /etc/fstab content is as follows:

UUID=b15cf2a1-1ad8-447a-871b-8ceddcc6f59d / ext3 defaults 1 1
UUID=3df71cdc-42f0-4d87-bd0d-6c08737bd0c7 /home ext3 defaults 1 2
tmpfs /dev/shm tmpfs defaults 0 0
devpts /dev/pts devpts gid=5,mode=620 0 0
sysfs /sys sysfs defaults 0 0
proc /proc proc defaults 0 0
UUID=acb66d68-9e75-446b-b6ce-ab4b024500e7 swap swap defaults 0 0

Here my problem is, I have two 'ntfs' drives. fedora detecting both drives as 'New Volume' but it is not able to mount at start up. Every time need to mount manually as a root user. In the same system I have windows XP, it detecting these two drives with D and E names.

Please suggest me how to rectify this problem.

Thanks in advance
Mogli
 
Old 09-18-2008, 05:29 AM   #2
Nylex
LQ Addict
 
Registered: Jul 2003
Location: London, UK
Distribution: Slackware
Posts: 7,464

Rep: Reputation: Disabled
Have you already tried adding fstab entries for those partitions? If so, did it not work? In that case, please post the relevant entries. If you haven't already added entries, then do so..
 
Old 09-18-2008, 12:35 PM   #3
farslayer
Guru
 
Registered: Oct 2005
Location: Willoughby, Ohio
Distribution: linuxdebian
Posts: 7,232
Blog Entries: 5

Rep: Reputation: 189Reputation: 189
You should be using ntfs-3g to mount ntfs partitions read write.


ntfs-3g /dev/sda2 /mnt/winstorage -o umask=0,nls=utf8


If that all works you can add it to your /etc/fstab file so it will automatically mount

/dev/sda2 /mnt/winstorage ntfs-3g umask=0,nls=utf8 0 0


man ntfs-3g for more information
 
Old 09-19-2008, 05:13 AM   #4
Mogli
Member
 
Registered: Jun 2008
Posts: 41

Original Poster
Rep: Reputation: 15
This problem solved.

Thanks for helping.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
trying to auto mount xp share in fstab babag Linux - Networking 3 07-12-2008 05:48 AM
devices in /etc/fstab don't auto mount at startup : jabka Linux - General 3 08-23-2006 04:28 PM
fstab: auto mount floppy at boot blackzone Linux - Newbie 2 07-10-2006 02:17 AM
Win share will not auto mount, inclu in Fstab ZingSter Suse/Novell 4 04-06-2005 08:22 AM


All times are GMT -5. The time now is 09:25 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration