LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (http://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   Audio Problems (http://www.linuxquestions.org/questions/linux-hardware-18/audio-problems-388040/)

Eric55441 11-30-2005 04:47 PM

Audio Problems
 
My audio cards seems to not be working with linux. I am using ubuntu. I know the card is in good shape because it works when I boot windows. Here is the list of all my PCI cards and my audio card does show up.
Code:

0000:00:00.0 Host bridge: Intel Corp. 82875P Memory Controller Hub (rev 02)
0000:00:01.0 PCI bridge: Intel Corp. 82875P Processor to AGP Controller (rev 02)0000:00:03.0 PCI bridge: Intel Corp. 82875P Processor to PCI to CSA Bridge (rev 02)
0000:00:1d.0 USB Controller: Intel Corp. 82801EB/ER (ICH5/ICH5R) USB UHCI #1 (rev 02)
0000:00:1d.1 USB Controller: Intel Corp. 82801EB/ER (ICH5/ICH5R) USB UHCI #2 (rev 02)
0000:00:1d.2 USB Controller: Intel Corp. 82801EB/ER (ICH5/ICH5R) USB UHCI #3 (rev 02)
0000:00:1d.3 USB Controller: Intel Corp. 82801EB/ER (ICH5/ICH5R) USB UHCI #4 (rev 02)
0000:00:1d.7 USB Controller: Intel Corp. 82801EB/ER (ICH5/ICH5R) USB2 EHCI Controller (rev 02)
0000:00:1e.0 PCI bridge: Intel Corp. 82801 PCI Bridge (rev c2)
0000:00:1f.0 ISA bridge: Intel Corp. 82801EB/ER (ICH5/ICH5R) LPC Bridge (rev 02)0000:00:1f.1 IDE interface: Intel Corp. 82801EB/ER (ICH5/ICH5R) Ultra ATA 100 Storage Controller (rev 02)
0000:00:1f.2 IDE interface: Intel Corp. 82801EB (ICH5) Serial ATA 150 Storage Controller (rev 02)
0000:00:1f.3 SMBus: Intel Corp. 82801EB/ER (ICH5/ICH5R) SMBus Controller (rev 02)
0000:01:00.0 VGA compatible controller: nVidia Corporation: Unknown device 0326 (rev a1)
0000:02:01.0 Ethernet controller: Intel Corp. 82547EI Gigabit Ethernet Controller (LOM)
0000:03:00.0 FireWire (IEEE 1394): VIA Technologies, Inc. IEEE 1394 Host Controller (rev 46)
0000:03:02.0 Multimedia audio controller: VIA Technologies Inc. VT1720/24 [Envy24PT/HT] PCI Multi-Channel Audio Controller (rev 01)
0000:03:03.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
0000:03:0b.0 Multimedia controller: Philips Semiconductors SAA7133 Audio+video broadcast decoder (rev d0)

This is the audio card
Code:

0000:03:02.0 Multimedia audio controller: VIA Technologies Inc. VT1720/24 [Envy24PT/HT] PCI Multi-Channel Audio Controller (rev 01)
And also if you know how to get a TV capture card working with linux I would love to know. Here is my TV card
Code:

0000:03:0b.0 Multimedia controller: Philips Semiconductors SAA7133 Audio+video broadcast decoder (rev d0)
Thanks!

TimmyP 11-30-2005 09:09 PM

'ello eric,

i don't mean to be offensive, i'm just trying to get a feel for your situation. are you new to linux and / or ubuntu or the debian base system?

do you have ALSA installed or set up properly?

if your not sure if you have alsa, try running the program alsamixer in a terminal.

another note, since you are using ubuntu, i take it you are using gnome, have you enabled the sound themes/mixer/sound support in gnome?

reply here with what you come up with

Eric55441 11-30-2005 10:03 PM

I am kind of new to linux. I have used it gotten frusterated with it before and then started using it agian and I have slowly been getting used to it. I tryed the alsamixer in the terminal and got this.
Code:

eric@ubuntu:~$ alsamixer

alsamixer: function snd_ctl_open failed for default: No such device
eric@ubuntu:~$

I am not really sure how or where I am supposed to go to enable sound in gnome but I will keep looking.

TimmyP 11-30-2005 11:07 PM

i use debian, and from what i understand ubuntu is debian based, so here are some debian commands that i would use. they are for installing and uninstalling:

as root:
1. apt-get remove alsa-base alsa-utils
2. apt-get install alsa-base alsa-utils

this should run the alsaconfig program, if it does not, run this program as root:
alsaconf

it should guide you through setting up your sound system, and devices. you have the same sound chipset i have, so i know alsa is compatable with it. i have had really bad luck with gnome and sound in the past, i'll play around with it and see if i can come up with a solution for ya (i also need to get it working properly...i tend to aviod it and use kde)

Mitjau 12-01-2005 02:50 AM

Similar difficulties
 
Hi! I'm using kubuntu i386 on an AMD processor, and nVIDIA CK804 Realtek ACL655 audio on board chip, and have similar troubles. The thing is when I installed OS for the first time, the sound worked perfectly, but then I uninstalled a few packages and now sound is gone. I did reinstall alsa-base and alsa-utils, but the configuration never showed up. There also isn't any alsaconf command when I try it manually. Someone suggested hotplug, but I don't know how exactly to use that thing. I have no clue what exactly I uninstalled so I don't know what the original setup was.

I also ran kubuntu from a Live CD where sound just worked and looked for the packages installed. I searched packages by keywords: sound, audio, and drivers. Then, on my original installation, I made sure the very same packages were installed. Maybe I got a little further, as of now every now and then PC speaker "beeps", but still no usual sound. Still, when I run alsamixer I get:
Code:

function: snd_ctl_open failed: No such file or directory
.

My next bet would be to search for any files related to audio and sound configuration on an equivalent working system (either live or installed), then just copy all those files into the original installation and hope it works. I'm asking you for a favor here. I don't know which files to look for and how many there are related to this (audio, sound config, drivers, etc.).

Also if someone has a better solution, I would be happy to hear about.


Thanks kindly,
Mitja Ursic

dusik 12-01-2005 11:35 AM

Eric55441, Mitjau,

Try running alsaconf as root perhaps? Does that help? You need to have the right module(s) installed (or compiled into the kernel) for your sound card.

Mitjau 12-01-2005 12:35 PM

There is no alsaconf present neither in user, sudo or su mode. According to lsmod there is no snd like module installed either. /dev/dsp doesn't exist, neither does /etc/modprobe.conf.

I reinstalled Realtek ACL655 drivers which in the first place only helped me to hear sound along playing avi and bin movies. They don't make any difference now.

alsactl outputs this:
Code:

$ alsactl names
alsactl: for_each_card:51: No soundcards found...
alsactl: generate_names:522: probe 0 failed: No such device
alsactl: for_each_card:51: No soundcards found...
alsactl: generate_names:522: probe 1 failed: No such device
alsactl: for_each_card:51: No soundcards found...
alsactl: generate_names:522: probe 2 failed: No such device
alsactl: generate_names:522: probe 3 failed: No such device or address
alsactl: generate_names:535: Cannot open /etc/asound.names for writing


Eric55441 12-01-2005 03:57 PM

even after uninstalling alsa and then reinstalling it, it still doesnt work.

Mitjau 12-01-2005 04:04 PM

Are you asking me? I still have ubuntu on another partition and I think KDE is installed, so I guess I could do that. Why? Remember that kubuntu is my primary OS which I'm trying to fix.

Eric55441 12-01-2005 04:13 PM

Quote:

Originally posted by Mitjau
Are you asking me? I still have ubuntu on another partition and I think KDE is installed, so I guess I could do that. Why? Remember that kubuntu is my primary OS which I'm trying to fix.
no I am one of the people who cant seem to get sound working.

axobeauvi 12-02-2005 04:54 PM

I know VIA intigrated sound cards are funny in linux
I think they offer drivers on their site
take a look
good luck

Electro 12-02-2005 11:43 PM

Not to be blunt but everybody is wrong. What people do not understand that saa7134 also adds a sound device but I would get to that soon. The sound card is probably on card 1 (second card), so if you run alsamixer -c 1 it should bring up the mixer settings for your sound card. Though to make sure the sound card is the first audio device add a line in either /etc/modules.conf or /etc/modprobe.conf that states:
options snd-ice1724 index=0

The SAA7134 video capture module is a little tricky to get it working. First find the card list and go through to that matches your video capture card and note it down. The card list will be in the Documentation directory that is under kernel source code directory. Add a line in either /etc/modprobe.conf or /etc/modules.conf that states:
options saa7134 card=X
Place the card number where the X is located. Use either tvtime or mplayer to view only the composite or s-video connections for a test. After that include tuner=Y on the same line of saa7134. I am sorry to say but you will have to through one by one until a tuner number works for your card. Hopefully, you can watch TV stations.

The SAA7134 module creates an audio device that is used for recording only. The problem you are having is hotplug detected the video capture device first so it loaded it up and designated as sound card zero or first sound card. Really the programmer for this module did not give full support for recording sound from the video capture card, so it is ok to disable audio by adding oss=0 to the same options line as saa7134.

bayonetblaha 02-05-2006 12:27 AM

I'm a new ubuntu user as well trying to install Avermedia AverTV Cardbus with Zapping or TVTime or something like that. I'm having trouble following these instructions- found a plain text file in /etc called modules, but it's read-only and I don't even know how to add the neccesary line

oddiofile 12-10-2007 05:33 PM

Ubuntu Cripples Alsa
 
GRR, it is so annoying.

There are great tools for configuring your sound card, which ubuntu REMOVES from their version of alsa-utils, so the only way you can get it is by compiling it from source. This renders all of the useful "troubleshooting" pages on the alsa websites totally useless, since they assume you have a full installation of alsa, including alsaconf, and the snddevices script which recreates all those /dev/snd/ files if you happen to have lost them.


All times are GMT -5. The time now is 01:26 AM.