LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 12-05-2003, 08:18 PM   #1
abiagi
Member
 
Registered: Aug 2003
Location: Orange County, CA
Distribution: slackware 9.0
Posts: 104

Rep: Reputation: 15
audio not working.."device not present"??


When I boot into Linux and type startx I get a message indicating a problem initializing audio, and that the Device is not present. I don't even know where to START attacking this one. My Slack has been up and sprinting for 3 days and I'm stoked.
 
Old 12-05-2003, 08:37 PM   #2
ac1980
Member
 
Registered: Aug 2003
Location: Trento, Italy
Distribution: Debian testing
Posts: 394

Rep: Reputation: 30
1) as root, try
chmod 777 /dev/audio* /dev/mixer*
it might be a misleading error message.
If this doesn't work you need to supply more info: at minimum, what's your sound board
 
Old 12-05-2003, 10:33 PM   #3
abiagi
Member
 
Registered: Aug 2003
Location: Orange County, CA
Distribution: slackware 9.0
Posts: 104

Original Poster
Rep: Reputation: 15
I'll try it now, but my audio is as follows:

Realtek AC97 Audio ( I believe it's PCI based )

I'll report back once I reboot into Slack.

Thank you.
 
Old 12-05-2003, 10:41 PM   #4
abiagi
Member
 
Registered: Aug 2003
Location: Orange County, CA
Distribution: slackware 9.0
Posts: 104

Original Poster
Rep: Reputation: 15
OK Here is what the message box displays upon starting of KDE

"Sound Server Informational Message:
Error while initializing sound driver
device/dev/dsp can't be opened(No such device)
The sound server will continue using the null output device

And that previous tip didn't do anything I could see

Thanks again
 
Old 12-05-2003, 10:41 PM   #5
abiagi
Member
 
Registered: Aug 2003
Location: Orange County, CA
Distribution: slackware 9.0
Posts: 104

Original Poster
Rep: Reputation: 15
and it's not PCI based
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
echo "blabla" in a script present present in /etc/rc.d/rc5.d/S96dinesh murugesan Linux - Newbie 3 04-14-2009 10:53 PM
Audacity - "Error opening audio device" Locura Slackware 6 08-22-2008 05:24 PM
Real Player and XMMS "Cannot open audio device" - SuSE 9 pro hand of fate Linux - Software 16 07-01-2007 09:45 PM
xine "Audio output unavailable. Device is busy." shellshock Linux - Software 3 05-13-2006 12:19 PM
Bash's "present working directory" doesn't exit jonr Linux - General 2 11-07-2003 01:58 PM


All times are GMT -5. The time now is 08:20 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration