LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 09-19-2007, 11:22 AM   #1
a_j_67
LQ Newbie
 
Registered: Sep 2007
Posts: 3

Rep: Reputation: 0
audio intel 82801H (ICH8 Family)


Hello there
i got troubles with the audio on my HP Pavilion DV9000 and opensuse 10.2.
I dont ear any sound from my laptop, even if the alsaconf recognize my card... (as you can see below..)

inux-etgi:/home/corrado # lspci|grep -i audio
00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 03)
linux-etgi:/home/corrado # lsmod | grep snd
snd_seq_dummy 8068 0
snd_pcm_oss 53376 0
snd_mixer_oss 21248 1 snd_pcm_oss
snd_seq 60272 1 snd_seq_dummy
snd_seq_device 12812 2 snd_seq_dummy,snd_seq
snd_hda_intel 23060 0
snd_hda_codec 164352 1 snd_hda_intel
snd_pcm 86916 3 snd_pcm_oss,snd_hda_intel,snd_hda_codec
snd_timer 27908 2 snd_seq,snd_pcm
snd 61188 9 snd_seq_dummy,snd_pcm_oss,snd_mixer_oss,snd_seq,snd_seq_device,snd_hda_intel,snd_hda_codec,snd_pcm,s nd_timer
soundcore 13792 1 snd
snd_page_alloc 14472 2 snd_hda_intel,snd_pcm
linux-etgi:/home/corrado # lspci -v | fgrep audio
linux-etgi:/home/corrado # modprobe snd_hda_intel
linux-etgi:/home/corrado # alsaconf
┌─────────────────────────────────────────────────────────────┐
│ │
│ ALSA CONFIGURATOR │
│ version 1.0.14 │
│ │
│ This script is a configurator for │
│ Advanced Linux Sound Architecture (ALSA) driver. │
│ │
│ │
│ If ALSA is already running, you should close all sound │
│ apps now and stop the sound driver. │
│ alsaconf will try to do this, but it's not 100% sure. │
│ │
│ │
│ │
│ │
│ │
├─────────────────────────────────────────────────────────────┤
│ < OK > │
└─────────────────────────────────────────────────────────────┘


Building card database..


┌──────────────────────────────────────┐
│ Searching sound cards │
│ ┌────────────────────────────────┐ │
│ │ 97% │ │
│ └────────────────────────────────┘ │
└──────────────────────────────────────┘


┌──────────────────────────Soundcard Selection─────────────────────────────┐
│ │
│ Following card(s) are found on your system. │
│ Choose a soundcard to configure: │
│ ┌──────────────────────────────────────────────────────────────────────┐ │
│ │hda-intel Intel Corporation 82801H (ICH8 Family) HD Audio Controller │ │
│ │legacy Probe legacy ISA (non-PnP) chips │ │
│ │ │ │
│ │ │ │
│ │ │ │
│ │ │ │
│ │ │ │
│ │ │ │
│ └──────────────────────────────────────────────────────────────────────┘ │
├──────────────────────────────────────────────────────────────────────────┤
│ < OK > <Annulla> │
└──────────────────────────────────────────────────────────────────────────┘

┌────────────────────────────────────────────────┐
│ │
│ Configuring snd-hda-intel │
│ Do you want to modify /etc/modprobe.d/sound │
│ (and /etc/modprobe.conf if present)? │
├────────────────────────────────────────────────┤
│ < Sė > < No > │
└────────────────────────────────────────────────┘

┌──────────────────────────────────────────────────────────┐
│ │
│ │
│ OK, sound driver is configured. │
│ │
│ ALSA CONFIGURATOR │
│ │
│ will prepare the card for playing now. │
│ │
│ Now I'll run alsasound init script, then I'll use │
│ amixer to raise the default volumes. │
│ You can change the volume later via a mixer │
│ program such as alsamixer or gamix. │
│ │
├─────────────────────────────────────────────────────92%──┤
│ < OK > │
└──────────────────────────────────────────────────────────┘



Loading driver...
Starting sound driver: hda-intel done
Setting default volumes...

┌───────────────────────────────────────────────────────────────┐
│ │
│ The mixer is set up now for for playing. │
│ Shall I try to play a sound sample now? │
│ │
│ NOTE: │
│ If you have a big amplifier, lower your volumes or say no. │
│ Otherwise check that your speaker volume is open, │
│ and look if you can hear test sound. │
│ │
├───────────────────────────────────────────────────────────────┤
│ < Sė > < No > │
└───────────────────────────────────────────────────────────────┘


Playing WAVE '/usr/share/sounds/alsa/test.wav' : Signed 16 bit Little Endian, Rate 44100 Hz, Stereo


NO SOUND HERE IN THE TEST



===============================================================================

Now ALSA is ready to use.
For adjustment of volumes, use your favorite mixer.

Have a lot of fun!


linux-etgi:/home/corrado # uname -a
Linux linux-etgi 2.6.18.2-34-default #1 SMP Mon Nov 27 11:46:27 UTC 2006 i686 i686 i386 GNU/Linux
linux-etgi:/home/corrado #


Could someone help me?

Many thanks in advance

Aj
 
Old 09-19-2007, 01:45 PM   #2
kaz2100
Senior Member
 
Registered: Apr 2005
Location: Penguin land, with apple, no gates
Distribution: Debian testing woody(32) sarge etch lenny squeeze(+64) wheezy jessie
Posts: 1,430

Rep: Reputation: 83
Hya,

How does alsamixer look like?

Also alsamixergui ?

Happy Penguins!
 
Old 09-27-2007, 10:09 AM   #3
a_j_67
LQ Newbie
 
Registered: Sep 2007
Posts: 3

Original Poster
Rep: Reputation: 0
Alsa conf and alsamixer look like ok, bur if i emerge alsa driver.. Sabayon says me that no alsadrivers are installed... I'm trying to install them but without success.. hereby the answer...

emerge alsa-driver
Calculating dependencies... done!
>>> Verifying ebuild Manifests...

>>> Emerging (1 of 1) media-sound/alsa-driver-1.0.15_rc2 to /
* alsa-driver-1.0.15rc2.tar.bz2 RMD160 ;-) ... [ ok ]
* alsa-driver-1.0.15rc2.tar.bz2 SHA1 ;-) ... [ ok ]
* alsa-driver-1.0.15rc2.tar.bz2 SHA256 ;-) ... [ ok ]
* alsa-driver-1.0.15rc2.tar.bz2 size ;-) ... [ ok ]
* checking ebuild checksums ;-) ... [ ok ]
* checking auxfile checksums ;-) ... [ ok ]
* checking miscfile checksums ;-) ... [ ok ]
* checking alsa-driver-1.0.15rc2.tar.bz2 ;-) ... [ ok ]
* Determining the location of the kernel source code
* Found kernel source directory:
* /usr/src/linux
* Found kernel object directory:
* /lib/modules/2.6.22-sabayon/build
* Found sources for kernel version:
* 2.6.22-sabayon
* Checking for suitable kernel configuration options...
* ALSA is already compiled into the kernel. This is the recommended configuration, don't emerge alsa-driver.
* Please check to make sure these options are set correctly.
* Failure to do so may cause unexpected problems.
* Once you have satisfied these options, please try merging
* this package again.
*
* ERROR: media-sound/alsa-driver-1.0.15_rc2 failed.
* Call stack:
* ebuild.sh, line 1670: Called dyn_setup
* ebuild.sh, line 719: Called qa_call 'pkg_setup'
* ebuild.sh, line 44: Called pkg_setup
* alsa-driver-1.0.15_rc2.ebuild, line 104: Called linux-mod_pkg_setup
* linux-mod.eclass, line 464: Called linux-info_pkg_setup
* linux-info.eclass, line 572: Called check_extra_config
* linux-info.eclass, line 471: Called die
*
* Incorrect kernel configuration options
* If you need support, post the topmost build error, and the call stack if relevant.
* A complete build log is located at '/var/tmp/portage/media-sound/alsa-driver-1.0.15_rc2/temp/build.log'.
*

* Messages for package media-sound/alsa-driver-1.0.15_rc2:

* ALSA is already compiled into the kernel. This is the recommended configuration, don't emerge alsa-driver.
* Please check to make sure these options are set correctly.
* Failure to do so may cause unexpected problems.
* Once you have satisfied these options, please try merging
* this package again.
*
* ERROR: media-sound/alsa-driver-1.0.15_rc2 failed.
* Call stack:
* ebuild.sh, line 1670: Called dyn_setup
* ebuild.sh, line 719: Called qa_call 'pkg_setup'
* ebuild.sh, line 44: Called pkg_setup
* alsa-driver-1.0.15_rc2.ebuild, line 104: Called linux-mod_pkg_setup
* linux-mod.eclass, line 464: Called linux-info_pkg_setup
* linux-info.eclass, line 572: Called check_extra_config
* linux-info.eclass, line 471: Called die
*
* Incorrect kernel configuration options
* If you need support, post the topmost build error, and the call stack if relevant.
* A complete build log is located at '/var/tmp/portage/media-sound/alsa-driver-1.0.15_rc2/temp/build.log'.




What can i do?

Thanks
 
Old 09-27-2007, 12:16 PM   #4
DiBosco
Member
 
Registered: Nov 2001
Location: Manchester, UK
Distribution: Mandriva, Mandriva, Mandriva. (Three different releases depending on the computer)
Posts: 710

Rep: Reputation: 35
I have pretty much the same issue. I have even tried recompiling alsa. I downloaded 1.0.15rc3, configured, made, installed and run snddivces all seemingly just fine. However, when I reboot it's telling me it's still loading 1.0.14. alsamixer seems to think it's 15rc3, but the kernel messages indicate otherwise!

Anyone know how to force the kernel to load the newer version I've compiled? Many thanks.
 
Old 09-28-2007, 06:45 PM   #5
kaz2100
Senior Member
 
Registered: Apr 2005
Location: Penguin land, with apple, no gates
Distribution: Debian testing woody(32) sarge etch lenny squeeze(+64) wheezy jessie
Posts: 1,430

Rep: Reputation: 83
Hya,

DiBosco: read man page of modprobe. you can force to load modules. But it seems that something else is also not quite right. Did you correctly install your newly complied kernel??

It seems that something is not quite right with kernels 2.6.21/2. I have not figured out yet, although it may not be related to your issue.

http://www.linuxquestions.org/questi...d.php?t=585577

Happy Penguins!
 
Old 11-26-2007, 05:13 PM   #6
smOk3
Member
 
Registered: Feb 2007
Posts: 43

Rep: Reputation: 15
Exact Same Problem

I am having the exact same problem on my HP laptop with exact same sound card. I have a new install of opensuse and everything is working correctly. Not muted, current drivers, sound up. No errors. JUST NO SOUND. I was on an irc channel about 3 months ago and someone helped me fix this 'bug'. He directed me to a website with exact instructions on how to recompile the alsa drivers with some 'patch'. I lost the site and it was opensuse specific. I am having a hard time finding this site again and no luck on irc. If anyone can help me I would appreciate it. Thanks.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
ICH8 audio problems after hibernate/resume on Inspiron 1420N cdhgee Linux - Hardware 0 09-03-2007 08:17 PM
Intel ICH8 (965) install guide with all SATA drives Method9455 Slackware 3 03-12-2007 05:53 AM
Intel 82801FB/FBM/FR/FW/FRW (ICH6 Family) High Definition Audio EwanG Linux - Hardware 2 09-10-2005 08:33 AM
Linux audio driver for Intel 915 Family Chipset sambitnayak Linux - Hardware 2 05-09-2005 09:08 PM
Linux audio driver for Intel 915 Family Chipset sambitnayak Linux - Software 2 05-09-2005 09:07 PM


All times are GMT -5. The time now is 08:37 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration