LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (http://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   Audio CD Problems (http://www.linuxquestions.org/questions/linux-hardware-18/audio-cd-problems-94555/)

Sentaku senshi 09-19-2003 12:24 PM

Audio CD Problems
 
I can not figure out how to get audio CD's to work at all, and I've tried everything I could find on this board:

OS: Mandarke 9.0
Gui Perferibly KDE 3 but will use Gnome 2 if nessery

/ect/lilo.conf:
boot=/dev/hda
map=/boot/map
vga=normal
default=XP
keytable=/boot/us.klt
prompt
nowarn
timeout=100
message=/boot/message
menu-scheme=wb:bw:wb:bw
image=/boot/vmlinuz
label=failsafe
root=/dev/hda3
initrd=/boot/initrd.img
append="failsafe devfs=nomount hdc=ide-scsi"
read-only
other=/dev/hda2
label=XP
table=/dev/hda
other=/dev/fd0
label=floppy
unsafe
image=/boot/vmlinuz
label=linux
root=/dev/hda3
initrd=/boot/initrd-2.4.19-16mdk.img
vga=normal
read-only

/ect/fstab
/dev/hda3 / ext2 defaults 1 1
none /dev/pts devpts mode=0620 0 0
none /mnt/cdrom supermount dev=/dev/scd0,fs=auto,ro,--,iocharset=iso8859-1,codepage=850,users,umask=0 0 0
none /mnt/cdrom2 supermount dev=/dev/hdd,fs=auto,ro,--,iocharset=iso8859-1,codepage=850,users,umask=0 0 0
none /mnt/floppy supermount dev=/dev/fd0,fs=auto,--,iocharset=iso8859-1,sync,codepage=850,umask=0 0 0
/dev/hda1 /mnt/nt ntfs iocharset=iso8859-1,ro,umask=0 0 0
/dev/hda2 /mnt/nt2 ntfs iocharset=iso8859-1,ro,umask=0 0 0
/dev/hda5 /mnt/nt3 ntfs iocharset=iso8859-1,ro,umask=0 0 0
none /proc proc defaults 0 0

KsCD Error upon starting:
CDROM read or access error (or no audio disc in drive).

Please make sure you have access permissions to:
<were ever I have it set>

Gnomes player gives simuler errors.

Can anyone help?

RolledOat 09-19-2003 12:30 PM

You have 2 CD drives, which one does KsCD point to? If /dev/cdrom then is the CD in that drive? or if /dev/cdrom2, is the CD in that drive? I remeber a long time ago aliasing KsCD to any CDROM drive automatically, but don't remember, and only ever use my burner CD to listen to music.

RO

Sentaku senshi 09-19-2003 12:36 PM

I've pointed KsCD to:


/dev/hdd
/dev/scd0
/mnt/cdrom
/mnt/cdrom2

and yes there is a cd in the drive.

RolledOat 09-19-2003 12:46 PM

well, it isn't going to show up as /mnt unless it is mounted, and an audio CD can't be mounted. Both the /dev/* should be right, but you may as well try...

/dev/cdrom
and
/dev/cdrom2

Also, with the audio CD in, see what you /etc/mtab shows.

RO

P.S. I am NOT a fan of Mandrake's supermount. They haven't gotten the reliability up enough lately. Probably trying to automount, fails and then leaves in a bad state.

Sentaku senshi 09-19-2003 12:56 PM

ect/mtab:

/dev/hda3 / ext2 rw 0 0
none /proc proc rw 0 0
none /proc/bus/usb usbdevfs rw 0 0
none /dev/pts devpts rw,mode=0620 0 0
none /mnt/floppy supermount rw,sync,dev=/dev/fd0,fs=auto,--,iocharset=iso8859-1,codepage=850,umask=0 0 0
/dev/hda1 /mnt/nt ntfs ro,iocharset=iso8859-1,umask=0 0 0
/dev/hda2 /mnt/nt2 ntfs ro,iocharset=iso8859-1,umask=0 0 0
/dev/hda5 /mnt/nt3 ntfs ro,iocharset=iso8859-1,umask=0 0 0

RolledOat 09-19-2003 02:55 PM

Well, I can't see anything wrong. The last thing I would suggest trying is to disable supermount of your CD drives, but don't know how to do that (beyond what I have read, never had supermount, so won't guarantee anything about it :) ). I see a LOT of posts with flaky mounting/operation with supermount enabled.

http://www.yellowbugcomputers.com/te...lockdrive.html

supermount -i disabled

RO

Sentaku senshi 09-20-2003 08:55 PM

ok, I logged in a root and changed dev/scd0 so that everyone one had read/write and excute privilages. However now, the CD player in Gnome dosn't work. and the one in KDE crashes: I also can't figure out how to get a cd to work with XMMs, though I'll look around this board.

(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
0x40ff9739 in wait4 () from /lib/i686/libc.so.6
#0 0x40ff9739 in wait4 () from /lib/i686/libc.so.6
#1 0x41076340 in sys_sigabbrev () from /lib/i686/libc.so.6
#2 0x40e5ca73 in waitpid () from /lib/i686/libpthread.so.0
#3 0x4059df55 in KCrash::defaultCrashHandler(int) ()
from /usr/lib/libkdecore.so.4


All times are GMT -5. The time now is 03:15 AM.