LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices



Reply
 
Search this Thread
Old 01-18-2003, 06:45 AM   #1
cnc76
LQ Newbie
 
Registered: Jan 2003
Posts: 12

Rep: Reputation: 0
Audigy and SCRIPT...for Digital Output and AC3


Hello....

I have installed emu10k1 and emu-tools

I changed my modules.conf in this way:

alias sound emu10k1
alias sound-service-0-0 sound
alias sound-slot-0 sound
post-install sound-slot-0 /usr/local/etc/emu-script
post-install emu10k1 /usr/local/etc/audigy-script restore
pre-remove emu10k1 /usr/local/etc/audigy-script save


I put the script audigy-script, emu10k1.conf and emu-script
in /usr/local/etc

I'am a newbie and I have download the script from

http://basic-rip.co.uk/tenpin/linux_audigy_faq.html


Now....when I start linux....I have analogical mode..... but I changed script and I put "yes" to use_digital_mode and AC3passthrou

If I write:

emu-config -d

I active digital mode....and all OK.

But however I'm not able to listen ac3 file.

Which is the "command" to active ac3passthrou ???
Why it doesn't read script???

Can you help me?

bye by CNC
 
Old 01-18-2003, 10:23 AM   #2
unSpawn
Moderator
 
Registered: May 2001
Posts: 27,725
Blog Entries: 54

Rep: Reputation: 2971Reputation: 2971Reputation: 2971Reputation: 2971Reputation: 2971Reputation: 2971Reputation: 2971Reputation: 2971Reputation: 2971Reputation: 2971Reputation: 2971
The default conf sez:
# Set to yes if you want digital output
USE_DIGITAL_OUTPUT=no
AC3PASSTHROUGH=no
If you didn't change these you'll have to add "-d yes -3 yes" to your commandline.
 
Old 01-18-2003, 01:31 PM   #3
cnc76
LQ Newbie
 
Registered: Jan 2003
Posts: 12

Original Poster
Rep: Reputation: 0
I have changed in YES what you say.....but don't work.

I try to write:

/usr/local/etc/audigy-script

and i receive 4 errors of BAD COMMAND.


I think that this is the problem.

I have to change this script....but I'm not able.

Can you help me?

bye by CNC
 
Old 01-18-2003, 03:43 PM   #4
unSpawn
Moderator
 
Registered: May 2001
Posts: 27,725
Blog Entries: 54

Rep: Reputation: 2971Reputation: 2971Reputation: 2971Reputation: 2971Reputation: 2971Reputation: 2971Reputation: 2971Reputation: 2971Reputation: 2971Reputation: 2971Reputation: 2971
ok, execute your script like this:
"sh -x /usr/local/etc/audigy-script 2> /tmp/error.log", then post those contents here.
 
Old 01-19-2003, 04:09 PM   #5
cnc76
LQ Newbie
 
Registered: Jan 2003
Posts: 12

Original Poster
Rep: Reputation: 0
Hello..... I do what you say....
but I don't understand nothing.

[root@xp-1800 etc]# sh -x /usr/local/etc/audigy-script > /tmp/error.log
+ BASE_PATH=/usr/local
+ DSPPATH=/usr/local/share/emu10k1
++ which aumix
+ AUMIX=/usr/bin/aumix
+ DSPDEV=
+ MIXERDEV=
+ DSPMGR=/usr/local/bin/emu-dspmgr
+ CONFIG=/usr/local/bin/emu-config
+ SAVEARGS=
+ load
+ . /usr/local/etc/emu10k1.conf
++ USE_DIGITAL_OUTPUT=yes
++ ENABLE_TONE_CONTROL=no
++ AC3PASSTHROUGH=yes
++ ENABLE_LIVEDRIVE_IR=no
++ ENABLE_CD_Spdif=no
++ ENABLE_OPTICAL_SPDIF=no
++ ENABLE_LINE2_MIC2=no
++ ENABLE_RCA_SPDIF=no
++ ENABLE_RCA_AUX=no
+ getopts d:t:3:i: OPT
+ '[' yes = yes ']'
+ FRONT=Dig Front
+ CENTER=Dig Center
+ SUB=Dig LFE
+ REAR=Dig rear
+ CTR_SUB=Dig ctr/sub
+ /usr/local/bin/emu-dspmgr -x -z
+ /usr/local/bin/emu-dspmgr '-aPcmig Front' '-aPcm Rearig rear' '-aPcm ctr/subig ctr/sub' -aPcm:Headphones
Error: Bad route specified
Error: Bad route specified
Error: Bad route specified
Error: Bad route specified
+ /usr/local/bin/emu-dspmgr -lpcm '-lPcm Rear' '-lPcm Ctr/sub' -f/usr/local/share/emu10k1/vol_pcm.bin -cVol_L -mpcm_l -cVol_R -mpcm_r
Error:Bad Line name
+ '[' no = yes ']'
+ '[' no = yes ']'
+ '[' no = yes ']'
+ '[' no = yes ']'
+ '[' no = yes ']'
+ /usr/local/bin/emu-dspmgr -aAnalog:Recording -aAnalog:Headphones
Error: Bad route specified
Error: Bad route specified
+ '[' yes = yes ']'
+ /usr/local/bin/emu-dspmgr '-aAnalogig Front'
Error: Bad route specified
+ enable_volume 'Dig Front' vol
+ INPUT=Dig Front
+ VOLUME=vol
+ /usr/local/bin/emu-dspmgr '-pvol Vol' '-lDig Front' -f/usr/local/share/emu10k1/vol_2.bin -cVol_L -mvol_l -cVol_R -mvol_r
Error:Bad Line name
+ enable_volume 'Dig rear' ogain
+ INPUT=Dig rear
+ VOLUME=ogain
+ /usr/local/bin/emu-dspmgr '-pogain Vol' '-lDig rear' -f/usr/local/share/emu10k1/vol_2.bin -cVol_L -mogain_l -cVol_R -mogain_r
Error:Bad Line name
+ enable_volume 'Dig ctr/sub' igain
+ INPUT=Dig ctr/sub
+ VOLUME=igain
+ /usr/local/bin/emu-dspmgr '-pigain Vol' '-lDig ctr/sub' -f/usr/local/share/emu10k1/vol_2.bin -cVol_L -migain_l -cVol_R -migain_r
Error:Bad Line name
+ '[' no = yes ']'
+ '[' yes = yes ']'
+ /usr/local/bin/emu-config -d
+ '[' no = yes ']'
+ '[' yes = yes ']'
+ '[' yes = yes ']'
+ /usr/local/bin/emu-dspmgr '-ldig front' -F/usr/local/share/emu10k1/ac3pass-audigy.bin
Error:Bad Line name
+ /usr/local/bin/emu-dspmgr -y



Help me.

bye by CNC
 
Old 01-23-2003, 03:17 AM   #6
cnc76
LQ Newbie
 
Registered: Jan 2003
Posts: 12

Original Poster
Rep: Reputation: 0
UP
 
Old 01-23-2003, 05:46 AM   #7
unSpawn
Moderator
 
Registered: May 2001
Posts: 27,725
Blog Entries: 54

Rep: Reputation: 2971Reputation: 2971Reputation: 2971Reputation: 2971Reputation: 2971Reputation: 2971Reputation: 2971Reputation: 2971Reputation: 2971Reputation: 2971Reputation: 2971
Ok, when I'm reading the emu-tools-0.9.4 docs then for instance for option "-l" there is no line called "Dig rear", for instance output to "Digital Front out" is called with "Digital L" and input from /dev/dsp (PCM) is called "Pcm L". You should reread the docs and choose your options more carefully IMHO.
 
Old 01-24-2003, 04:05 AM   #8
cnc76
LQ Newbie
 
Registered: Jan 2003
Posts: 12

Original Poster
Rep: Reputation: 0
I want active ONLY Digital Output and AC3pass

I used these commands but the ac3pass doesn't work.

I wrote:
emu-dspmgr -x -z
emu-dspmgr -a"Analogigital"
emu-config -d
emu-dspmgr -l"Digital" -F"/usr/local/share/emu10k1/ac3pass-audigy.bin

I don't receive any message....
Digital output works but the ac3pass doesn't work.

Can you help me?

bye by CNC
 
Old 01-24-2003, 09:21 AM   #9
unSpawn
Moderator
 
Registered: May 2001
Posts: 27,725
Blog Entries: 54

Rep: Reputation: 2971Reputation: 2971Reputation: 2971Reputation: 2971Reputation: 2971Reputation: 2971Reputation: 2971Reputation: 2971Reputation: 2971Reputation: 2971Reputation: 2971
I think it's time you searched LQ for other Audigy posts or if it turns up zilch contact the maker of the Linux Audigy FAQ.

Last edited by unSpawn; 01-24-2003 at 09:25 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Audigy, SuSE 9.1, and digital output MachineShedFred Linux - Hardware 1 07-09-2004 10:56 PM
SP/DIF / AC3 output with MDK 9.1 & SBLive! WildChild978 Linux - Hardware 2 03-09-2004 06:11 PM
Sound Volume not adjustable/AC3 Output not working rabbit_high Linux - Hardware 0 02-28-2004 04:37 PM
Dolby Digital output on Audigy Mp3+ alexmoose Linux - Hardware 3 01-11-2004 04:26 AM
ALSA...how I can active Digital Out and Ac3 passthtrou cnc76 Linux - Hardware 2 02-14-2003 12:15 PM


All times are GMT -5. The time now is 12:37 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration