LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 02-26-2007, 10:24 PM   #1
wyth
LQ Newbie
 
Registered: Jan 2005
Location: Charlottesville, VA
Distribution: Ubuntu
Posts: 16

Rep: Reputation: 0
ATI reconfigure = no X


I'm pretty sure there's an easy answer to this that I'm just not finding, so I'm posting for some aid.

Earlier I tried installing beryl on Kubuntu with the automatic script here. Didn't work. So I tried to remove beryl. I'm not even certain my donkey of a machine can run it. But when I did remove it, I couldn't get X windows again. It would always boot to a tty1 screen.

Did a dpkg-reconfigrere xserver-xorg, and when I chose ati, I can get back in. But when I try to configure the fglrx drivers, I end up back at the tty1 screen. (sudo aticonfig --initial, sudo aticonfig --overlay-type=Xv; did do sudo depmod -a, did disable Composite in xorg.conf.)

- lspci -n | grep 0300 gets me 01:00.0 0300: 1002:4c66 (rev 01)
- lspci | grep VGA gets me 01:00.0 VGA compatible controller: ATI Technologies Inc Radeon R250 Lf [FireGL 9000] (rev 01)
- kernel is 2.6.17-11-generic

I can offer any more info as needed. There has to be an answer to this; when I configure the ATI drivers, I lose X. This never happened until I removed Beryl. If I have to go back to beryl, that's fine, because it wasn't running anyway. But at least I had my nice desktop that didn't degrade. What do I need to reconfigure/fix so I can have X back and video card drivers that work? These fuzzy screens are getting on my nerves.

Help anyone?
 
Old 02-27-2007, 01:13 PM   #2
wyth
LQ Newbie
 
Registered: Jan 2005
Location: Charlottesville, VA
Distribution: Ubuntu
Posts: 16

Original Poster
Rep: Reputation: 0
Bumping this, cuz I need to get this fixed. Been a problem for a couple days now.
 
Old 03-03-2007, 10:24 AM   #3
wyth
LQ Newbie
 
Registered: Jan 2005
Location: Charlottesville, VA
Distribution: Ubuntu
Posts: 16

Original Poster
Rep: Reputation: 0
Ach, no reply.

No matter.

I'm not quite sure how it happened, but this thing has sorted itself out. All's I can say is that eventually I had an update with a new ATI driver and a new xorg, and after that I gave the standard ATI configuration another try. This time it took. For the first time in a work week I have a properly-working X Windows system.

But I'm still interested in Beryl...
 
  


Reply

Tags
ati, beryl, windows, xorg


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
reconfigure xserver alaios Fedora 7 08-25-2005 04:01 PM
How to Reconfigure CPAN amer_58 Linux - Newbie 1 04-19-2005 06:47 AM
How do I reconfigure Freeswan? Oxyacetylene Debian 2 02-10-2005 09:54 AM
Can't reconfigure Grub mikieboy Linux - Newbie 2 05-19-2004 06:03 PM
kernel reconfigure apax Linux - Software 2 11-04-2003 03:39 PM


All times are GMT -5. The time now is 07:01 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration