LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 01-22-2006, 04:17 PM   #1
Kavon89
LQ Newbie
 
Registered: Sep 2005
Location: Pennsylvania
Distribution: Knoppix (Live CD), Xubuntu (Live CD & PPC)
Posts: 26

Rep: Reputation: 15
ATI Radeon x300 Driver Problems


hi, i just installed Linux Mandrake 10.1 and noticed it has issues with my X300 PCIxpress 16x card. when installing and trying to config it, it kept telling me that it wasn't responding, and now that it has rebooted, it goes to the black and white mode. it asks me to log in but i dunno how do log in like that either! i noticed on the ATI site that they had the Xfree86 thing, i have no idea how to use it or install it via a console.

please give me a link to a place to download the right driver, then tell me how to tell mandrake in console to install the file from a CD drive.

Thanks in Advance

Last edited by Kavon89; 01-22-2006 at 09:59 PM.
 
Old 01-23-2006, 11:16 AM   #2
webterractive
Member
 
Registered: Apr 2004
Location: Richmond, Canada
Distribution: Mandriva 2006/XPSP2
Posts: 265

Rep: Reputation: 30
Don't bother with ATI just use XFree86 drivers cause they're are a piece of shit on both Linux and Windows. I went back to Windows to use my 9600 AIW and after installing the ATI drivers for XP SP2 the computer turned off twice on its own, after reading the error logs it was the ATI drivers. They cater mostly to Apple, and Microsoft. For Linux/Unix they have some company that sells drivers for certain cards and kernels, I just wouldn't bother. The best solution is to purchase and Nvidia Card next time, Nvidia works pretty well with opensource.

I regret that my Nvidia GForce4 Mx 440 SE busted, I should have just bought another one it was only $40.00, but this 9600 AIW was only $99.00 on sale so I bit into the bait and now I'm regreting it.

Further more, if you are using PCI Express you should use Kernel 2.6.15 and above, as PCI Express is supported; though still experimental.

Last edited by webterractive; 01-23-2006 at 11:19 AM.
 
Old 01-23-2006, 02:16 PM   #3
Kavon89
LQ Newbie
 
Registered: Sep 2005
Location: Pennsylvania
Distribution: Knoppix (Live CD), Xubuntu (Live CD & PPC)
Posts: 26

Original Poster
Rep: Reputation: 15
Smile

Yeah i kno, im buyin a new system in a few months, im using Nvidia GFX + AGP, no pcixpress till it's solid in linux, i shall never buy ATI's again (cuz i plan to use Linux from now on) here are my qestions:

1. Where can i get that kernel version, i'll take the experemental kernel.

2. How do i install it via a CD drive which i don't know the letter for (i have 2 cd drives, i bet it's either like D, or E, cuz i'll burn it onto a CD-RW (to save a disk) then i gotta log in with the console (which i learned how to do ) then i need the command to tell it to install and ne other instructions, cuz it has never loaded the KDE desktop yet cus its saying my pciXpress card isn't responding prob cuz it's talking to the wrong hub.

Thanks,
The Kavon
 
Old 01-24-2006, 12:04 PM   #4
webterractive
Member
 
Registered: Apr 2004
Location: Richmond, Canada
Distribution: Mandriva 2006/XPSP2
Posts: 265

Rep: Reputation: 30
Kernel Versions

You can download a variety of kernels @ http://www.kernel.org.

I am using 2.6.15.1
 
Old 01-24-2006, 02:09 PM   #5
Kavon89
LQ Newbie
 
Registered: Sep 2005
Location: Pennsylvania
Distribution: Knoppix (Live CD), Xubuntu (Live CD & PPC)
Posts: 26

Original Poster
Rep: Reputation: 15
how should i install it via a CD? whould the command (while in root) be:

Code:
/mnt/cdrom/patch-2.6.15.1.bz2
if so i will do that now and then see if it works after a reboot. thanks for the link
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Mplayer window blank when using TV Out with ATI Radeon X300 card, and DVI montior PirateFSM Linux - Software 2 01-19-2006 09:54 AM
Ati Radeon Mobility X300 Graphics Card Murdock1979 Linux - Hardware 4 01-15-2006 02:24 AM
Cannot start X with ATi Radeon X300 on Slackware 10.1 belga Linux - Hardware 2 07-14-2005 02:18 PM
laptop vid card (ati radeon x300) trying to get hardware accelleratoin going. nkoplm Linux - General 2 06-18-2005 09:51 PM
radeon x300 linux driver edmlo Linux - Hardware 4 03-11-2005 08:10 AM


All times are GMT -5. The time now is 05:31 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration