Register a domain and help support LQ
Go Back > Forums > Linux Forums > Linux - Hardware
User Name
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?


  Search this Thread
Old 03-27-2004, 02:23 PM   #1
LQ Newbie
Registered: Mar 2004
Location: Cleveland, OH
Distribution: Gentoo
Posts: 7

Rep: Reputation: 0
Unhappy ATI Radeon Direct Rendering

I am running a stage 1 install of Gentoo 2004.0 with a standard 2.4.6 kernel. I can't get Direct Rendering to work with my ATI Radeon 8500. I use XFree86 4.3 and I used emerge ati-drivers and ati-drivers-extra.

Kernel settings:
AGPGART - Module
module support for my AMD chipset
no framebuffer
DRM - compiled in (because I can't use emerge xfree-drm with a 2.6.4 kernel?)
ATI radeon support

It looks like the DRIScreenInit fails in my XFree86 log....what does that mean??

I've included my glxinfo, dmesg, and XFree86 log ouputs....
I'm fairly new at this linux stuff....but i've tried EVERYTHING to get DRI working.....

uname -a
Linux evilinside 2.6.4 #1 SMP Sat Mar 27 15:08:24 EST 2004 i686 AMD Athlon(TM) MP 2000+ AuthenticAMD GNU/Linux

dmesg output: www .benchodroff .com/dmesglog
glxinfo output: www .benchodroff .com/glxinfolog
kernel config: www .benchodroff .com/kernelconfig
XFree86 log: www .benchodroff .com/XFree86.0.log

(remove the spaces...thanks)
If you can help me, I'd really appreciate it!


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
No Direct Rendering with Radeon 9700Pro in 6.8.2 Dtsazza Linux - Software 12 12-01-2005 02:22 PM
Direct Rendering (ATI Radeon) xbuzz Linux - Newbie 8 06-03-2005 05:38 PM
Gentoo Ati Radeon 9000 Pro Direct Rendering not working stocks29 Linux - Hardware 9 03-05-2005 03:50 PM
Poor 3d performance with ATI Radeon 7500LE desipte "Direct rendering enabled" tallman Linux - Hardware 5 06-16-2004 11:31 PM
ATI Radeon 9600 pro, Mandrake 10.0, Nforce2 Mobo, no direct rendering :( DarkNebula Linux - Hardware 10 06-01-2004 11:16 AM

All times are GMT -5. The time now is 02:21 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration