LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 08-24-2003, 04:06 PM   #1
joe_blow_22
LQ Newbie
 
Registered: Aug 2003
Posts: 17

Rep: Reputation: 0
Exclamation Ati Radeon 9600


Ok so I seen this posted here before I have red hat 8 with xfree86 4.3.0 with my radeon 9600 pro, I downloaded the drivers from ati and that crazy german snieder somin site the firegl 8700/8800 driver and it does show support for the 9600, so I install the rpm and configure the driver for the system and run the fglrx config program put in all the required info and bang x fails everytime so I have the log file if anyone sees anything that looks bad, I think it mentions the generic vesa drivers a few times that cam in the install. Had to remove some resource memory ranges to fit it in the size limits.


Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/XFree86.0.log", Time: Sun Aug 24 17:27:13 2003
(==) Using config file: "/etc/X11/XF86Config-4"
(==) ServerLayout "Server Layout"
(**) |-->Screen "Screen0" (0)
(**) | |-->Monitor "Monitor0"
(**) | |-->Device "ATI Graphics Adapter"
(**) |-->Input Device "Mouse1"
(**) |-->Input Device "Keyboard1"
(**) Option "AutoRepeat" "500 30"
(**) Option "XkbRules" "xfree86"
(**) XKB: rules: "xfree86"
(**) Option "XkbModel" "pc101"
(**) XKB: model: "pc101"
(**) Option "XkbLayout" "us"
(**) XKB: layout: "us"
(==) Keyboard: CustomKeycode disabled
(**) FontPath set to "/usr/X11R6/lib/X11/fonts/local/,/usr/X11R6/lib/X11/fonts/misc/,/usr/X11R6/lib/X11/fonts/75dpi/:unscaled,/usr/X11R6/lib/X11/fonts/100dpi/:unscaled,/usr/X11R6/lib/X11/fonts/Type1/,/usr/X11R6/lib/X11/fonts/Speedo/,/usr/X11R6/lib/X11/fonts/75dpi/,/usr/X11R6/lib/X11/fonts/100dpi/"
(**) RgbPath set to "/usr/X11R6/lib/X11/rgb"
(==) ModulePath set to "/usr/X11R6/lib/modules"
(--) using VT number 7

(II) Open APM successful
(II) Module ABI versions:
XFree86 ANSI C Emulation: 0.2
XFree86 Video Driver: 0.6
XFree86 XInput driver : 0.4
XFree86 Server Extension : 0.2
XFree86 Font Renderer : 0.4
(II) Loader running on linux
(II) LoadModule: "bitmap"
(II) Loading /usr/X11R6/lib/modules/fonts/libbitmap.a
(II) Module bitmap: vendor="The XFree86 Project"
compiled for 4.3.0, module version = 1.0.0
Module class: XFree86 Font Renderer
ABI class: XFree86 Font Renderer, version 0.4
(II) Loading font Bitmap
(II) LoadModule: "pcidata"
(II) Loading /usr/X11R6/lib/modules/libpcidata.a
(II) Module pcidata: vendor="The XFree86 Project"
compiled for 4.3.0, module version = 1.0.0
ABI class: XFree86 Video Driver, version 0.6
(II) PCI: Probing config type using method 1
(II) PCI: Config type is 1
(II) PCI: stages = 0x03, oldVal1 = 0x00000000, mode1Res1 = 0x80000000
(II) PCI: PCI scan (all values are in hex)
(II) PCI: 00:00:0: chip 1106,3189 card 1043,807f rev 00 class 06,00,00 hdr 00
(II) PCI: 00:01:0: chip 1106,b168 card 0000,0000 rev 00 class 06,04,00 hdr 01
(II) PCI: 00:07:0: chip 1106,3044 card 1106,3044 rev 80 class 0c,00,10 hdr 00
(II) PCI: 00:08:0: chip 105a,3376 card 1043,809e rev 02 class 01,04,00 hdr 00
(II) PCI: 00:09:0: chip 14e4,16a6 card 1043,80a9 rev 02 class 02,00,00 hdr 00
(II) PCI: 00:10:0: chip 1106,3038 card 1043,808c rev 80 class 0c,03,00 hdr 80
(II) PCI: 00:10:1: chip 1106,3038 card 1043,808c rev 80 class 0c,03,00 hdr 80
(II) PCI: 00:10:2: chip 1106,3038 card 1043,808c rev 80 class 0c,03,00 hdr 80
(II) PCI: 00:10:3: chip 1106,3104 card 1043,808c rev 82 class 0c,03,20 hdr 00
(II) PCI: 00:11:0: chip 1106,3177 card 1043,808c rev 00 class 06,01,00 hdr 80
(II) PCI: 00:11:1: chip 1106,0571 card 1043,808c rev 06 class 01,01,8a hdr 00
(II) PCI: 00:11:5: chip 1106,3059 card 1043,8095 rev 50 class 04,01,00 hdr 00
(II) PCI: 01:00:0: chip 1002,4150 card 17ee,0002 rev 00 class 03,00,00 hdr 80
(II) PCI: 01:00:1: chip 1002,4170 card 17ee,0003 rev 00 class 03,80,00 hdr 00
(II) PCI: End of PCI scan
(II) Host-to-PCI bridge:
(II) Bus 0: bridge is at (0:0:0), (0,0,1), BCTRL: 0x0008 (VGA_EN is set)
(II) Bus 0 I/O range:
[0] -1 0 0x00000000 - 0x0000ffff (0x10000) IX[B]
(II) Bus 0 non-prefetchable memory range:
[0] -1 0 0x00000000 - 0xffffffff (0x0) MX[B]
(II) Bus 0 prefetchable memory range:
[0] -1 0 0x00000000 - 0xffffffff (0x0) MX[B]
(II) PCI-to-PCI bridge:
(II) Bus 1: bridge is at (0:1:0), (0,1,1), BCTRL: 0x0008 (VGA_EN is set)
(II) Bus 1 I/O range:
[0] -1 0 0x0000d000 - 0x0000dfff (0x1000) IX[B]
(II) Bus 1 non-prefetchable memory range:
[0] -1 0 0xbe800000 - 0xbfefffff (0x1700000) MX[B]
(II) Bus 1 prefetchable memory range:
[0] -1 0 0xc0000000 - 0xf7ffffff (0x38000000) MX[B]
(II) PCI-to-ISA bridge:
(II) Bus -1: bridge is at (0:17:0), (0,-1,-1), BCTRL: 0x0008 (VGA_EN is set)
(--) PCI:*(1:0:0) ATI Technologies Inc unknown chipset (0x4150) rev 0, Mem @ 0xe0000000/28, 0xbf000000/16, I/O @ 0xd800/8, BIOS @ 0xdffe0000/17
(--) PCI: (1:0:1) ATI Technologies Inc unknown chipset (0x4170) rev 0, Mem @ 0xc0000000/28, 0xbe800000/16
(II) Addressable bus resource ranges are
[0] -1 0 0x00000000 - 0xffffffff (0x0) MX[B]
[1] -1 0 0x00000000 - 0x0000ffff (0x10000) IX[B]
(II) OS-reported resource ranges:
[0] -1 0 0xffe00000 - 0xffffffff (0x200000) MX[B](B)
[6] -1 0 0x00000000 - 0x000000ff (0x100) IX[B]
(II) PCI Memory resource overlap reduced 0xf8000000 from 0xfbffffff to 0xf7ffffff
(II) Active PCI resource ranges:
[0] -1 0 0xbc000000 - 0xbc0000ff (0x100) MX[B]

[17] -1 0 0x0000d800 - 0x0000d8ff (0x100) IX[B](B)
(II) Inactive PCI resource ranges:
[0] -1 0 0xbe800000 - 0xbe80ffff (0x10000) MX[B](B)
[1] -1 0 0xc0000000 - 0xcfffffff (0x10000000) MX[B](B)
(II) Active PCI resource ranges after removing overlaps:
[0] -1 0 0xbc000000 - 0xbc0000ff (0x100) MX[B]

[17] -1 0 0x0000d800 - 0x0000d8ff (0x100) IX[B](B)
(II) Inactive PCI resource ranges after removing overlaps:
[0] -1 0 0xbe800000 - 0xbe80ffff (0x10000) MX[B](B)
[1] -1 0 0xc0000000 - 0xcfffffff (0x10000000) MX[B](B)
(II) OS-reported resource ranges after removing overlaps with PCI:
[0] -1 0 0xffe00000 - 0xffffffff (0x200000) MX[B](B)
[6] -1 0 0x00000000 - 0x000000ff (0x100) IX[B]
(II) All system resource ranges:
[0] -1 0 0xffe00000 - 0xffffffff (0x200000) MX[B](B)

[26] -1 0 0x0000d800 - 0x0000d8ff (0x100) IX[B](B)
(II) LoadModule: "dbe"
(II) Loading /usr/X11R6/lib/modules/extensions/libdbe.a
(II) Module dbe: vendor="The XFree86 Project"
compiled for 4.3.0, module version = 1.0.0
Module class: XFree86 Server Extension
ABI class: XFree86 Server Extension, version 0.2
(II) Loading extension DOUBLE-BUFFER
(II) LoadModule: "extmod"
(II) Loading /usr/X11R6/lib/modules/extensions/libextmod.a
(II) Module extmod: vendor="The XFree86 Project"
compiled for 4.3.0, module version = 1.0.0
Module class: XFree86 Server Extension
ABI class: XFree86 Server Extension, version 0.2
(II) Loading extension SHAPE
(II) Loading extension MIT-SUNDRY-NONSTANDARD
(II) Loading extension BIG-REQUESTS
(II) Loading extension SYNC
(II) Loading extension MIT-SCREEN-SAVER
(II) Loading extension XC-MISC
(II) Loading extension XFree86-VidModeExtension
(II) Loading extension XFree86-Misc
(II) Loading extension DPMS
(II) Loading extension FontCache
(II) Loading extension TOG-CUP
(II) Loading extension Extended-Visual-Information
(II) Loading extension XVideo
(II) Loading extension XVideo-MotionCompensation
(II) Loading extension X-Resource
(II) LoadModule: "type1"
(II) Loading /usr/X11R6/lib/modules/fonts/libtype1.a
(II) Module type1: vendor="The XFree86 Project"
compiled for 4.3.0, module version = 1.0.2
Module class: XFree86 Font Renderer
ABI class: XFree86 Font Renderer, version 0.4
(II) Loading font Type1
(II) Loading font CID
(II) LoadModule: "freetype"
(II) Loading /usr/X11R6/lib/modules/fonts/libfreetype.a
(II) Module freetype: vendor="The XFree86 Project"
compiled for 4.3.0, module version = 2.0.2
Module class: XFree86 Font Renderer
ABI class: XFree86 Font Renderer, version 0.4
(II) Loading font FreeType
(II) LoadModule: "glx"
(II) Loading /usr/X11R6/lib/modules/extensions/libglx.a
(II) Module glx: vendor="The XFree86 Project"
compiled for 4.3.0, module version = 1.0.0
ABI class: XFree86 Server Extension, version 0.2
(II) Loading sub module "GLcore"
(II) LoadModule: "GLcore"
(II) Loading /usr/X11R6/lib/modules/extensions/libGLcore.a
(II) Module GLcore: vendor="The XFree86 Project"
compiled for 4.3.0, module version = 1.0.0
ABI class: XFree86 Server Extension, version 0.2
(II) Loading extension GLX
(II) LoadModule: "dri"
(II) Loading /usr/X11R6/lib/modules/extensions/libdri.a
(II) Module dri: vendor="The XFree86 Project"
compiled for 4.3.0, module version = 1.0.0
ABI class: XFree86 Server Extension, version 0.2
(II) Loading sub module "drm"
(II) LoadModule: "drm"
(II) Loading /usr/X11R6/lib/modules/linux/libdrm.a
(II) Module drm: vendor="The XFree86 Project"
compiled for 4.3.0, module version = 1.0.0
ABI class: XFree86 Server Extension, version 0.2
(II) Loading extension XFree86-DRI
(II) LoadModule: "fglrx"
(II) Loading /usr/X11R6/lib/modules/drivers/fglrx_drv.o
(II) Module fglrx: vendor="Fire GL - ATI Research GmbH, Germany"
compiled for 4.3.0, module version = 3.2.0
Module class: XFree86 Video Driver
ABI class: XFree86 Video Driver, version 0.6
(II) LoadModule: "mouse"
(II) Loading /usr/X11R6/lib/modules/input/mouse_drv.o
(II) Module mouse: vendor="The XFree86 Project"
compiled for 4.3.0, module version = 1.0.0
Module class: XFree86 XInput Driver
ABI class: XFree86 XInput driver, version 0.4
(II) FireGL8700/8800: Driver for chipset: ATI RV250 Id (R9000),
ATI RV250 Ie (R9000), ATI RV250 If (R9000), ATI RV250 Ig (R9000),
ATI RV250 Ld (M9), ATI RV250 Le (M9), ATI RV250 Lf (M9),
ATI RV250 Lg (M9), ATI RV280 5960 (R9200 PRO), ATI RV280 Ya (R9200),
ATI RV250 5C61 (M9+), ATI RV250 5C63 (M9+), ATI R200 QH (R8500),
ATI R200 QL (R8500), ATI R200 QM (R9100), ATI R200 QT (R8500),
ATI R200 QU (R9100), ATI R200 BB (R8500), ATI RV350 AP (R9600),
ATI RV350 AR (R9600 PRO), ATI RV350 NP (M10), ATI R300 AD (R9500),
ATI R300 AE (R9500), ATI R300 AF (R9500),
ATI R300 AG (Fire GL Z1/X1), ATI R300 ND (R9700 PRO),
ATI R300 NE (R9700/R9500 PRO), ATI R300 NF (R9600 TX),
ATI R300 NG (Fire GL X1), ATI R350 AK (Fire GL unknown),
ATI RV350 AT (Fire GL T2), ATI RV350 AU (Fire GL T2),
ATI RV350 AV (Fire GL T2), ATI RV350 AW (Fire GL T2),
ATI R350 NH (R9800), ATI R350 NK (Fire GL unknown)
(II) Primary Device is: PCI 01:00:0
(WW) fglrx: No matching Device section for instance (BusID PCI:1:0:1) found
(--) Chipset ATI RV350 AP (R9600) found
(II) resource ranges after xf86ClaimFixedResources() call:
[0] -1 0 0xffe00000 - 0xffffffff (0x200000) MX[B](B)

[26] -1 0 0x0000d800 - 0x0000d8ff (0x100) IX[B](B)
(II) fglrx(0): pEnt->device->identifier=0x081e71f8
(II) resource ranges after probing:
[0] -1 0 0xffe00000 - 0xffffffff (0x200000) MX[B](B)
[31] 0 0 0x000003c0 - 0x000003df (0x20) IS[B]
(II) Setting vga for screen 0.
(II) fglrx(0): === [R200PreInit] === begin, [s]
(II) Loading sub module "vgahw"
(II) LoadModule: "vgahw"
(II) Loading /usr/X11R6/lib/modules/libvgahw.a
(II) Module vgahw: vendor="The XFree86 Project"
compiled for 4.3.0, module version = 0.1.0
ABI class: XFree86 Video Driver, version 0.6
(II) fglrx(0): PCI bus 1 card 0 func 0
(**) fglrx(0): Depth 24, (--) framebuffer bpp 32
(II) fglrx(0): Pixel depth = 24 bits stored in 4 bytes (32 bpp pixmaps)
(==) fglrx(0): Default visual is TrueColor
(**) fglrx(0): Option "NoAccel" "no"
(**) fglrx(0): Option "NoDRI" "no"
(**) fglrx(0): Option "Capabilities" "0x00000000"
(**) fglrx(0): Option "GammaCorrectionI" "0x00000000"
(**) fglrx(0): Option "GammaCorrectionII" "0x00000000"
(**) fglrx(0): Option "OpenGLOverlay" "off"
(**) fglrx(0): Option "VideoOverlay" "on"
(**) fglrx(0): Option "DesktopSetup" "0x00000000"
(**) fglrx(0): Option "MonitorLayout" "AUTO, AUTO"
(**) fglrx(0): Option "HSync2" "unspecified"
(**) fglrx(0): Option "VRefresh2" "unspecified"
(**) fglrx(0): Option "ScreenOverlap" "0"
(**) fglrx(0): Option "IgnoreEDID" "off"
(**) fglrx(0): Option "UseInternalAGPGART" "yes"
(**) fglrx(0): Option "Stereo" "off"
(**) fglrx(0): Option "StereoSyncEnable" "1"
(**) fglrx(0): Option "UseFastTLS" "0"
(**) fglrx(0): Option "BlockSignalsOnLock" "on"
(**) fglrx(0): Option "ForceGenericCPU" "no"
(**) fglrx(0): Option "CenterMode" "off"
(**) fglrx(0): Option "FSAAScale" "1"
(**) fglrx(0): Option "NoTV" "yes"
(**) fglrx(0): Option "TVStandard" "NTSC-M"
(**) fglrx(0): Option "TVHSizeAdj" "0"
(**) fglrx(0): Option "TVVSizeAdj" "0"
(**) fglrx(0): Option "TVHPosAdj" "0"
(**) fglrx(0): Option "TVVPosAdj" "0"
(**) fglrx(0): Option "TVHStartAdj" "0"
(**) fglrx(0): Option "TVColorAdj" "0"
(**) fglrx(0): Qbs disabled
(==) fglrx(0): RGB weight 888
(II) fglrx(0): Using 8 bits per RGB (8 bit DAC)
(**) fglrx(0): Gamma Correction for I is 0x00000000
(**) fglrx(0): Gamma Correction for II is 0x00000000
(==) fglrx(0): Buffer Tiling is ON
(II) Loading sub module "int10"
(II) LoadModule: "int10"
(II) Loading /usr/X11R6/lib/modules/linux/libint10.a
(II) Module int10: vendor="The XFree86 Project"
compiled for 4.3.0, module version = 1.0.0
ABI class: XFree86 Video Driver, version 0.6
(II) fglrx(0): initializing int10
(II) fglrx(0): Primary V_BIOS segment is: 0xc000
(--) fglrx(0): Chipset: "ATI RV350 AP (R9600)" (Chipset = 0x4150)
(--) fglrx(0): (PciSubVendor = 0x17ee, PciSubDevice = 0x0002)
(--) fglrx(0): board vendor info: third party grafics adapter - NOT original ATI
(--) fglrx(0): Linear framebuffer (phys) at 0xe0000000
(--) fglrx(0): MMIO registers at 0xbf000000
(--) fglrx(0): ROM-BIOS at 0xdffe0000
(--) fglrx(0): ChipRevID = 0x04
(--) fglrx(0): VideoRAM: 131072 kByte (64-bit SDR SDRAM)
(WW) fglrx(0): board is an unknown third party board, chipset is supported
(II) Loading sub module "ddc"
(II) LoadModule: "ddc"
(II) Loading /usr/X11R6/lib/modules/libddc.a
(II) Module ddc: vendor="The XFree86 Project"
compiled for 4.3.0, module version = 1.0.0
ABI class: XFree86 Video Driver, version 0.6
(II) Loading sub module "i2c"
(II) LoadModule: "i2c"
(II) Loading /usr/X11R6/lib/modules/libi2c.a
(II) Module i2c: vendor="The XFree86 Project"
compiled for 4.3.0, module version = 1.2.0
ABI class: XFree86 Video Driver, version 0.6
(II) fglrx(0): I2C bus "DDC" initialized.
(II) fglrx(0): Connector Layout from BIOS --------
(II) fglrx(0): Connector1: DDCType-3, DACType-0, TMDSType--1, ConnectorType-2
(II) fglrx(0): Connector0: DDCType-2, DACType-1, TMDSType-0, ConnectorType-3
(**) fglrx(0): MonitorLayout Option:
Monitor1--Type AUTO, Monitor2--Type AUTO

(II) fglrx(0): I2C device "DDC:ddc2" registered at address 0xA0.
(II) fglrx(0): I2C device "DDC:ddc2" removed.
(II) fglrx(0): I2C device "DDC:ddc2" registered at address 0xA0.
(II) fglrx(0): I2C device "DDC:ddc2" removed.
(II) fglrx(0): I2C device "DDC:ddc2" registered at address 0xA0.
(II) fglrx(0): I2C device "DDC:ddc2" removed.
(II) fglrx(0): DDC detected on DDCType 2 with Monitor Type 0
(II) fglrx(0): DDC detected on DDCType 3 with Monitor Type 0
(II) fglrx(0): Primary head:
Monitor -- NONE
Connector -- DVI-I
DAC Type -- TVDAC/ExtDAC
TMDS Type -- Internal
DDC Type -- DVI_DDC
(II) fglrx(0): Secondary head:
Monitor -- CRT
Connector -- VGA
DAC Type -- Primary
TMDS Type -- NONE
DDC Type -- VGA_DDC
(II) fglrx(0):
(II) fglrx(0): DesktopSetup 0x0000
(**) fglrx(0): Overlay disabled
(II) fglrx(0): PLL parameters: rf=2700 rd=12 min=20000 max=50000; xclk=29700
(==) fglrx(0): Using gamma correction (1.0, 1.0, 1.0)
(**) fglrx(0): Center Mode is disabled
(==) fglrx(0): TMDS coherent mode is enabled
(II) fglrx(0): Monitor0: Using hsync range of 30.00-95.00 kHz
(II) fglrx(0): Monitor0: Using vrefresh range of 50.00-150.00 Hz
(II) fglrx(0): Clock range: 20.00 to 500.00 MHz
(II) fglrx(0): Not using default mode "320x175" (bad mode clock/interlace/doublescan)
(II) fglrx(0): Not using default mode "320x200" (bad mode clock/interlace/doublescan)
(II) fglrx(0): Not using default mode "360x200" (bad mode clock/interlace/doublescan)
(II) fglrx(0): Not using default mode "320x240" (bad mode clock/interlace/doublescan)
(II) fglrx(0): Not using default mode "320x240" (bad mode clock/interlace/doublescan)
(II) fglrx(0): Not using default mode "320x240" (bad mode clock/interlace/doublescan)
(II) fglrx(0): Not using default mode "320x240" (bad mode clock/interlace/doublescan)
(II) fglrx(0): Not using default mode "400x300" (bad mode clock/interlace/doublescan)
(II) fglrx(0): Not using default mode "1600x1200" (hsync out of range)


(
(II) fglrx(0): Not using default mode "720x400" (width too large for virtual size)
(--) fglrx(0): Virtual size is 640x480 (pitch 640)
(**) fglrx(0): *Default mode "640x480": 74.2 MHz, 85.9 kHz, 85.1 Hz (D)
(II) fglrx(0): Modeline "640x480" 74.25 640 672 752 864 480 480 482 505 doublescan +hsync +vsync
(**) fglrx(0): Default mode "640x480": 36.0 MHz, 43.3 kHz, 85.0 Hz
(II) fglrx(0): Modeline "640x480" 36.00 640 696 752 832 480 481 484 509 -hsync -vsync
(**) fglrx(0): Default mode "640x480": 31.5 MHz, 37.5 kHz, 75.0 Hz
(II) fglrx(0): Modeline "640x480" 31.50 640 656 720 840 480 481 484 500 -hsync -vsync
(**) fglrx(0): Default mode "640x480": 31.5 MHz, 37.9 kHz, 72.8 Hz
(II) fglrx(0): Modeline "640x480" 31.50 640 664 704 832 480 489 491 520 -hsync -vsync

(**) fglrx(0): Default mode "640x350": 31.5 MHz, 37.9 kHz, 85.1 Hz

(**) fglrx(0): Default mode "512x384": 37.5 MHz, 56.5 kHz, 70.1 Hz (D)
(II) fglrx(0): Modeline "512x384" 37.50 512 524 592 664 384 385 388 403 doublescan -hsync -vsync
(**) fglrx(0): Default mode "512x384": 32.5 MHz, 48.4 kHz, 60.0 Hz (D)
(II) fglrx(0): Modeline "512x384" 32.50 512 524 592 672 384 385 388 403 doublescan -hsync -vsync
(
(==) fglrx(0): DPI set to (75, 75)
(II) Loading sub module "fb"
(II) LoadModule: "fb"
(II) Loading /usr/X11R6/lib/modules/libfb.a
(II) Module fb: vendor="The XFree86 Project"
compiled for 4.3.0, module version = 1.0.0
ABI class: XFree86 ANSI C Emulation, version 0.2
(II) Loading sub module "ramdac"
(II) LoadModule: "ramdac"
(II) Loading /usr/X11R6/lib/modules/libramdac.a
(II) Module ramdac: vendor="The XFree86 Project"
compiled for 4.3.0, module version = 0.1.0
ABI class: XFree86 Video Driver, version 0.6
(**) fglrx(0): NoAccel = NO
(II) Loading sub module "xaa"
(II) LoadModule: "xaa"
(II) Loading /usr/X11R6/lib/modules/libxaa.a
(II) Module xaa: vendor="The XFree86 Project"
compiled for 4.3.0, module version = 1.1.0
ABI class: XFree86 Video Driver, version 0.6
(**) fglrx(0): FSAAScale=1
(**) fglrx(0): NoDRI = NO
(II) Loading sub module "fglrxdrm"
(II) LoadModule: "fglrxdrm"
(II) Loading /usr/X11R6/lib/modules/linux/libfglrxdrm.a
(II) Module fglrxdrm: vendor="Fire GL - ATI Research GmbH, Germany"
compiled for 4.3.0, module version = 3.2.0
ABI class: XFree86 Server Extension, version 0.2
(II) fglrx(0): Depth moves disabled by default
(**) fglrx(0): Capabilities: 0x00000000
(**) fglrx(0): cpuFlags: 0x4000000f
(**) fglrx(0): cpuSpeedMHz: 0x000005fd
(==) fglrx(0): OpenGL ClientDriverName: "fglrx_dri.so"
(**) fglrx(0): using built in AGPGART module: yes
(**) fglrx(0): UseFastTLS=0
(**) fglrx(0): BlockSignalsOnLock=1
(==) fglrx(0): EnablePrivateBackZ = NO
(II) fglrx(0): using CAIL version [ATI LIB=CAIL.LIB,IA32,2.0024]
(--) Depth 24 pixmap format is 32 bpp
(II) do I need RAC? No, I don't.
(II) resource ranges after preInit:
[0] 0 0 0xbf000000 - 0xbf00ffff (0x10000) MX[B]

[34] 0 0 0x000003c0 - 0x000003df (0x20) IS[B]
(II) fglrx(0): UMM area: 0xe032c000 (size=0x07cd4000)
(II) fglrx(0): driver needs XFree86 version: 4.3.x
(II) fglrx(0): detected XFree86 version: 4.3.0
(II) Loading extension ATIFGLRXDRI
(II) fglrx(0): doing DRIScreenInit
drmOpenDevice: minor is 0
drmOpenDevice: node name is /dev/dri/card0
drmOpenDevice: open result is 7, (OK)
drmOpenDevice: minor is 0
drmOpenDevice: node name is /dev/dri/card0
drmOpenDevice: open result is 7, (OK)
drmOpenDevice: minor is 0
drmOpenDevice: node name is /dev/dri/card0
drmOpenDevice: open result is 7, (OK)
drmGetBusid returned ''
(II) fglrx(0): [drm] created "fglrx" driver at busid "PCI:1:0:0"
(II) fglrx(0): [drm] added 8192 byte SAREA at 0xf0a18000
(II) fglrx(0): [drm] mapped SAREA 0xf0a18000 to 0x400cf000
(II) fglrx(0): [drm] framebuffer handle = 0xe0000000
(II) fglrx(0): [drm] added 1 reserved context for kernel
(II) fglrx(0): DRIScreenInit done
(II) fglrx(0): Kernel Module Version Information:
(II) fglrx(0): Name: fglrx
(II) fglrx(0): Version: 3.2.0
(II) fglrx(0): Date: Jul 10 2003
(II) fglrx(0): Desc: ATI Fire GL DRM kernel module
(II) fglrx(0): Kernel Module version matches driver.
(II) fglrx(0): Kernel Module Build Time Information:
(II) fglrx(0): Build-Kernel UTS_RELEASE: 2.4.20-20.8
(II) fglrx(0): Build-Kernel MODVERSIONS: yes
(II) fglrx(0): Build-Kernel __SMP__: no
(II) fglrx(0): Build-Kernel PAGE_SIZE: 0x1000
(II) fglrx(0): [drm] register handle = 0xbf000000
(EE) fglrx(0): [agp] unable to acquire AGP, error "xf86_ENODEV"
(EE) fglrx(0): cannot init AGP

*** If unresolved symbols were reported above, they might not
*** be the reason for the server aborting.

Fatal server error:
Caught signal 11. Server aborting


When reporting a problem related to a server crash, please send
the full server output, not just the last messages.
This can be found in the log file "/var/log/XFree86.0.log".
Please report problems to xfree86@xfree86.org.
 
Old 08-24-2003, 09:51 PM   #2
TMMO
LQ Newbie
 
Registered: Aug 2003
Location: South Africa
Distribution: Red Hat 9
Posts: 8

Rep: Reputation: 0
Hey I get the exact same error, but I have a Radeon 9200 on Mandrake 9.1 X version 4.3.0.

Would like to hear from u guys!!!

HELP!!

haha

Cheers
 
Old 08-25-2003, 01:44 AM   #3
joe_blow_22
LQ Newbie
 
Registered: Aug 2003
Posts: 17

Original Poster
Rep: Reputation: 0
Ati Radeon 9600

Mind you there is an ati generic and ati radeon generic driver listed with xfree86 when you run the config but picking them makes the x server crash at no matter wat resolution wats up with that. I would just like to pull a half decent resolution and refresh rate.
 
Old 08-25-2003, 09:10 AM   #4
EyesOnly
Member
 
Registered: Aug 2003
Location: The Netherlands
Distribution: SlackWare
Posts: 202

Rep: Reputation: 30
I had the same error, He cannot load the AGP module.

In my case I had just compiled a custom kernel, and didn't include AGP.

Type lsmod, and check wheter agpgart is listed. If not, you will have to load this module.
 
Old 08-25-2003, 02:38 PM   #5
makai_wi
Member
 
Registered: Nov 2002
Location: Thiensville, WI, USA
Distribution: RedHat Linux 9
Posts: 85

Rep: Reputation: 15
you can also use the internal agpgart module that came with your driver, I believe the xf86config option is "UseInternalAGPGART" "yes", if you use the firegl config program the option is in their and all you have to do is change it from no to yes.

Last edited by makai_wi; 08-25-2003 at 02:47 PM.
 
Old 08-26-2003, 10:41 PM   #6
joe_blow_22
LQ Newbie
 
Registered: Aug 2003
Posts: 17

Original Poster
Rep: Reputation: 0
Ati Radeon 9600

Well tried that and it still failed but the key being is it does still got this in the log file

(EE) fglrx(0): [agp] unable to acquire AGP, error "xf86_ENODEV"
(EE) fglrx(0): cannot init AGP

so this must be the root of the problem (no pun) lol I found my own agpgart.0 in the /lib/modules/2.4.20-20.8/kernel/drivers/char/agp
directory but not sure if it was put there by the driver or not, is there a way to test this or install it properly?
 
Old 08-26-2003, 11:52 PM   #7
TMMO
LQ Newbie
 
Registered: Aug 2003
Location: South Africa
Distribution: Red Hat 9
Posts: 8

Rep: Reputation: 0
OK I am a newbie so I dont know what I'm talking about, but give this a try...

after u have run fglrxconfig type this

/sbin/insmod agpgart agp_try_unsupported=1

might work

 
Old 08-28-2003, 11:35 PM   #8
joe_blow_22
LQ Newbie
 
Registered: Aug 2003
Posts: 17

Original Poster
Rep: Reputation: 0
ati radeon 9600

Figured it out, when it says cannot initialize agp, or cannot get aperature size it is because of the chipset, I am using the kt400 chipset from via and it is not using a proper driver for it so it does not read it as agp so I have to update the kernel. I tried 2.6 and 2.5 but there were more problems kernal panic and such but I am just doing sumin wrong.
 
Old 11-03-2003, 05:43 PM   #9
membrax
Member
 
Registered: Nov 2002
Location: 50'48''N - 4'21''E
Distribution: SuSE7.1 - SuSE8.1 - SuSE8.2 - RH6.2 - RH7.1 - RH7.3 - RH8.0 - RH9.0 - Fedora Core 1
Posts: 281

Rep: Reputation: 30
In /etc/modules.conf just add (as root) :

options agpgart agp_try_unsupported=1


(Assuming that agpgart is loaded, obviously).
Try "modprobe agpgart" to see that.


Should run fine then.
Cheers !
 
Old 12-07-2003, 10:23 PM   #10
Elizma1955
LQ Newbie
 
Registered: Dec 2003
Location: Midwest USA
Distribution: Mandrake 9.2
Posts: 14

Rep: Reputation: 0
hi how did you fix this

if you go to this post you notice i have no screen and can't start x as it doesn't recognize my ati 9600pro either! and i'm extremely new
http://www.linuxquestions.org/questions/showthread.php?s=&threadid=123360&perpage=15&pagenumber=1

I'm hoping you found a solution! Thanks so much in advance if you did!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
ATI Radeon 9600 SE mlerch Linux - Newbie 2 09-19-2005 10:27 PM
ATI Radeon 9600 Nightmare Linux - Hardware 5 02-26-2005 01:38 AM
ATI Radeon 9600 SE Adrohak Linux - Hardware 24 08-08-2004 04:04 AM
ATI Radeon 9600 XT jgold03 Linux - Hardware 2 05-23-2004 12:07 PM
ATI Radeon 9600 TV-Out? siberian_laika Linux - Hardware 1 12-09-2003 09:17 AM


All times are GMT -5. The time now is 03:33 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration