LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (http://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   ATI Radeon 9200 with 2 ports... problems (http://www.linuxquestions.org/questions/linux-hardware-18/ati-radeon-9200-with-2-ports-problems-240893/)

qodenet 10-10-2004 06:10 AM

ATI Radeon 9200 with 2 ports.. problems.. STILL OPEN! PLEASE HELP QUICKLY!
 
I just installed SuSE 9.1, when I installed it, I noticed extremely bad lag time with the graphics.. Its so slow.. I have to type this in windows.. just to be able to read what I am typing... the video card is a ATI Radeon 9200 with 128 mb ram.. and works great in windows.

Its a PCI card.. and wont pick up in linux... thats the problem. :) It wont even let me change the resolution or refresh rate of my monitor.. which sucks.

I found that the drivers cause problems in 9.1, and I tried them in 9.0.. and it didnt work..

I am a complete :newbie: , so if you can possible explain your help.. that would be wonderful!

Thanks

BedriddenTech 10-10-2004 07:05 AM

Ok, so, Shell access works? If yes, try to login as root and post your X config file, here; it's usually found in /etc/X11, named "xorg.conf" or "XF86Config-4", or something similar.

qodenet 10-10-2004 07:59 AM

Here it is... thanks for any help in advance!

Code:

# generic XFree86 4.x configuration file

Section "Files"
  FontPath        "/usr/X11R6/lib/X11/fonts/truetype/"
  FontPath        "/usr/X11R6/lib/X11/fonts/URW/"
  FontPath        "/usr/X11R6/lib/X11/fonts/uni/"
  FontPath        "/usr/X11R6/lib/X11/fonts/misc/"
  ModulePath        "/usr/X11R6/lib/modules"
  RgbPath        "/usr/X11R6/lib/X11/rgb"
  InputDevices        "/dev/ttyS0"
  InputDevices        "/dev/ttyS1"
  InputDevices        "/dev/ttyS2"
  InputDevices        "/dev/ttyS3"
  InputDevices        "/dev/ttyS4"
  InputDevices        "/dev/ttyS5"
  InputDevices        "/dev/ttyS6"
  InputDevices        "/dev/ttyS7"
  InputDevices        "/dev/ttyS8"
  InputDevices        "/dev/psaux"
  InputDevices        "/dev/logibm"
  InputDevices        "/dev/sunmouse"
  InputDevices        "/dev/atibm"
  InputDevices        "/dev/amigamouse"
  InputDevices        "/dev/atarimouse"
  InputDevices        "/dev/inportbm"
  InputDevices        "/dev/gpmdata"
  InputDevices        "/dev/usbmouse"
  InputDevices        "/dev/adbmouse"
  InputDevices        "/dev/input/mice"
  InputDevices        "/dev/input/event0"
EndSection

Section "ServerFlags"
  Option        "AllowMouseOpenFail"
  Option        "BlankTime"        "0"
EndSection

Section "Module"
  Load                "dbe"
  Load                "extmod"
  Load                "glx"
  # extensions
EndSection

Section "InputDevice"
  Driver        "keyboard"
  Identifier        "Keyboard[0]"
  Option        "Protocol"        "Standard"
  Option        "XkbRules"        "xfree86"
  Option        "XkbKeycodes"        "xfree86"
  Option        "XkbModel"        "pc105"
  Option        "XkbLayout"        "de"
  Option        "XkbVariant"        "nodeadkeys"
EndSection

Section "InputDevice"
  Driver    "mouse"
  Identifier "Mouse[1]"
  Option    "Protocol" "Auto"
  Option    "Device"  "/dev/mouse"
EndSection

Section "Monitor"
  HorizSync        25-40       
  Identifier        "Monitor[0]"
  ModelName        "Initial"
  VendorName        "Initial"
  VertRefresh        47-75
  UseModes        "Modes[0]"
EndSection

Section "Modes"
  Identifier        "Modes[0]"
  Modeline        "640x480" 31.5  640 656 720 840 480 481 484 500 # 6. Try
  Modeline        "640x480" 31.5  640 680 720 864 480 488 491 521 # 5. Try
  Modeline        "640x480" 28    640 664 760 800 480 491 493 525 # 4. Try
  Modeline        "640x480" 28.32  640 664 760 800 480 491 493 525 # 3. Try
  Modeline        "640x480" 25.18  640 664 760 800 480 491 493 525 # 2. Try
  Modeline        "640x480" 25.175 640 664 760 800 480 491 493 525 # 1. Try
EndSection

# Screen Section for module X support
# -------------------------------------
Section "Screen"
  SubSection "Display"
    Depth        16
    Modes        "640x480"
  EndSubSection
  SubSection "Display"
    Depth        24
    Modes        "640x480"
  EndSubSection
  SubSection "Display"
    Depth        32
    Modes        "640x480"
  EndSubSection
  SubSection "Display"
    Depth        8
    Modes        "640x480"
  EndSubSection
  Device        "Device[0]"
  Identifier        "Screen[0]"
  Monitor        "Monitor[0]"
EndSection

# Screen Section for fbdev support
# ----------------------------------
Section "Screen"
  SubSection "Display"
    Depth        16
    Modes        "default"           
  EndSubSection
  SubSection "Display"
    Depth        15
    Modes        "default"           
  EndSubSection
  SubSection "Display"
    Depth        15
    Modes        "default"           
  EndSubSection
  SubSection "Display"
    Depth        24
    Modes        "default" 
  EndSubSection
  SubSection "Display"
    Depth        32
    Modes        "default" 
  EndSubSection
  SubSection "Display"
    Depth        8
    Modes        "default" 
  EndSubSection
  Device        "Device[fbdev]"
  Identifier        "Screen[fbdev]"
  Monitor        "Monitor[0]"
EndSection

# Screen Section for vga support
# ----------------------------------
Section "Screen"
  SubSection "Display"
    Depth        4
    Modes        "640x480"
  EndSubSection
  Device        "Device[vga]"
  Identifier        "Screen[vga]"
  Monitor        "Monitor[0]"
EndSection

# Screen Section for vesa support
# ----------------------------------
Section "Screen"
  SubSection "Display"
    Depth        16
    Modes        "default"           
  EndSubSection
  SubSection "Display"
    Depth        8
    Modes        "default" 
  EndSubSection
  Device        "Device[vesa]"
  Identifier        "Screen[vesa]"
EndSection

Section "Device"
  Driver        "radeon"
  Identifier        "Device[0]"
  BusID                "1:10:0"
  # device_options
  Option        "sw_cursor"        "on"
EndSection

Section "Device"
  Driver        "fbdev"
  Identifier        "Device[fbdev]"
  BusID                "1:10:0"
  # fbdev_options
  Option        "ShadowFB"        "off"
EndSection

Section "Device"
  Driver        "vga"
  Identifier        "Device[vga]"
  BusID                "1:10:0"
  # vga_options
  Option        "KGAUniversal"
  Option        "VGAClocks"
EndSection

Section "Device"
  Driver        "vesa"
  Identifier        "Device[vesa]"
EndSection

Section "ServerLayout"
  Identifier        "Layout[all]"
  InputDevice        "Keyboard[0]"        "CoreKeyboard"
  InputDevice        "Mouse[1]"        "CorePointer"
  Option        "Xinerama"        "off"
  Screen        "Screen[fbdev]"
EndSection


qodenet 10-10-2004 12:02 PM

anyone? please !? :D

J.W. 10-10-2004 01:33 PM

Per the LQ Rules, please do not bump your own thread until at least 24 hours have elapsed without a reply. Because the LQ membership is global, people in other time zones may not have seen this post yet, and thus it may take some time before a response is received.

http://www.linuxquestions.org/rules.php

qodenet - everyone here at LQ is a volunteer, helping out others in their spare time. I'm sorry if you are encountering difficulty, but you need to be patient and give people in other time zones a chance to see your question. If/when anyone has any helpful advice to offer, they will post it up. -- J.W.

otchie1 10-10-2004 04:29 PM

Your radeon card is listed in the DEVICE section labelled DEVICE[0]. This DEVICS is listed in the SCREEN sectioned labelled SCREEN[0].

But, in the SERVERLAYOUT SECTION you are referencing a SCREEN called SCREEN[FBDEV].

Change that to read
Code:

Screen        "Screen[0]"
At the moment you aren't using the radeon driver, just a fbdev one :-)

otchie1 10-10-2004 04:38 PM

Whilst your in there doing that, modify all those display subsection that currently rattle on about 640 x 480 resolution to be more realistic...try this instead,

Code:

SubSection "Display"
    Depth          16
    Modes          "1024x768" "800x600" "640x480"
EndSubSection

and repeat for all Depths listed.

When X boots, use 'CTRL' + 'ALT' + '+' or '-' to step through screen resolutions or use the Gnome desktop configurator or similar.


All times are GMT -5. The time now is 01:20 PM.