LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
LinkBack Search this Thread
Old 02-23-2009, 04:43 AM   #1
highowl
LQ Newbie
 
Registered: Feb 2009
Posts: 3

Rep: Reputation: 0
ATI Radeon 7000 AGP 64 MB - Xorg 7.4 won't load with 'radeon' driver


Problem: When using the 'radeon' driver in my xorg.conf I get one of 3 problems. The most common one being that it starts to load X, then I get a black screen and the system locks up hard with the only option of a hard-reset. The 2nd most common one is - X loads up to the desktop but upon pressing Ctrl+Alt+Backspace to exit, I get a black screen and it locks up again. The 3rd (and this has only happened once) It works fine for a short while but then the graphics tear and it locks up.

Right now the only way I can get it working consistently is by using the 'vesa' driver. Which works fine, but OpenGL has to resort to software rather than hardware acceleration - making it painfully slow.

'X -configure' doesn't provide a working xorg.conf

'xorgconfig' doesn't either if I try to use the 'radeon' driver.

The card is too old for the proprietary ATI drivers.

my xorg.conf is:

Code:
Section "Module"

# This loads the DBE extension module.

    Load        "dbe"  	# Double buffer extension

# This loads the miscellaneous extensions module, and disables
# initialisation of the XFree86-DGA extension within that module.
    SubSection  "extmod"
      Option    "omit xfree86-dga"   # don't initialise the DGA extension
    EndSubSection


# This loads the font modules
#    Load        "type1"
    Load        "freetype"
#    Load        "xtt"

# This loads the GLX module
    Load       "glx"
# This loads the DRI module
    Load       "dri"

EndSection

# **********************************************************************
# Files section.  This allows default font and rgb paths to be set
# **********************************************************************

Section "Files"

# Multiple FontPath entries are allowed (which are concatenated together),
# as well as specifying multiple comma-separated entries in one FontPath
# command (or a combination of both methods)
# 

#    FontPath   "/usr/lib/X11/fonts/misc/"
    FontPath   "/usr/lib/X11/fonts/100dpi/"
    FontPath   "/usr/lib/X11/fonts/TTF/"
    FontPath   "/usr/lib/X11/fonts/OTF"
    FontPath   "/usr/lib/X11/fonts/Type1/"
    FontPath   "/usr/lib/X11/fonts/75dpi/"
#    FontPath   "/usr/lib/X11/fonts/local/"
#    FontPath   "/usr/lib/X11/fonts/TrueType/"
#    FontPath   "/usr/lib/X11/fonts/freefont/"

# The module search path.  The default path is shown here.

#    ModulePath "/usr/lib/modules"

EndSection

# **********************************************************************
# Server flags section.
# **********************************************************************

Section "ServerFlags"

    Option "AllowEmptyInput" "false"

EndSection

# **********************************************************************
# Input devices
# **********************************************************************

# **********************************************************************
# Core keyboard's InputDevice section
# **********************************************************************

Section "InputDevice"

    Identifier	"Keyboard1"
    Driver	"kbd"

    Option "AutoRepeat" "500 30"


    Option "XkbRules"	"xorg"
    Option "XkbModel"	"pc104"
    Option "XkbLayout"	"us"

EndSection


# **********************************************************************
# Core Pointer's InputDevice section
# **********************************************************************

Section "InputDevice"

# Identifier and driver

    Identifier	"Mouse1"
    Driver	"mouse"
    Option "Protocol"    "Auto"	# Auto detect
    Option "Device"      "/dev/input/mice"


# Mouse wheel mapping.  Default is to map vertical wheel to buttons 4 & 5,
# horizontal wheel to buttons 6 & 7.   Change if your mouse has more than
# 3 buttons and you need to map the wheel to different button ids to avoid
# conflicts.

    Option "ZAxisMapping"   "4 5 6 7"

# Emulate3Buttons is an option for 2-button mice
# Emulate3Timeout is the timeout in milliseconds (default is 50ms)

#    Option "Emulate3Buttons"
#    Option "Emulate3Timeout"    "50"

# ChordMiddle is an option for some 3-button Logitech mice

#    Option "ChordMiddle"

EndSection


# **********************************************************************
# Monitor section
# **********************************************************************

# Any number of monitor sections may be present

Section "Monitor"

    Identifier  "NorthGate"

    HorizSync   31-62

    VertRefresh 56-75

EndSection


# **********************************************************************
# Graphics device section
# **********************************************************************

Section "Device"
    Identifier  "ATI Radeon 7000"
    Driver      "vesa"
#    Option "AccelMethod" "XAA"
#    Option "AGPMode" "4"
#    Option "GARTSize" "64"
#    Option "EnablePageFlip" "1"
#    Option "ColorTiling" "1"
    #VideoRam    65536
    # Insert Clocks lines here if appropriate
EndSection


# **********************************************************************
# Screen sections
# **********************************************************************

# Any number of screen sections may be present.  Each describes
# the configuration of a single screen.  A single specific screen section
# may be specified from the X server command line with the "-screen"
# option.
Section "Screen"
    Identifier  "Screen 1"
    Device      "ATI Radeon 7000"
    Monitor     "NorthGate"
    DefaultDepth 24

    Subsection "Display"
        Depth       24
        Modes       "1024x768" "800x600"
#        ViewPort    0 0
    EndSubsection
EndSection

# **********************************************************************
# ServerLayout sections.
# **********************************************************************

# Any number of ServerLayout sections may be present.  Each describes
# the way multiple screens are organised.  A specific ServerLayout
# section may be specified from the X server command line with the
# "-layout" option.  In the absence of this, the first section is used.
# When now ServerLayout section is present, the first Screen section
# is used alone.

Section "ServerLayout"

# The Identifier line must be present
    Identifier  "Simple Layout"

# Each Screen line specifies a Screen section name, and optionally
# the relative position of other screens.  The four names after
# primary screen name are the screens to the top, bottom, left and right
# of the primary screen.  In this example, screen 2 is located to the
# right of screen 1.

    Screen "Screen 1"

# Each InputDevice line specifies an InputDevice section name and
# optionally some options to specify the way the device is to be
# used.  Those options include "CorePointer", "CoreKeyboard" and
# "SendCoreEvents".

    InputDevice "Mouse1" "CorePointer"
    InputDevice "Keyboard1" "CoreKeyboard"

EndSection

Section "DRI"
    group "video"
    Mode 0666
EndSection
I removed alot of the extra garbage that was in there to save space.

If anyone has any suggestions i'd be glad to hear them.

For the record I'm using Xorg 7.4 and Mesa 7.2

Monitor is a 15" Northgate Innovations EZX15G (though i seriously doubt the monitor is to blame for this)

/var/log/Xorg.0.log doesn't update when the computer locks up so no hints there....and no problems are seen when it actually boots up with 'vesa'
 
Old 02-23-2009, 09:08 AM   #2
jdkaye
Senior Member
 
Registered: Dec 2008
Location: Westgate-on-Sea, Kent, UK
Distribution: Debian Testing Amd64
Posts: 4,024

Rep: Reputation: Disabled
1. What distro are you using?
2. Have you installed the various xserver-xorg-video packages?
3. If you have those packages have you tried putting in "ati" in place of "radeon" as the driver name?
Cheers,
jdk
 
Old 02-23-2009, 09:31 AM   #3
highowl
LQ Newbie
 
Registered: Feb 2009
Posts: 3

Original Poster
Rep: Reputation: 0
1.) Not using a distro. Built everything from scratch. But I've tried many flavors of linux on this machine through the years....Ubuntu, Slackware, Knoppix, Fedora Core...etc. None have 'just worked' with it. So nowadays I just use scratch built linuxes so I can cut-down on all the un-needed bloat. Right now I tri-boot Windows XP, Ubuntu 8.10, and my custom linux. Out of those 3 windows is the only one that can properly use my video card - which is a bummer. Ubuntu 8.10 has a 'forcevesa' option set in the bootloader and xorg uses the 'vesa' driver.

As a side note I also can't boot into linux with my TV hooked up to the composite out on my video card otherwise my monitor goes out-of-sync and my TV looks fine. This happens with every flavor of linux and also when I tried out the Windows 7 beta. (a bit of a pain because I have to unplug the TV from the back of my computer when not booting into windows)



2.) I installed every part of Xorg that was suitable to build on the x86 architecture. (with the modular build @ about 300 different packages....I scripted the whole thing so I wouldn't get carpal tunnel lol) So yeah every part of Xorg including the unneeded windows and apple parts are compiled and installed.



3.) I have actually tried the 'ati' driver even though the 'radeon' driver is specifically for my card. The 'ati' driver pretty much had the same results as 'radeon' with one added side effect which i'll get to in a second. But yeah, 'ati' would either give me the black screen lock up on starting X, leaving X. Or - 2 times it actually let me ctrl+alt+backspace without crashing it left me at the prompt but it left this strange side effect. I normally have my $PS1 and $PS2 env. variables set to red for root and green for normal users. After exiting X successfully with the 'ati' driver my $PS1 and $PS2 variables were set to strange colors.....what was once green was a dark but still readable gray and I don't remember what color root's prompt turned but you get the point. Some other things were strange colors too...I think probably the colors of things listed with 'ls' but I can't remember. Though I do remember whatever I typed still came up white as normal. But yeah a bit strange eh?


One more thing I figured I may want to include is that I'm running kernel version 2.6.28.5 - had the same issues with the 2.6.27.x kernel and yes I do have the proper AGP chipset drivers for my mobo. compiled into the kernel. 'dmesg' also reported nothing out of the ordinary.


In the past...(haven't used linux since 2.6.26.x kernels) the radeon driver would always load (usually never a crash - if anything just an out-of-sync monitor) It seems that xorg crashes really easily nowadays...or is that just me? I'm thinking the kernel might be playing a part in this too so if there's any suggestions as to what I might want to make sure IS and IS NOT compiled into the kernel - please let me know.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Xorg won't start on ATI Radeon 7000 (PCI) szim90 Linux - Hardware 5 03-29-2007 11:18 PM
Trouble with ati radeon 7000 VE agp in Mepis Uncle Buggerson Linux - Hardware 2 01-31-2006 01:32 PM
ATI Radeon Mobility 7000 - where's the driver? sarysa Linux - Laptop and Netbook 0 09-07-2005 09:17 AM
TV-Out and Xorg with ATI Radeon 7000/VE khermans Linux - Software 3 06-16-2005 01:12 PM
xorg, can't enable direct rendering, logfile doesn't update Radeon 7000 AGP slackwarefan Linux - Software 0 04-11-2005 10:34 PM


All times are GMT -5. The time now is 07:11 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration